IRC channel logs

2015-10-01.log

back to list of logs

<codemac>bash completion files -- pulseaudio 7.0 can't build because DESTDIR && bashcompletiondir are not set when running with gnu-build-system. Any suggestions into where I should be looking?
<civodul>Hello Guix!
<civodul>mailing lists are back up!
<rekado>one thing that annoys me a little is that bash completion seems to be broken when hitting TAB after "guix environment -l". Just stalls. Did anyone else notice this behaviour?
<amz3>héllo :)
<civodul>paroneayea: how was your talk show yesterday? :-)
<davexunit>civodul: https://identi.ca/cwebber/note/aSrCQ1JqQbKSb9uaa8L5AA
<rekado>paroneayea: do you plan to attend FOSDEM 2015? If so, maybe you could give the talk there in place of "a friendly introduction to Guile/Guix".
<civodul>davexunit: thanks, that sounds encouraging!
<amz3>\\o/ new nixos release
<amz3>oops, wrong channel
<amz3>;)
<civodul>heheh :-)
<civodul>next time you'll be banned ;-)
<iyzsong>lol
<civodul>it's nice to provide the release notes on the web site: http://nixos.org/nixos/manual/release-notes.html#sec-release-15.09
<civodul>we should do the same
<civodul>probably by converting NEWS to HTML with Org
<davexunit>wow, lots of new stuff for nixos.
<davexunit>I wish we had as many system services
<rekado>"newly packaged TeX Live 2015 is provided in pkgs.texlive, split into 6500 nix packages"
<rekado>nice
<davexunit>6500!!!
<civodul>oh!
<civodul> https://github.com/NixOS/nixpkgs/blob/release-15.09/pkgs/tools/typesetting/tex/texlive-new/pkgs.nix
<davexunit>holy cow
<kristofer>good morning! is it possible to tinker with guix in a live usb environment?
<rekado>kristofer: depends on what you mean with "tinker".
<rekado>there's a USB image with which you can boot into a rather boring minimal GuixSD system.
<orly_owl>whats does guix use for package management
<rekado>orly_owl: GuixSD uses Guix for package management.
<rekado>Guix is the package manager, GuixSD (Guix System Distribution) is the GNU system built around this package manager.
<civodul>rekado: https://github.com/NixOS/nixpkgs/blob/release-15.09/pkgs/tools/typesetting/tex/texlive-new/default.nix explains how to use it, not trivial
<civodul>rekado: the package info comes from http://ftp.math.utah.edu/pub/texlive/tlnet/tlpkg/texlive.tlpdb
<orly_owl>hmm
<rekado>civodul: I've seen things like this repeatedly in Nix. To provide packages they seem to "go meta" much more often than Guix.
<kristofer>rekado: I'm aware of guixsd. I can't install it on the host machine. is it possible to install packages and work on some code in the liveusb environment?
<rekado>kristofer: you can use Guix as a package manager on top of another GNU system.
<rekado>to work in the liveusb environment sounds painful as it is minimal and does not include the latest development version of Guix.
<iyzsong>I want to add squashfs for compress the live USB(and CD) image, like other distros. the current one is big :)
<kristofer>rekado: I understand. Thanks for the info :)
<rekado>kristofer: you're welcome. Feel free to ask here if you need help getting started.
<rekado>mailing list posts are still delivered with quite some delay.
<Steap>$ export LOL=42
<Steap>$ ./pre-inst-env guix environment --ad-hoc --pure python --exec="echo $LOL"
<Steap>42
<Steap>isn't "pure" supposed to unset environment variables ?
<davexunit>yes, pure unsets them.
<iyzsong>Steap: the $LOL is un-expland by the shell.
<Steap>oh right
<davexunit>ah, yup. that's it.
<Steap>$ python3 -c "import os; print(os.getenv('LOL'))"
<Steap>42
<Steap>still, this works in the guix environment
<davexunit>Steap: for a simpler proof of concept, can you skip the python stuff and just invoke 'env'?
<Steap>davexunit: in which package is it ? :p
<mark_weaver>Steap: coreutils
<mark_weaver>(the same package that has 'ls' and 'cp')
<Steap>oh ok, I have less variables
<mark_weaver>I think it's great that Nix broke up texlive into a bunch of individual packages. Unless I'm missing something, I'd love to see the same in Guix.
<Steap>just TERM, USER etc.
<Steap>so Python is basically doing crap
<mark_weaver>Steap: are you setting LOL=42 in any of your dot files?
<mark_weaver>setting environment variables in .bashrc (or equivalent) is a common error
<mark_weaver>is there an analogous dot file that python loads?
<Steap>oh right
<Steap>I did that in .bashrc
<davexunit>there we go :)
<Steap>the issue is that it is such a common error that everybody does it
<mark_weaver>Steap: better to set environment variables in .bash_profile, which is only loaded from login shells.
<Steap>yeah
<Steap>still, if a user sets environment variables in their .bashrc
<Steap>they won't end up with a "pure" environment
<Steap>though there is not much we can do about that
<mark_weaver>except to warn them that setting environment variables in .bashrc will prevent "guix environment" from working properly.
<mark_weaver>and I believe we do that in the manual
<mark_weaver>yes, we do. see the footnote in section 6.10 (Invoking `guix environment') in the guix manual.
<davexunit>Steap: in the near future, 'guix environment --container' will create pure environments without such issues
<Steap>davexunit: nice
<davexunit>(unless you mount your home directory in the container or something)
<Steap>is it only available in its own branch ?
<davexunit>wip-container
<mark_weaver>davexunit: great stuff!
<davexunit>there's feedback I need to address still.
<davexunit>and i'm far behind on getting it done.
<civodul>rekado: re going meta, i don't think Nix has something equivalent to 'guix import'
<civodul>AFAIK it's more a bunch of isolated scripts that provide this functionality
<civodul>but anyway i agree it's a good strategy
<civodul>mark_weaver: i'm looking into changing libc to search for locales in DIR/2.22
<civodul>but that's surprisingly difficult
<civodul>i'd want to do: (map (cut string-append <> "/2.22") locpath)
<civodul>but that's much trickier here
<civodul>i think in C you basically give up in such situations
<mark_weaver>civodul: heh, yeah, every time I have to write things like that in C, I feel like I'm back in the stone age. I did some of that for xfce4-panel as I recall, and maybe some other packages.
<mark_weaver>but of course it can be done
<paroneayea>civodul: davthe talk went ASTOUNDINGLY well.
<paroneayea>also hi aeva! welcome to #guix :)
<paroneayea>aeva is a good friend of mine and an awesome hac ker
<aeva>^______________^ hi all
<paroneayea>I was surprised to find that the audience generlaly seemed like it had a group consensus that Guix was the right solution
<paroneayea>the talk was long, longer maybe than it should be if I do it again (okay, longer for sure) but I think it did manage to be verrry clear
<mark_weaver>paroneayea: wow, that's great news! :)
<davexunit>paroneayea: oh wow. great to hear.
<aeva>I am really stoked about guix and guixsd after hearing the talk :D
<mark_weaver>\\o/ and welcome, aeva!
<aeva>whereas before I didn't really get why the projects are special
<aeva>^_^
<davexunit>it looks like outreach is effective.
<davexunit>hello aeva!
<aeva>I'm going to be putting together a new install of gnu/whatever soon, and so I'm thinking of trying to use guix for as much as I can :)
<aeva>and try to package things that are missing?
<karhunguixi>Did anyone capture the talk on film? I'd be very interested in watching it.
<aeva>so yeah, it was a good talk :) I think paroneayea should give it a bunch more times at more places
<paroneayea>karl fogel thinks I should start giving the talk at various companies
<paroneayea>since after my talk he thinks guix is totally the right direction but he thinks that what can really push it to the next level is various companies adopting it for their own usage
<paroneayea>he might be right
<Steap>paroneayea: now we just have to find companies willing to use alpha software \\o/
<paroneayea>I think Guix is not a salpha as we say it is; it's certailny a lot less unstable than many of the devops type solutions people throw themelves behind
<Steap>yeah
<Steap>I'd rather use Guix than Docker
<paroneayea>one perosn there was telling me about OStree from GNOME and how it shares some "similar properties"... it does look interesting, but this line right here is a red flag:
<mark_weaver>yeah, "alpha" isn't quite the right word to describe Guix, IMO.
<paroneayea>> Finally, each deployment has its own writable copy of the configuration store /etc. On upgrade, OSTree will perform a basic 3-way diff, and apply any local changes to the new copy, while leaving the old untouched.
<paroneayea>yikes
<davexunit>paroneayea: maybe we can co-talk about Guix at libreplanet. or maybe get mark involved, too. :)
<zacts>oh when is the next libreplanet?
<zacts>I would really like to try to finally make one of those
<mark_weaver>davexunit, paroneayea: I get nervous in front of audiences
<paroneayea>davexunit: I really want to talk about guix at libreplanet. I'm going to talk to Georgia about it while at fsf 30
<paroneayea>davexunit: because I think libreplanet is probably interested in a social angle, but that can be accomplished:
<mark_weaver>and my "people skills" aren't very good in general.
<paroneayea>"How GNU can solve the deployment crisis"
<mark_weaver>but paroneayea is obviously I good speaker, I think it would be great to have him give a talk at libreplanet.
<mark_weaver>s/I good/a good/
<paroneayea>I think we might want a multi-pronged outreach strategy, and I have some ideas towards that
<mark_weaver>I could perhaps be on hand to answer more technical questions about guix internals, if needed.
<paroneayea>I think kfogel's idea of outreach to companies is probably right also: Guix solves some problems that nothing else can right now
<paroneayea>however
<paroneayea>I want to get guixops along a bit and using it personally before I do that I think
<davexunit>mark_weaver: okay. :) wouldn't want to take you out of comfort zone.
<paroneayea>but kfogel knows some people in the google open source offices and thinks I could give talks there.
<davexunit>oh cool :)
<paroneayea>something that would be comparatively easy for me also would be to get on something like FLOSS Weekly
<paroneayea>and other podcasts
<davexunit>if he knows Boston area places... I'm interested in speaking.
<Steap>ACTION might talk about Guix(-tox) next week at Red Hat, though they may not start using it right away :-)
<paroneayea>I have to prepare a lot less for that kind of thing
<paroneayea>and I've done it for mediagoblin
<davexunit>good thing paroneayea is on our side
<mark_weaver>+1 :)
<efraim>i've been thinking about it a bit while reading irc backlog, I heard about guix from phoronix covering the 0.8.0(?) release and then finding out it was based on functional programming
<aeva>+10
<paroneayea>aw shucks
<paroneayea>anyway I am feeling pretty energized
<paroneayea>davexunit: mark_weaver: and I'm looking forward to talking more about this in person!
<mark_weaver>yes, it'll be good to meet you finally!
<paroneayea>this trip was worth it already for the massive confirmation that this is the right direction for me to be expending my energy
<paroneayea>based on audience feedback from that talk
<paroneayea>there were 25 pretty solid people in that audience, and some of them actively invested in other devopsy type solutions
<paroneayea>I expected a lot of pushback, but instead the general reaction seemed to be "this makes sense, when can I start using it"
<paroneayea>mark_weaver: yes I'm really excited to meet you at last!
<mark_weaver>:)
<paroneayea>mark_weaver: you've helped me so much, it would be great to put a face on you in my mind (not that I'm good at remembering faces)
<paroneayea>(I appreciate all that help btw!)
<mark_weaver>paroneayea: glad to help, and obviously my time was well spent in this case (and many others :) your energy, ideas, and enthusiasm are a great addition to our community :)
<paroneayea>ok, I'm dgoing to do a bit of writing. Later, *!
<paroneayea>thanks mark_weaver :)
<mark_weaver>happy hacking!
<mark_weaver>(I'm also rather glad to have played a part in bringing davexunit into our community :)
<davexunit>:)
<davexunit>it all started because I wanted script bullet hell video games using lisp
<davexunit>what a trip
<mark_weaver>:)
***JamesJRH is now known as JRHaigh
***JRHaigh is now known as JRHaigh_
***JRHaigh_ is now known as JamesJRH
<civodul>paroneayea: the feedback you're giving sounds like good news! :-)
<civodul>thanks for spreading the word and communicating your enthusiasm!
<civodul>Steap: that'd be great if you can talk about Guix at RH
<civodul>Steap: BTW we should announce your PyConfFR talk on the site sometime soon i guess?
<Steap>civodul: yeah well
<Steap>Just have to write the blog article
<Steap>the slides
<Steap>and the code
<Steap>:D
<civodul>you're almost done :-)
<karhunguixi>I'm a bit stuck trying to make my own package. I've borrowed the recipe for the "hello" package from the manual and substituted hello with something else. I've added the directory with this file to GUIX_PACKAGE_PATH
<karhunguixi>Should i now be able to build it, or am i doing things wrong? Running "guix build myfile.scm" says "failed to load", "no code for module" and "unknown package"
<davexunit>karhunguixi: you ask guix to build a package given a name, not a file
<davexunit>if your package is named 'foo', and your scheme code is valid, and GUIX_PACKAGE_PATH is setup properly, then 'guix build foo' will build it for you
<karhunguixi>it displays the same message
<Sleep_Walker>check the file using guile first
<karhunguixi>i don't know how to check a file using guile
<davexunit>karhunguixi: could you paste your package module?
<davexunit> http://paste.lisp.org
<alezost>karhunguixi: did you change the module name from (gnu packages base) to (<your module>)
<karhunguixi> http://sprunge.us/hSRR
<karhunguixi>yes
<alezost>karhunguixi: if that directory is placed GUIX_PACKAGE_PATH, then it should be (petter) module
<alezost>*is placed in
<karhunguixi>should i surround petter in parentheses everywhere?
<alezost>karhunguixi: only "(define-module (petter) ..."
<karhunguixi>it didn't change anything for me
<alezost>or alternatively make <smth>/gnu/packages/petter dir and add <smth> to GUIX_PACKAGE_PATH
<alezost>karhunguixi: what is the value of GUIX_PACKAGE_PATH?
<karhunguixi>it's "/home/petter/temp"
<karhunguixi>i'll try with those extra directories
<davexunit>karhunguixi: Guile module names correspond directly to their file names on disk
<davexunit>(gnu packages petter) must be located at gnu/packages/petter.scm
<karhunguixi>i have "/home/petter/temp/gnu/packages/petter.scm" now
<alezost>karhunguixi: wait a second, you also need to add "#:use-module (gnu packages gawk)"
<karhunguixi>then "guix build petter" says "unknown package"
<civodul>karhunguixi: is there a warning before that?
<karhunguixi>no, that's the only line: "guix builld: error: petter: unknown package"
<davexunit>that module will fail to evaluate because 'gawk' is an unbound variable
<alezost>karhunguixi: the module is not correct, add "#:use-module (gnu packages gawk)"
<karhunguixi>i borrowed this: https://gnu.org/software/guix/manual/guix.html#Defining-Packages
<karhunguixi>ok, i'll add
<alezost>it's the old manual
<alezost>ISTR it was fixed
<davexunit>yeah
<karhunguixi>ok, with gawk i get two more messages: "guix build: warning: failed to load '(gnu packages petter)':" and "ERROR: Unbound variable: guix"
<davexunit>next release won't have that error
<karhunguixi>and then "unknown package"
<karhunguixi>oh, i had an extra ) now i just get "unknown package"
<alezost>yeah, it was fixed: <http://git.savannah.gnu.org/cgit/guix.git/commit/?id=a6dcdcac762b0396b529a3794186f31da8779338>
<civodul>and no warning?
<karhunguixi> http://sprunge.us/NYDD
<karhunguixi>no warning
<civodul>karhunguixi: should be: (define-public petter ...)
<civodul>here you defined a procedure instead of a plain object
<karhunguixi>ok, i removed them
<karhunguixi>and it's building :D
<karhunguixi>thanks guys
<civodul>cool :-)
<civodul>rekado: with the mailing list delay, we did a bit of duplicate review work, oops!
<karhunguixi>just in case anyone is interested, i got a presumably network error the first time i tried to install "my" package, http://sprunge.us/hHZC
<alezost>I had this error several times – every time it was solved by "trying again"
<karhunguixi>yeah, for me too. I don't know how rare it is, so i just thought i'd post it.
<lfam>What's the difference between `guix pull` and `guix package -u guix`?
<alezost>lfam: "guix pull" populates "~/.config/guix/latest"; "guix package -u guix" upgrades your profile ("~/.guix-profile/")
<lfam>alezost: thanks
<alezost>np
<karhunguixi>should you run both commands regularly?
<civodul>karhunguixi, alezost: the error is triggered by overload on hydra.gnu.org, but the problematic backtrace itself was fixed in 15d5ca135
<karhunguixi>ok
<alezost>karhunguixi: yes, although I never run neither of them: instead of "guix pull" I use guix git repo directly, and when I need to update the whole profile, I use "guix package --manifest=..."
<karhunguixi>aha
<mark_weaver>karhunguixi: I do the same. highly recommended
<lfam_>mark_weaver: I'm having trouble putting your glibc locales workaround into practice. /run/current-system does not persist across reboots on my Debian system
<mark_weaver>lfam_: ah, I hadn't thought of that.
<mark_weaver>lfam_: I guess you'll need to arrange for it to be created on every boot, sometime after /run is mounted
<mark_weaver>I don't know if /etc/rc.local is run early enough or not.
<mark_weaver>if so, that would be the easiest
<karhunguixi>mark_weaver, ok, i'll consider this later. Currently i think it will be good to get acquainted with the normal approach
<mark_weaver>hydra should be more usable now
<lfam_>mark_weaver: rebooting, then I'll report back
<karhunguixi>hydra seemed to be under heavy load earlier, was something unusual going on?
<mark_weaver>there's a space leak somewhere, and postgresql ends up using a huge amount of memory after a while.
<mark_weaver>I just restarted all the daemons, including postgresql
<karhunguixi>how often do you do this?
<mark_weaver>it depends how much work it's doing, but every few days
<mark_weaver>typically
<mark_weaver>hydra is not yet running GuixSD. it's trisquel plus some selected guix packages.
<mark_weaver>and it's a VM with not enough disk or memory allocated to it to run well.
<karhunguixi>i can chip in if you want more hardware
<mark_weaver>that would be great, it's exactly what we need.
<lfam>mark_weaver: what locale path are you symlinking to? /root/.guix-profile/lib/locale doesn't work because nobody can read it... :P
<karhunguixi>how can i send money? On the donate page it asks for hardware