IRC channel logs

2016-01-07.log

back to list of logs

<zacts>hi guix
<efraim>does anyone want to work on the update to cmake for core-updates?
<civodul>Hello Guix!
<civodul>sneek: later tell alezost i'm getting this upon M-x guix-hydra-latest-builds: http://paste.lisp.org/+6J38
<sneek>Will do.
<efraim>i think our copy of tcl uses a bundled sqlite
<efraim>from their website: Tcl delivers in the pkgs subdirectory a bundled collection of third-party packages built and installed along with Tcl.
<civodul>efraim: ouch, we should remove it
<civodul>we can do it in core-updates
<efraim>I have sqlite about ready to push, just finishing testing it, thats how I noticed it
<efraim>tk has it also
<civodul>good
<jubalh>ACTION did his first guixsd install in a VM this morning :-)
<civodul>\\o/
<civodul>jubalh: did it go well?
<jubalh>yeah finally it did
<jubalh>will play around with it after work. and if i understand more of it i will install it on a laptop
<civodul>cool :-)
<efraim>using offlineimap as my graph visualization, offlineimap -> python2, python2->sqlite&tk&tcl, tk->tcl
<efraim>and I've built to offlineimap, so that's doable
<efraim>tcl doesn't have configure flags to replace the bundled stuff, but a README with the bundled programs says they can just be all taken out and it'll build without them, so I'll try just ripping them out first to see what breaks
<efraim> http://www.tcl.tk/man/tcl8.6/ it looks like we'll lose funcitonality, it might be better to replace bundled versions with our own copies
<efraim>i don't see an obvious way to link to inputs
<efraim>is there a way to see other branches in git without switching to them? in .git/something?
<rekado>what do you mean by "see"?
<rekado>you can show branches with "git branch"
<rekado>and you can show the log for other branches with "git log <branchname>"
<civodul>efraim: in Magit you can press "y"
<civodul>and then unfold the branches
<civodul>very convenient
<efraim>i mean can I look at a patch that I have in a different branch
<civodul>you can always type "git log some-branch", and then "git show some-commit"
<rekado>efraim: if it has been committed in another branch you can take a look at the log for that branch and then ... do as civodul writes.
<rekado>:)
<efraim>yeah, but i;m not an emacs user :\\ (yet)
<efraim>ok, so I'll copy the commit and see it that way
<rekado>"git log my-branch", find the commit hash, then "git show the-hash"
<efraim>so i'll try something like (inputs `(("sqlite" ,(package-source sqlite)))) and (add-after 'unpack 'perform-switcheroo-on-bundled-apps
<efraim>except i'll make it sound more professional :)
<rekado>efraim: can it not be linked against an existing sqlite?
<efraim>I didn't see anything in the configure for it
<rekado>replacing the tarball is of course better than nothing, but it would be nicer if sqlite didn't have to be rebuilt at all.
<efraim>not the flags from configure, but a list of variables from configure: ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS MAN_FLAGS CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC
<efraim> EXEEXT OBJEXT CPP EGREP TCL_THREADS TCLSH_PROG ZLIB_OBJS ZLIB_SRCS ZLIB_INCLUDE RANLIB ac_ct_RANLIB AR ac_ct_AR LIBOBJS TCL_LIBS DL_LIBS DL_OBJS PLAT_OBJS PLAT_SRCS LDAIX_SRC CFLAGS_DEBUG CFLAGS_OPTIMIZE CFLAGS_WARNING LDFLAGS_DEBUG LDFLAGS_OPTIMIZE CC_SEARCH_FLAGS LD_SEARCH_FLAGS STLIB_LD SHLIB_LD TCL_SHLIB_LD_EXTRAS TK_SHLIB_LD_EXTRAS SHLIB_LD_LIBS SHLIB_CFLAGS SHLIB_SUFFIX MAKE_LIB MAKE_STUB_LIB INSTALL_LIB DLL_INSTALL_DIR INSTALL_STUB_LIB
<efraim>CFLAGS_DEFAULT LDFLAGS_DEFAULT DTRACE TCL_VERSION TCL_MAJOR_VERSION TCL_MINOR_VERSION TCL_PATCH_LEVEL TCL_YEAR PKG_CFG_ARGS TCL_LIB_FILE TCL_LIB_FLAG TCL_LIB_SPEC TCL_STUB_LIB_FILE TCL_STUB_LIB_FLAG TCL_STUB_LIB_SPEC TCL_STUB_LIB_PATH TCL_INCLUDE_SPEC TCL_BUILD_STUB_LIB_SPEC TCL_BUILD_STUB_LIB_PATH TCL_SRC_DIR CFG_TCL_SHARED_LIB_SUFFIX CFG_TCL_UNSHARED_LIB_SUFFIX TCL_SHARED_BUILD LD_LIBRARY_PATH_VAR TCL_BUILD_LIB_SPEC TCL_LIB_VERSIONS_OK
<efraim>TCL_SHARED_LIB_SUFFIX TCL_UNSHARED_LIB_SUFFIX TCL_HAS_LONGLONG INSTALL_TZDATA DTRACE_SRC DTRACE_HDR DTRACE_OBJ MAKEFILE_SHELL BUILD_DLTEST TCL_PACKAGE_PATH TCL_MODULE_PATH TCL_LIBRARY PRIVATE_INCLUDE_DIR HTML_DIR PACKAGE_DIR EXTRA_CC_SWITCHES EXTRA_APP_CC_SWITCHES EXTRA_INSTALL EXTRA_INSTALL_BINARIES EXTRA_BUILD_HTML EXTRA_TCLSH_LIBS DLTEST_LD DLTEST_SUFFIX'
<rekado>which version of tcl is this?
<efraim>8.6.4
<efraim>our current version
<efraim>"This is the SQLite extension for Tcl using the Tcl Extension Architecture (TEA)."
<efraim>from the bundled sqlite README
<efraim>I'll see how it goes with just sqlite replaced
<anoopcs>Hi all, I would like to try out GuixSD. So I downloaded ftp://alpha.gnu.org/gnu/guix/guixsd-usb-install-0.9.0.x86_64-linux.xz.
<anoopcs>I would like to boot it from USB. Which file system the USB should be formatted to?
<jubalh>anoopcs: in the manual there are exact instrucitons on this. you need to use dd to put it on the USB stick
<jubalh>all stuff will be gone from the USB stick. and you dont need to worry about the filesystem
<civodul>anoopcs: indeed, see https://www.gnu.org/software/guix/manual/html_node/System-Installation.html
<anoopcs>jubalh, Ok. But I am confused on device number.
<anoopcs>When I mount my USB stick, df -h shows /dev/sdb1 mounted @ some location.
<anoopcs>So I ran dd if=guixsd-usb-install-0.9.0.x86_64 of=/dev/sdb1
<anoopcs>Other than dd being successful, how can I verify whether image was successfully written to USB?
<anoopcs>civodul, Because booting from it (after dd is successful) shows 'No bootable device'.
<anoopcs>By the way, I am trying to boot USB from virt-manager.
<jubalh>anoopcs: i dont know virt-manager, i used qemu alone. this guide helped me: https://github.com/guix-nonfree/pkgs/wiki/qemu-installation
<civodul>efraim: as rekado wrote, i think it's best to remove the bundled sqlite entirely, and to pass --with-system-sqlite or whatever configure flag causes Tcl to use the already-built sqlite
<anoopcs>jubalh, Ok. I will try that and let you know.
<anoopcs>civodul, jubalh : Ooops.. I did something different from what I intended. Now I can run GuixSD from virt-manager.
<anoopcs>Just need to point virt-manager to downloaded image.. that's all.
<d4n1>Hi Guix
<d4n1>I install Gnome-shell in my GuixSD, but there's a error when I try to do login
<d4n1>I add following packages in my config.scm: adwaita-icon-theme, gnome-session, gnome-shell, gnome-control-center, gnome-settings-daemon
<d4n1>P.S.: When try add dbus not compile (guix system reconfigure config.scm)
<d4n1>What do I do? Help me and thanks :)
<civodul>d4n1: could you paste the command you run and its output?
<d4n1>Yes, waith a momment
<d4n1>civodul
<d4n1>This is my config.scm: http://pastebin.com/0Rs546u4
<d4n1>I added in pastebin to not a lot text here (irc)
<d4n1>After that, I did: guix system reconfigure /etc/config.scm
<civodul>d4n1: pastebin.com blocks Tor users; could you use http://paste.lisp.org instead, for example?
<d4n1>Reboot, after that I did login, so it appear a "computer error" (gnome error screen) and return do login screen
<d4n1>ok
***civodul changes topic to 'GNU Guix | http://gnu.org/s/guix/ | 0.9.0 is out! | donations for the build farm are welcome! https://www.fsf.org/blogs/community/fsf-announces-support-for-gnu-guix | avoid pastebin.com, which blocks Tor | channel logged: <https://gnunet.org/bot/log/guix>.'
<d4n1> http://paste.lisp.org/display/304687
<d4n1>My config in paste.lisp: http://paste.lisp.org/display/304687
<d4n1>David was success with Gnome-shell in GuixSD: https://lists.gnu.org/archive/html/guix-devel/2015-12/msg00538.html
<d4n1>But when add dbus in packages there's a error and I can't upower-daemon
<d4n1>Someone here got run gnome-shell in GuixSD? How? Can you send your config.scm to me?
<d4n1>I'm using Enlightenment desktop because I like it, but I like more Gnome-shell because is more beautiful and a GNU project :)
<rekado>"But when add dbus in packages there's a error and I can't upower-daemon" <-- what error do you get? And what do you mean about "upower-daemon"?
<rekado>d4n1: ^
<d4n1>Rekado, visit this link about it https://lists.gnu.org/archive/html/guix-devel/2015-12/msg00538.html
<d4n1>Rekado: Error, the upower service there insn't
<d4n1>The same error with the dbus: Dbus package not exist
<d4n1>Rekado: Do you running gnome-shell in GuixSD? If yes, help me. Do you can show my config.scm in http://paste.lisp.org/display/304687
<civodul>any volunteer to review these cute little Ruby packages? https://lists.gnu.org/archive/html/guix-devel/2015-12/msg00914.html :-)
<rekado>civodul: I'll do it.
<rekado>there's also another one "Add 12 rubygems" that I'll review first. It spawned off the discussion about making ruby packages reproducible, but the actual patches were not reviewed yet.
<rgrau>talking about reviews... I sent some fixes (basically rewording) for xmlstarlet, and I think it's forgotten. :)
<d4n1>When add dbus to (packages (cons * dbus ...) and I try to reconfigure GuixSD (guix system reconfigure) there is a error: /etc/config.scm:8:0: In procedure module-lookup: Unbound variable: dbus
<rekado>d4n1: this means that your config does not load the module containing the package definition for "dbus".
<d4n1>How do I do to add dbus?
<d4n1>Rekado: Do you have example?
<rekado>d4n1: it's defined in the module "(gnu packages glib)" in the file "glib.scm".
<rekado>so you would need to add this module to the list of modules loaded at the top of your config.
<d4n1>Rekado: Thank you! I add "(use-package-modules glib ... )" in top of my config.scm and add dbus to "(packages (cons* dbus ...))" and it's work now! I try again reconfigure my system now and report here. Thank so much.
<civodul>d4n1: dbus is already part of %desktop-services
<civodul>i don't think you need to add it to 'packages'
<civodul>rekado: tgamblin of Spack commented at https://news.ycombinator.com/item?id=10817978
<civodul>i just replied :-)
<rekado>civodul: what do think about giving Ben push access?
<civodul>rekado: sounds like a good idea
<civodul>let's do it?
<rekado>okay
<rekado>(I don't know how :))
<civodul>maybe you can't do it yourself
<civodul>but we need to ask him for his account first, anyway
<civodul>i'll send him an email
<rekado>civodul: thank you!
<d4n1>civodul: Thanks!
<d4n1>I'll reboot my PC, because my GuixSD reconfiguration finished with gnome-shell. I return after it. Thanks guixs
<paroneayea>hello #guix!
<jlicht>mark_weaver: thank you for your help the other day, I found out the reason I had issues compiling guix from the git repo was an issue with my ~/.cache folder. After clearing that, everything worked like it should :)
<civodul>hello, paroneayea!
<civodul>you on the West now? :-)
<paroneayea>civodul: indeed I am!
<paroneayea>working from the "hacker hostel" today
<civodul>nice :-)
<paroneayea>the place is labeled as "hackerspace"
<paroneayea>though I have learned quickly that my definition of hacker and silicon valley's definition is not the same...
<civodul>heheh
<paroneayea>most of the people here seem to be dreaming of something about making it big at some startup
<paroneayea>or starting their own
<civodul>we'll see if that's contagious ;-)
<paroneayea>hah :)
<civodul>in other news, i got the green light from rms to rename dmd to Shepherd
<civodul>(to avoid confusion with the D compiler, as was requested a few months ago)
<paroneayea>civodul: oh excellent!
<paroneayea>less excellent: being forced to do this migration off of linode now :(
<paroneayea>I was hoping to wait to move away until I could get my server running GuixSD somewhere, now it looks like I won't have time
<paroneayea>yarg
<bavier>civodul: I like the name
<civodul>bavier: cool, thanks
<civodul>we discussed it here long ago, i think
<bavier>I was absent for about two weeks over the holidays, so I might have missed it
<civodul>oh i think it was this summer or something, np
<bavier>:P
<civodul>i don't think we'll open a poll or something
<civodul>but i'm happy to hear about those who like it ;-)
<civodul>paroneayea: on packaging web apps: http://lwn.net/SubscriberLink/670566/241f4c8602bbb50a/
<civodul>the important quote is: "Debian and other distributions are going to be that thing you run docker on, little more."
<bavier>that's an unflattering generalization
<civodul>it highlights a cultural gap between traditional distro/OS people and web-app developers
<civodul>we need paroneayea, davexunit, & co. to fill the gap :-)
<paroneayea>:)
<paroneayea>ACTION needs to boot back into guixsd today now that he's semi-settled in and try to dive back into the system clock thing
<jubalh>now that i have guixsd running in a vm i would like to start packaging some applicatoins and when i am more familiar with the system install it on my laptop
<jubalh>what should i know/read to start packaging?
<rekado>jubalh: I suggest reading the manual starting from section "Defining Packages"
<rekado>when you understand that you can just take one existing package expression and modify it.
<rekado>this is best done from a recent git clone.
<rekado>just take an existing module (e.g. gnu/packages/music.scm) and add your package expression there.
<rekado>then test it with "./pre-inst-env guix build my-new-package" from the git repository root.
<rekado>for some packages you can use importers to generate a package expression that requires only little tweaking.
<rekado>if you are an Emacs user, editing Scheme expressions is made simpler with paredit.
<jubalh>alright
<jubalh>hehe
<jubalh>ACTION uses vim
<rekado>here's an animated guide to paredit: http://danmidwood.com/content/2014/11/21/animated-paredit.html
<rekado>maybe there's something like that for vim as well.
<rekado>(although I, as a former vim user, suggest Emacs + evil mode)
<jubalh>I wanted to learn Emacs + evil mode, but didnt start yet. I also thought it would be quite handy
<rekado>ACTION no longer uses evil-mode
<jubalh>:O
<jubalh>why?
<rekado>after I switched to dvorak I could no longer rely on muscle memory for vim shortcuts, so I learned Emacs defaults on dvorak.
<rekado>I also played with god-mode, but I have yet to find a convenient toggle key to switch between modes.
<jubalh>i see
<jlicht>As you are probably already aware, spacemacs contains 1) a nice way of organizing packages and cross-package integrations, as well as some very nice defaults for a vim-refugee: http://spacemacs.org/
<jlicht>it's an emacs configuration that is centered around mnemonic and/or vim-like operation
<civodul>oh! http://lwn.net/Articles/670362/
<Sleep_Walker>nice :)
<jlicht>In that article, they say GuixSD is in beta. On http://www.gnu.org/software/guix/, it still says TEST v0.9.0 (alpha). One of the two seems to be inaccurate ;-)
<civodul>good point, we should switch to "beta"
<lfam_>jubalh: This is the paredit plugin for Vim: http://www.vim.org/scripts/script.php?script_id=3998
<efraim>the paredit plugin gave me problems
<efraim>it wouldnt let me delete parenthesies
<efraim>i don't remember which is which, but i'm using vim-fugitive, vim-airline and vim-indent-guides
<rekado>paredit lets you delete parentheses only when they are empty.
<lfam_>You can always delete them in visual mode. It's quotation marks that give me trouble in vim paredit.
<lfam_>It's a pain to split urls for the (uri)
<rekado>with Emacs paredit it's bound to Meta-S by default.
<efraim>I had to give up on tcl for now, working on zlib for now
<efraim>I didn't think of that, I almost never use visual mode
<efraim>either normal or insert
<cool_guy>hello. the docs seem to lack indication about how to change the default path of the store
<cool_guy>how to get the store in /opt/gnu instead of /gnu/ ?
<cool_guy>thanks
<bavier>cool_guy: use the --with-store-dir configure option
<bavier>cool_guy: note however that using a store dir other that /gnu/store means that you will not be able to download substitutes
<bavier>*than
<cool_guy>ok. problem is that my "/" lies in a pretty small partition and I got a "disk full" error while guix was downloading its stuff.
<bavier>cool_guy: could you mount /gnu/store to another partition?
<cool_guy>well, with some extra work yes, I can
<efraim>i made a separate partition and mounted it as /gnu
<lfam_>Guix on foreign distros DOES require a lot of space. Debian's "guided partitioning" doesn't recommend a very large /
<d4n1>rekado: Gnome-shell work :)
<d4n1>Thanks
<alezost>sneek: later tell civodul `guix-keyword-args-let' macro is placed in "guix-utils.el". My guess is: somehow you load an old version of "guix-utils.el" which does not contain this macro. Perhaps you load some guix.el code (e.g., `global-guix-prettify-mode') before augmenting `load-path' with "~/src/guix/emacs/"
<sneek>Welcome back alezost, you have 1 message.
<sneek>alezost, civodul says: i'm getting this upon M-x guix-hydra-latest-builds: http://paste.lisp.org/+6J38
<sneek>Okay.
***mog_ is now known as mog
<rekado>any ideas where to put the fingerprinting tool Pjotr posted a while ago?
<rekado>I'd like to fix the patch and push it, but I don't know where best to put it.
<rekado>we have so many one-off modules that it's hard to find something similar.
<efraim>I'm sticking connman in wicd when its time
<efraim>fingerprinting is sort of like hashing
<bavier>rekado: the pfff package? could it go in (gnu packages bioinformatics)?
<rekado>I don't think it's anything to do with bioinfo.
<rekado>efraim: note that we also have "networking.scm"
<bavier>just that the paper they ask to cite for its use is a bioinformatics paper
<rekado>true, but I think the connection to bioinfo is a bit too loose to put it there.
<bavier>how about gnu/packages/textutils.scm ?
<bavier>the cityhash package is in there
<rekado>oh, good. I'll put it there.
<rekado>thanks
<bavier>np
<bavier>rekado: glancing over the pfff paper, I'm not sure the authors claim that pfff is useful for general-purpose file hashing
<rekado>that's what I get for trying to clean up a subpar patch :-/ Do you propose moving it to the bioinfo module after all? (I didn't look at the paper; I trusted the description to be accurate).
<bavier>they say it "applies to any data with high variability. This includes, in particular, data that contains noisy measurements, such as scientific data in astronomy or particle physics, as well as sound and video files."
<bavier>so perhaps textutils.scm is fine, with some additional usage clarifications in the description.
<davexunit>ACTION read the chat backlog
<davexunit>that "owncloud and distribution packaging" article was an interesting read
<davexunit>needless to say I got a little irritated at the owncloud guy
<mog>i dont pay for lwn ):
<civodul>davexunit: his comments were made to irritate :-)
<sneek>Welcome back civodul, you have 1 message.
<sneek>civodul, alezost says: `guix-keyword-args-let' macro is placed in "guix-utils.el". My guess is: somehow you load an old version of "guix-utils.el" which does not contain this macro. Perhaps you load some guix.el code (e.g., `global-guix-prettify-mode') before augmenting `load-path' with "~/src/guix/emacs/"
<civodul>alezost: indeed, that's what i did; i figured that out later
<davexunit>civodul: I will probably be using that quote you pulled in my presentation
<civodul>yes, i've saved it for later as well :-)
<davexunit>I want to do a "here's where we're headed" series of slides, show why I think it's very bad, and how Guix brings us back on track.
<civodul>that sounds like a good idea
<civodul>i'd like to try to do something in that vein in the distro track at FOSDEM
<civodul>i guess i'll be preaching to the choir, though
<davexunit>perhaps, but perhaps not
<davexunit>some people see a hybrid approach to be best
<davexunit>and I just see that as giving up and dealing with a mess forever