IRC channel logs

2016-10-05.log

back to list of logs

<ng0>okay, email with patches on lispf4 is out, I'm offline now. thanks for the help in advance.
<asumu>So I tried to download a package's closure from Hydra and install it via "guix archive --import" but was told it lacks a signature. Is there a better way to do this? (trying to install a package to a machine without network access)
<xd1le>how can I save things to the store when running guix commands so that if something fails the stuff from before are still there? I recall this was possible but forgot how.
<xd1le>*if some command fails
<xd1le>when I do guix system reconfigure, I get "guix system: warning: while talking to shepherd: No such file or directory". Any ideas? :(
<xd1le>the system.scm file is basically the same as the barebones one here: https://www.gnu.org/software/guix/manual/guix.html#Using-the-Configuration-System
<xd1le>this might have something to do with it, so I just tried to `sudo halt`, but it said "error: connect: /var/run/shepherd/socket: No such file or directory". When I look into /var/run, I see dmd/socket but no shepherd/socket, so could this be due to the dmd rename to shepherd? (Because I haven't updated in a while.)
<xd1le>Also btw if I logout I'll still read the logs for responses! :)
<xd1le>But yes if it is, then what to do about it? :/
<lfam>xd1le: The transition from DMD to shepherd did have a bug like that. I think there should still be the right halt in '/run/booted-system/profile/sbin'
<xd1le>lfam: thanks! but I've already force shutdown. what to do about guix system reconfigure command though? (if you know)
<lfam>xd1le: If I remember correctly, the bug didn't manifest after rebooting. If not, let us know!
<xd1le>also on that note, how would I search the mailing lists? would I just have to download all the mbox files and grep it or something, or is there another better way?
<xd1le>lfam: ah sweet! let me try it out now!
<lfam>xd1le: I'm not sure how to search all the lists at once without having the mail. Maybe there is a meta-archive you can use
<xd1le>lfam: okay no worries! there are public archives.
<xd1le>lfam: still the same errors. :(
<xd1le>(with both sudk guix system reconfigure and sudo halt)
<lfam>Okay, sounds like some other change has compounded the earlier dmd -> shepherd transition bug
<xd1le>sudo*
<lfam>The reconfigure succeeds?
<xd1le>lfam: nope
<lfam>How about doing `guix system build` instead of `guix system reconfigure`?
<lfam>I'm wondering where exactly it fails
<xd1le>lfam: okay will do. here's a photo btw if it helps anyone at all: https://i.imgur.com/SVkwQc8h.jpg
<xd1le>because I don't know how to upload to paste service
<xd1le>blurry photo
<xd1le>lfam: guix system build worked..
<lfam>xd1le: Somebody else might have a suggestion, but I'm stumped. Since we renamed DMD to shepherd, there have been lots of changes to the code where the backtrace starts (guix/scripts/system.scm). I guess it starts around Git commit 0190c1c02fd
<lfam>You might find some discussion on the mailing lists
<xd1le>lfam: Thanks for your help. I think I might just go for a fresh install then. (I was trying to avoid it because no USB atm to do it with.)
<lfam>I guess if you really wanted to upgrade this system you could try it one release at a time. It looks like you are still using 0.8.3
<xd1le>well I did guix pull on both user and root and I also did guix package --upgrade
<lfam>You might hit some speed bumps with changed URLs, but I'm not sure. It depends on how far back our source code cache goes
<xd1le>but I guess that just does guix and other packages. not the base system itself, hence the errors
<lfam>xd1le: You could try instead reconfiguring from a Git checkout. At least, it would give you some flexibility of which commit you use
<lfam>As root, `guix pull && guix system reconfigure $CONFIG` is the way to upgrade the system.
<xd1le>lfam: yeah that's not really feasible anyway if I can't use the cache because atom processor. :/ But good to know. How does one use a guix from a particular commit, is it documented somewhere?
<lfam>Yes, in section 8 Contributing
<lfam>Particularly 8.1 and 8.2
<xd1le>thanks again. :D
<lfam>I think that upgrading from 0.8.3 to 0.11.0 is uncharted territory :)
<xd1le>hahaha that's quite likely ;)
<rekado>Hi Guix!
<rekado>For those of you who use mu4e to read patch emails: I encourage you to add this to your Emacs config:
<rekado>(require 'mu4e-actions)
<rekado>(add-to-list 'mu4e-view-actions
<rekado> '("git am" . mu4e-action-git-apply-mbox))
<rekado>(add-to-list 'mu4e-headers-actions
<rekado> '("git am" . mu4e-action-git-apply-mbox))
<rekado>Much easier to apply patches from email.
<civodul>Hello Guix!
<Petter>Hello Guik!
<civodul>:-)
<rekado>civodul: GSL fails to build on i686.
<civodul>rekado: bah!
<civodul>i'll look into it, sorry about that
<efraim>Compiler: gcc 4.9.3
<efraim> built by x86_64-unknown-linux-gnu
<efraim> on Sep 29 2016 16:53:48
<efraim>System: Linux 4.6.0-1-amd64 #1 SMP Debian 4.6.4-1 (2016-07-18) x86_64
<efraim>i assume I want to remove "on" and "System", "built by" also?
<civodul>efraim: yes, but not in core-updates, too late for this time :-)
<efraim>its in aria2, so I have time :)
<civodul>aaah, fine
<civodul>i thought it was gcc
***[0xAA] is now known as Zer0Pings
<tinyOwl>hi #guix
<tinyOwl>i was wondering if there's something along the lines of pkgfile for arch-linux in guix
<tinyOwl>ie a way to see which package provides a certain binary or other file
<civodul>tinyOwl: not really
<civodul>to see which packages provide which files, you have to traverse /gnu/store
<civodul>but that doesn't tell you anything about files provided by packages not in your store
<jmd>I often find myself typing "find /gnu/store -name ..."
<tinyOwl>i guess that could work
<tinyOwl>would be nicer if there was a way to get this info about packages not in the store too though
<tinyOwl>ty
<jmd>esp?
<jmd>I suppose hydra could have a feature where one could ask it about packages in its store.
<civodul>yeah, it could build a database that users could choose to use (or not)
<civodul>i occasionally end up looking up files on packages.debian.org actually :-)
<paroneayea>hi everyone
<paroneayea>oof, lots of updates for x.org today
<paroneayea> https://lists.freedesktop.org/archives/xorg/2016-October/058344.html
<jmd>What packages does the guix installer have?
<ng0>rekado: will you remove lispf4 as per my latest reply or should I send a 'delete' patch?
<ng0>I'll send the patch anyway, spare some minutes of your time :)
<civodul>paroneayea: oh, lots of fun :-)
<ng0>all right, delete lipf4 patch is out
<ng0>that should be easy to review :)
<jmd>tzdata contains a dangling link.
<civodul>oh
<ng0>packaging uclibc-ng is one of the things I do, and I just realized it's easier if we do it like I assume what's done for linux-libre - configure it by hand, include the configs in gnu/packages/ in extra files.
<ng0>i suppose there's no opposition if this is the only way to make it work..
<civodul>ng0: though the more is automated and turned into an API, the better
<civodul>this is hard to achieve for linux-libre because of the number of options and overall complexity, but it might be possible for uclibc
<ng0>my long term side quest for now is to make it work at all.. :)
<civodul>sounds reasonable :-)
<ng0>I also think blueness of the Gentoo project is right in assuming that uclibc is dead and -ng is the new upstream.
<ng0>just in case you wonder why ng, and not uclibc
<ng0>I need to change my terminal colors.. looking at the way configure kernel / makeconfig are displayed makes me dizzy.
<wingo>i started on a cups service
<wingo>lmk if someone already did this
<wingo>i realized i should have mentioned this before starting
<ng0>doesn't help all the time :) lfam and myself worked on colorio at the same time while I mentioned it.
<ng0>thanks for starting this :)
<civodul>wingo: would be great! i don't think anyone mentioned working on this
<wingo>i need to print a lot of stuff and am tired of asking someone else to do it for me :P
<civodul>i turns out my partner's laptop on Debian exports its printer, so i can access it from my laptop via GTK's print dialog :-)
<civodul>but yeah, i understand the need ;-)
<civodul>GNU Hurd on page 11 of http://csrc.nist.gov/publications/drafts/nistir-8151/nistir8151_draft.pdf :-)
***MatthewAllan93 is now known as GingaNinja
***GingaNinja is now known as MatthewAllan93
<ng0>do we have a drakonis here? apparently you wanted to tell me something on 2016-10-01 .. but I no longer know what the options were you asked about..
<ng0>sneek: later tell drakonis: which options did you ask about? I'm sorry I wasn't able to respond.
<paroneayea>wingo: !! thanks for starting the cups service :D
<ng0>sneek: where u at..
<ng0>sneek: you wandering, botless soul...
<ng0>sneek: you.. you.. BOT!
<ng0> /me uses memoserv
<paroneayea>civodul: ha, neat to see that mention
<ng0>so /MSG is included in /j in ii.. weird choice.
<ng0>not so weird, but when you expect raw irc..
<sankey>ng0: what do you mean by that? you message other people using the /j command?
<ng0>do we compile with -fPIC or -fpic by default? I'm trying to figure out a setting for uclibc-ng
<ng0>i'd assume yes
<ng0>sankey: join channels, query nickserv, query people etc.
<ng0>there are some pakcages setting fPIC
<ng0>I assume the freedom to just do and let corrections reign down on me once this is ready :)
<bavier>ng0: pic is package-dependent, AFAIK
<ng0>I have currently set FORCE_SHAREABLE_TEXT_SEGMENTS to y.. it's too much of a description to echo into irc, so in case this comes up I'm currently sticking close to what gentoo configures. should be documented on the website of uclibc-ng somewhere. but it will be a long time until uclibc-ng is ready. :)
<civodul>oh funny: 'wn' (wordnet) has an obfuscated reference to itself, which causes problems with grafts
<ng0>i hope no one works in parallel on uclibc-ng... would be bad
<ng0>so for those grepping the irc logs occasionally: I'm working on uclibc-ng for some time now and it will get doen as it's part of a project :)
<ng0>I do it for a while, run it, fail, save, hate it, go back to another project, and repeat. that's why it will take some time but I make progress
<rekado>first come, first serve... :)
<ng0>well i think parallel work is bad.. coordinated teamwork should be the ideal
<ng0>but in case someone is curious i think it's on my gitlab.. maybe.. not sure. once I get to a functional state the patch will get to the list and the checkout deleted
<ng0>"enable extra annoying warnings" hehe..
<ng0>at least the people writing the menu try to sneak in some humor
<jmd>I want to make a custom installer - with a few extra packages. How do I do that?
<davexunit>'guix system disk-image' with whatever OS config you want
<katco>hi, is anyone actively looking at getting ledger working again? http://hydra.gnu.org/job/gnu/master/ledger-3.1.1.x86_64-linux
<bavier>katco: I was looking at it a bit last night
<bavier>but didn't make much progress
<katco>bavier: i'm afraid i'm a bit too overcommited atm to contribute, but was curious what is happening with those tests
<bavier>katco: it might be partially due to the boost-1.61 upgrade, though some tests, I think, were failing before
<bavier>on test, e.g. fails because of some new warning output from a boost header
<bavier>s/on/one/
<katco>bavier: ah
<katco>bavier: how does guix handle failures like this? shouldn't this commit have been rejected when it failed to build?
<bavier>I think its a matter of tracking existing patches
<bavier>katco: we strive to minimize breaking builds
<bavier>in this case, since the package was already failing to build, it wasn't a blocker
<katco>bavier: it looks like it was building on 2016-07-26?
<katco>is there any way to pull down that substitute for use?
<bavier>katco: its doable.
<bavier>I haven't done it myself, but you can try `guix archive --import ...` of the downloaded closure
<jmd>davexunit: Where are the configs for our existing standard installer images?
<katco>bavier: ta, and gl with trying to diagnose/fix
<bavier>jmd: they're in gnu/system/install.scm
<jmd>Hmm. So where do I specify the architecture?
<bavier>jmd: when invoking 'guix system'
<bavier>e.g.
<bavier>guix system --system=x86_64-linux disk-image ...
<davexunit>try 'guix system --help' sometime
<jmd>Right now, I want to make a bog standard installer image but with an extra package preinstalled.
<bavier>jmd: then you should be able to just inport (gnu system install), then (inherit installation-os), and then override the 'packages' field.
<civodul>wordnet mystery solved, that was fun
<civodul>hello lfam!
<lfam>Hello civodul and all!
<lfam>civodul: How is core-updates doing? Can we change a bunch of Xorg packages on it?
<civodul>heheh :-)
<civodul>of course!
<civodul>and then we start building it?
<lfam>Okay, I'll get to work :)
<civodul>heh, take your time :-)
<civodul>paroneayea posted the list of affected X libraries earlier today
<civodul>that is a bit scary
<lfam>I saw the advisory yesterday but the updated libraries had not been released
<paroneayea>lfam: it looks like there are updates now
<lfam>Yes, they are out now
<paroneayea>I remember when not all programmers had to become security people... ;)
<lfam>I don't currently have a graphical GuixSD system. Does anyone want to test the grafted updates (if they can even be grafted) once the patches are ready?
<civodul>lfam: sure!
<lfam>Okay, you can find out if the grafts work :)
<lfam>Okay, the security advisory gives specific commits that we can use as patches. I will use those for the master branch, and then I will do full version updates on core-updates
<civodul>yeah, that's terrible
<lfam>Many terrible things on oss-sec, if you dare to read it ;)
<ng0>growing plants is more fun than security holes.. as long as you still can get 'drm-free' plants :)
<jmd>ng0: Unfortunately you cannot. Most countries have a "plant breeders rights act" or similarly named legislation.
<ng0>yeah..
<ng0>global drm sadness.
<jmd>bavier: What would I then give as the final argument to guix system ?
<lfam>I illegally propagated a few patented roses when I worked at a nursery. Take that... whoever!
<lfam>civodul: The libXi fix has two CVEs for one patch. Any advice on naming the patch so that the linter does the right thing?
<ng0>plant a seed, smash the system :)
<lfam>Can anyone figure out why the commit named for libXv doesn't exist in the Git repo? https://lists.freedesktop.org/archives/xorg/2016-October/058344.html
<lfam>MITRE pointed it out here: http://seclists.org/oss-sec/2016/q4/17
<lfam>Anyways, just going to use what is surely the right commit
<bavier>jmd: the path to your config file?
<lfam>(replacement libxfixes/fixed)
<jmd>bavier: But I don't have such a config file. You said just to inherit installation-os.
<jmd>Having done that. how do I generate the file?
<bavier>jmd: you've done that in a repl?
<jmd>bavier: No. I did it in emacs
<bavier>jmd: you'll probably want to put the os declaration in its own file. see the 'guix system' documentation
<jmd>I tried that too.
<bavier>jmd: just to be clear, I meant putting something like http://paste.lisp.org/+70XD into a install-config.scm file and giving that to 'guix system disk-image install-config.scm'
<bavier>*not tested
<efraim>looking at the powerpc bootstrap issues it looks like I may need to regernate my own aarch64 bootstrap binaries using an earlier version of tar
<lfam>civodul, paroneayea: I sent the Xorg patches series for the master branch to guix-devel
<ng0>Can someone apply the lispf4 removal patch?
<ng0>for all I know after looking at the docs again, we could be shipping copyrighted manuals/handbooks with it.. so removal is advised. my bad for not paying attention to this earlier.
<ng0>I will close the bug regarding lispf4 now as I know the package will be removed eventually, and the new one if I add it back won't be affected by the bug(s)
<wingo>guix should rename itself ABD, Always Be Downloadin'
<davexunit>+5
<civodul>heh
<civodul>lfam: thanks!
<janneke>well, better than ABBSM, Always Be Building, Substitutes Missing
<civodul>:-)
<civodul>Eventually™ we'll have content-addressed downloads and things will be more efficient
<lfam>That reminds me I wrote a draft email reminding people to be careful which hash they put in package definitions. The content addressed mirrors make it even easier to use the wrong thing
<janneke>lfam: got bitten by that a couple of times
<civodul>oh
<janneke>there was a time that a clean gnu-build-system build would produce a very nice binary package from the "wrong" source...not sure if that's still possible?
<lfam>Scary example: would anyone notice if an OpenSSL "update" patch instead used an older but compatible OpenSSL version's hash? As long as the hash changes and the package builds, it looks like everything is fine unless you look very closely.
<lfam>So, downloading the source code independently and verifying the hash is an important part of patch review
<lfam>I often "edit" the patched code with the hash I calculate. If `git diff` is empty, then I know it's right
<lfam>Or, I have some assurance that it's right
<civodul>you mean in case someone puts an old (but not too old) hash?
<lfam>Exactly
<civodul>good point
<civodul>our content-addressed mirror also includes the file name, so it wouldn't work with this one
<lfam>Ah, that's good.
<civodul>tarballs.nixos.org only includes the hash in its URLs though
<paroneayea>lfam: horray :)
<wingo>i am getting a few things like "suspicious ownership or permission on `/gnu/store/wbacf2dysgn8iwcrplc3na71m5pj91s5-gdk-pixbuf+svg-2.34.0'; rejecting this build output
<wingo>"
<janneke>ah, right...yes i've seen that
<wingo>what's that about?
<lfam>civodul: Yes, that's where I've noticed this behaviour
<lfam>wingo: See <http://bugs.gnu.org/22954>
<wingo>i had that earlier for a webkitgtk build and so i pulled and updated, thinking it would go away
<lfam>We think a bug in the daemon
<wingo>tx lfam :)
<lfam>It seems to happen non-deterministically
<civodul>yeah, it goes away when you retry
<civodul>annoying
<wingo>weird
<lfam>Does anyone remember this happening before we had recursive grafts?
<lfam>If not, that could narrow down the situations where the bug manifests
<wingo>it's in the grafting stage that this happens fwiw
<civodul>no, grafts are the thing that triggers it
<civodul>but it's really a race condition kind of bug in the daemon
<civodul>related to deduplication
<civodul>we should try "guix-daemon --disable-deduplication" to test this hypothesis
<lfam>here's the check that fails: http://git.savannah.gnu.org/cgit/guix.git/tree/nix/libstore/build.cc#n2368
<wingo>ACTION has a cups service built like the dovecot service, with ridiculous documentation etc
<wingo>yarr of course after updating i have to rebuild the kernel, blah
<wingo>back to the csp book :)
<ng0>i should mention i'm still working on the git service in addition to gnunet- and psyced-service, i just had to reconfigure the way my network works :)
<janneke>csp?
<janneke>as in https://en.wikipedia.org/wiki/Communicating_sequential_processes
<ng0>so this does not work.. but is there an expression which could build the public exported gnunet-svn from moduled named (guix) in file guix.scm here:
<ng0>ng0@shadowwalker ~/src/gnunet/gnunetsvn/svn/gnunet$ guix build --expression="(@ (guix) gnunet-svn)" ... will return: unbound variable: gnunet-svn. I'm trying to move from guix build -f guix.scm to something smarter :)
<ng0>so i can have gnunet-svn and gnunet-env in there for example.
<ng0>let me guess, module guix in this case takes module guix from the currently running system and not the file in cwd?
<rekado>ng0: is “gnunet-svn” defined in the module “(guix)”?
<ng0>yes
<rekado>is that module on the GUILE_LOAD_PATH?
<rekado>also note that there’s already a “(guix)” module — it’s part of Guix.
<rekado>don’t you use a git checkout?
<ng0>probably not. oh, THAT is why everybody is creating these pre-inst-env things
<ng0>it's in the svn checkout of gnunet
<ng0>I'm working on the same file in the gnunet.org/svn/gnunet/ dir
<ng0>so guix related, but not upstream'ish
<rekado>I see.
<rekado>it doesn’t matter where the file is located.
<rekado>you could rename it and add it to your GUIX_PACKAGE_PATH, no?
<lfam>I'm going to add some more comments to the "Remove lispf4" patch and push. Is that okay ng0 and rekado?
<lfam>I'm going to mention the generated C code in the commit message's explanation
<ng0>what's currently in svn you can build with guix build -f guix.scm when you are in the dir.. what does the pre-inst-env do? I've seen christopher create something like it for pubstrate. can I create this pre-inst-env to set the GUILE_LOAD_PATH temporarily?
<ng0>okay for me
<civodul>lfam: i'm testing the Xorg patch series here
<rekado>lfam: okay, thanks! I haven’t even looked at email since I got out of the office.
<rekado>(and possibly hours before leaving…)
<rekado>feeling a little burnt out.
<lfam>Okay, I don't want to put any pressure on you :) Guix can consume all of one's time if they allow it!
<ng0>so a quick hack can be to rename the file and add it to the load path.. i think this can be arranged in a script. thanks. take care :)
<ng0>i'm creating this general purpose, not for my own, easy to use
<asumu>Yay, I finally have GuixSD installed. Still having some trouble with GRUB but will figure that out later...
<ng0>reading the source of pre-inst-env now.. might be what i want
<lfam>New blog post, "A survey of remote shells in 2016". Topics will include OpenSSH, Dropbear, LSH, Imagemagick...
<wingo>lolll
<lfam>;)
<lfam>asumu: Welcome :) Please don't hesitate to ask for help regarding that GRUB problem
<wingo>asumu: cool!!!
<ng0>imagemagick?
<lfam>ng0: Yes, unfortunately
<ng0>exploit, or some joke i don't get? :)
<lfam>It was a joke, but the possibility for remote code execution controlled by the attacker is basically a feature
<ng0>:O
<lfam>So... exploit? Feature? Who can tell?
<lfam>Also ghostscript: http://seclists.org/oss-sec/2016/q4/29
<wingo>clownshoes
<janneke>ah ah ah, you did not provide the magic image
<lfam>Uhoh wingo, better change your password ;)
<wingo>what did i do
<lfam>janneke: Lol
<lfam>wingo: Just making a joke about "clownshoes"
<wingo>ah
<wingo>no, i am just trying to excise 'crazy' from my vocab :)
<lfam>I'm feeling jocular
<wingo>clownshoes seems a suitable replacement :)
<ng0>yes :)
<lfam>Also topical here in the US, for some bizarre reason
<ng0>clownshoes? why?
<asumu>lfam: thanks :) I'll see if I can figure it out on my own first. All this stuff with GPT, bios boot partitions, etc. is always such a pain.
<asumu>(I can currently boot with the help of supergrubdisk)
<lfam>ng0: The media claims there is an "epidemic" of people dressing as clowns and scaring other people. And it's not even Halloween yet!
<lfam>asumu: That stuff is such a mystery to me
<ng0>epidemic... that must be much with such a population. or as little and small as when the media reports that there was a terror attack in remote village somewhere in carpatian germany (meanwhile the police never said terror)
<ng0>I really think we need to symlink whatever binary libreoffice creates to 'libreoffice'. Everyone does that, and we are sticking much closer to upstream than Gentoo by not doing it. breaking peoples expectations.
<ng0>I would create the patch, but I first wanted to ask why libreoffice package does this
<ng0>or rather does not do it
<lfam>I've seen it used as an example of how we like to respect upstream's choices. What would we use an example if we make that symlink? ;)
<ng0>poke upstream about this weird name.
<lfam>ng0: I pushed your mailmap change
<ng0>soffice... probably an artifact from staroffice.
<lfam>Wow...
<ng0>thanks
<ng0>wasn't openoffice previously staroffice?
<ng0>yes https://en.wikipedia.org/wiki/StarOffice
<lfam>That's a name with deep roots
<ng0>i'd almost expect this falls under wasn't fixed because no one fixes trivial things..
<ng0>the mystical someoneelse should get in touch with upstream or search relevant bugtickets of it
<lfam>Yes, someone else, please do it :)
<civodul>:-)
<ng0>will GUILE_LOAD_PATH traverse down, or do I have to specify the exact directory/directories I want?
<ng0>example:
<ng0>(imagine this is appended to GUILE_LOAD_PATH):/home/alice/src/gnunet/svn/ versus GUILE_LOAD_PATH:/home/alice/src/gnunet/svn/gnunet/
<ng0>the first example assumes you have checked out the entire svn of gnunet.
<rekado>ng0: a directory in GUILE_LOAD_PATH is a root
<rekado>remember module names and how they map to directories?
<ng0>okay, so it traverses down.
<rekado>well, no…?
<ng0>i think i get it..
<ng0>let's say I use example 1 as the entry point and add it to the load path.. I have to call the module (gnunet guix) because it is in directory gnunet and the file guix.
<rekado>yes
<ng0>ok.. I should look at using some script to guess this, but so far I leave it up to the user. thanks for helping out :)
<ng0>s/guess/calculate
<ng0>i think this is what pkg-config was created for..
<ng0>I find mailmap weird. it would be more useful if I could move my early contributions into the name I use now. Some, even if the mailaddress is covered by it, fail to get catched
<ng0>I think this is just the bug which in at least 2 articles I've found was covered.. how git logs (and possibly other version control systems) do not respect peoples right to change their name.. even on such occassions such as mariage etc.
<lfam>Git does allow you to rewrite history if you want.
<ng0>I think base jumping from the mt everest can be equally successful.. and for a big project this does not work out in practice, at least I think so from what I've tried with a small ~1500 commits project
<wingo>does reconfiguring a service with a new config update the herd?
<wingo>ACTION sent cups service
<lfam>ACTION tests NSS update
<ng0>what I mean is, it should be a feature to have dynamic name/address. your name/email pair is bound to a unique hash, when you update name/email, all instances of name/email down to the first appearance of it change
<ng0>hash was the wrong term
<ng0>but some id
<lfam>I get the idea
<ng0>this is something I am thinking about for practical gnunet integration or whatever, but this feels bigger than I can code currently
<ng0>you just don't bootstrap a new version control system out of nowhere :)
<laurus>How can I make sure that a laptop I'm thinking of purchasing will support GuixSD?
<Walakea_>look for wifi and gpu drivers
<laurus>Walakea_, what do you mean?
<Walakea_>i think that that is where the most problems are
<lfam>laurus: I've seen <h-node.org> recommended as a resource for checking of some hardware is supported by free software.
<lfam>In most cases, the system will at least boot. But it's typical for wifi and GPU drivers to be non-free
<janneke>laurus: think of the right laptop ;-)
<laurus>OK, I will check that site and try to make sure the drivers are freely availble.
<lfam>laurus: We use the linux-libre kernel, which is based on linux and includes only free software (no proprietary non-free closed source firmware driver blobs)
<laurus>lfam, that's good
<ng0>worst case, you need an usb dongle for wifi, your 3d acceleration will be slow as a turtle in gnome.
<laurus>I don't need 3D acceleration I don't think
<laurus>Does anyone here have any laptop recommendations?
<ng0>for my desktop towers and their gpu cards, they are just a bit slow.
<bavier>laurus: there's https://minifree.org/
<ng0>basically anything on libreboot.org should work i think. possibly even coreboot.org with some added problems.
<ng0>wingo, don't you use an X-something by lenovo? is the gpu slow?
<ng0>I have these old nvidia and ati pci and pci-express cards and they are really slow in gnome mostly, when you drag around windows or do anything etc.. slowness differs.. but that's because of the chipsets and drivers
<tinyOwl>laurus: if you don't mind a bit older hardware, the thinkpad x60 and x200 series with atheros wifi are great, you can install libreboot and get an effectively 100% libre system going
<tinyOwl>i use a thinkpad x60s and it's nice, but if you intend to use a gui, it's gonna be pretty slow
<lfam>I don't think that Intel has every released a free wifi driver
<lfam>s/every/ever
<ng0>at least it's not wifi with AC standard.. those are not available yet.
<laurus>lfam, hm. Ok.
<laurus>I'll have to contact them with my complaint
<ng0>sad 5G router sitting unused here.
<laurus>How do I buy one of those USB wireless things?
<laurus>(that works with free software of course)
<ng0>i bought tp-link tl-wn722n dongles for other people at some point, they can be found on h-node too
<ng0>depending on your location and mail/shoping availabilities that's as simple as ordering any other hardware
<lfam>laurus: Once you've identified the chipsets that are acceptable to you, you can buy the USB wifi devices (or other form factors) from basically any computer components shop online
<laurus>ng0, thanks, I will purchase that.
<lfam>Some motherboards let you use minipcie cards instead of usb dongles. But there are some dastardly manufacturers that whitelist wifi cards
<laurus>lfam, thank you
<laurus>By the way... is GuixSD ever planning to change its logo?
<rekado>I use a Thinkpad X200s with Libreboot and an atheros Wifi card.
<lfam>Wow, I didn't know this but there are even M.2 wireless cards: https://www.thinkpenguin.com/gnu-linux/wireless-n-m2-ngff-combo-card-v2
<ng0>they can be akward.. i'm still searching for a way to somehow just punch it inside the t60.
<lfam>laurus: No plans, why?
<lfam>Not a fan? ;)
<laurus>lfam, don't take this the wrong way... but the first time I saw it, I instantly thought it looked like a stylized vagina.
<laurus>I know it's probably supposed to look like the outline of a gnu's head...
<lfam>Ah. I believe it is supposed to represent a gnu (wildebeest)
<laurus>But it looks similar to almost any abstract art depicting a vagina... sorry to say
<ng0>and looking at it another way is bad why?
<lfam>To be honest, considering the multitude of phallic representations, I don't mind our logo too much ;)
<laurus>It's not bad, I just thought I would mention it.
<ng0>okay
<laurus>It's probably what a lot of people who aren't from the GNU world would think of when they saw it.
<ng0>I have yet to meet those..
<laurus>Fair enough :)
<laurus>Anyway thank you for the info, I'm looking forward to installing and promoting this distribution
<bavier>yup, I haven't heard anyone else mention it
<ng0>I mean, I have a button with this logo printed, and no one had the impression so far.
<laurus>ng0, hah okay
<ng0>even if, it wouldn't be negative as a negative view would be in direct contradiction with our code of conduct.. but good that we have cleared that initial confusion
<ng0>sentence too short.. anyway, i have to continue writing
<laurus>Thank you ng0
<ng0>I see why documentation happens not so often.. to document how to use the changed file I had to add more documentation than I added code..