IRC channel logs

2016-11-28.log

back to list of logs

<lfam>Apteryx: That's what I've been doing but I realized recently I can probably configure my mail client to reply to the mailing list only. I'm not sure if that's better or worse
<Apteryx>lfam: I've read this: http://david.woodhou.se/reply-to-list.html, basically there is no 'one way' but the safest when you don't know how people configure their mail client is to use "Reply All". Mailman by defaults will not generate duplicated mails.
<nckx>lfam: ah, thanks for putting my mind at ease :-) (...and: cue sneek: )
<sneek>nckx, you have 1 message.
<sneek>nckx, lfam says: No, nothing in particular. I just wanted to be sure we weren't missing any important bug fixes. Sometimes projects see no official activity for years while the distros patch critical bugs. So you get something like Jasper, which we added the latest release of before realizing there were many unpatched bugs
<nckx>Ooh, just in time for ML holy war discussions.
<lfam>Heh, I'm never sure how to leave notes for idle people
<nckx>lfam: I run an always-on (and Guix-powered! whoo) ZNC instance, so should see everything eventually. But in general: nope, no clue.
<Apteryx>nckx: :D
<nckx>sneek: botsnack
<sneek>:)
<lfam>The great thing about sneek is they are so cheerful even if you already ate all the botsnacks
<lfam>Oh dang, I guess sneek is not a glutton ;)
<nckx>ACTION has enough botsnacks for everybody; being in a post-Thanksgiving ‘I'll never eat a $%*# thing again’ mood.
<lfam>sneek: help
<nckx>lfam: /msg sneek help (or you found out already)
<lfam>I was hoping for documentation fo the botsnack feature
<lfam>How many botsnacks can sneek eat at once?
<nckx>sneek: be honest, who ate *ALL* the botsnack?
<sneek>:)
<nckx>That :) looks pretty guilty to me.
<lfam>Lololol
<ZombieChicken>Who is sneek?
<sneek>I've heard sneek is a good boy
<ZombieChicken>I'm assuming a bot of some description...
<Common_Era>Hi.
<Common_Era>Hello.
<Common_Era>When I start my GuixSD machine, after "Service ssh-daemon has been started", I get "Seed file too short
<Common_Era>Then, I have to reboot to re-enable ssh and it happens again. Anything?
<Common_Era>I need to be able to SSH into this machine. This is a fresh install.
<Common_Era>What's happening here?
<Common_Era>Nothing at all?
<Apteryx>Common_Era: Did you generate the initial seed?
<Apteryx>I haven't enabled the server, but I remember having to do that for the client. I followed the info manual for lsh.
<Common_Era>Hmm. Wait a second.
<Common_Era>When I try generating the key, I get seed file too short again.
<Apteryx>:(
<Apteryx>Not sure what is going on.
<Common_Era>It's weird.
<Apteryx>What happens when we "refresh" a package in git (bump its source url/version/hash) ? Does this new version replace completely the "older" version, i.e. make it impossible to install the older version?
<geemili>I'm trying to install gnome-terminal, but it says gnome-terminal not found. How do I fix that?
<Apteryx>geemili: What command are you running exactly?
<geemili>Apteryx, I am running guix system reconfigure
<geemili>I'm trying to specify it in a manifest file
<Apteryx>guix system reconfigure /path/to/your/config.scm ?
<Apteryx>And in your config.scm you have gnome-terminal listed in the (packages ) sexp?
<Apteryx>And did you not forget to put gnome in the top defined (use-package-module ... gnome)
<Apteryx>Otherwise the gnome-terminal symbol would not be defined, I think.
<geemili>Apteryx, I have to put gnome in the (use-package-module)? How do I figure out which package module a package is in?
<Apteryx>guix edit gnome-terminal
<Apteryx>Will open the definition of the 'gnome-terminal'. And at the top of the file there should be a line like: "(define-module (gnu packages gnome)"
<Apteryx>This tells you that this package lives in the (gnu packages gnome) namespace.
<Apteryx>or gnu.packages.gnome module if you want a Python equivalent
<Apteryx>Normally you'd have to use (use-module (gnu packages gnome)) at the top of your config.scm to make the gnome-terminal symbol (definition) available, but there is syntactic sugar to make this more concise: (define-syntax-rule (use-package-modules module ...)
<Apteryx> (use-modules (gnu packages module) ...))
<Apteryx>This aollows you to just use: (use-package modules somepackage anotherone ... gnome)
<Apteryx>*allows
<Apteryx>Or, if you don't like the idea of having to hunt for the location of a package definition, you could also use the specification->package procedure which will resolve this for you. You'll want to read about it in the "7.2.1 Using the Configuration System
<Apteryx>section of the Guix info manual.
<Apteryx>Is there no way to "step" Guile code using Emacs + Geiser?
<Apteryx>For debugging, with breakpoints et al.?
<Apteryx>It seems that using pip install --user doesn't work quite right with Guix.
<Apteryx>I've tried forcing an update to pip using "pip install --user --upgrade pip", and it prints the following: pip install --user --upgrade pip
<Apteryx>Collecting pip
<Apteryx> Using cached pip-9.0.1-py2.py3-none-any.whl
<Apteryx>Installing collected packages: pip
<Apteryx>Successfully installed pip-8.0.2
<Apteryx>You are using pip version 8.0.2, however version 9.0.1 is available.
<Apteryx>You should consider upgrading via the 'pip install --upgrade pip' command.
<Apteryx>It seems that the Python installed will always prefer its PYTHONPATH rather than looking in $HOME/.local/lib/python2.7/site-packages. This is not the usual behavior of Python.
<Apteryx>Defining a PYTHONPATH to try to make it see the updated definitions in $HOME/.local/lib/python2.7/site-packages is also a no go.
<Albertoefg>hello
<rekado>looks like I was wrong about the GCJ patch. It *does* seem to affect builds on other architectures :(
<rekado>guess I’ll have to apply the patch conditionally then
<rekado>sorry about this
<efraim>it happens
<jmd> sh^^
<spacekitteh>hey, just wondering, where can i find like, a rationale of why you started guix?
<kmicu>spacekitteh: http://lists.science.uu.nl/pipermail/nix-dev/2013-January/010471.html
<kmicu>(Also Nix{pkgs,OS} does not follow https://www.gnu.org/distros/free-system-distribution-guidelines.html )
<civodul>security in Nix: https://github.com/NixOS/security
<civodul>seems to be similar in spirit to 'guix lint -c cve', if i read correctly
<ng0>I'll deactive/delete my github account once more, so the open issue on pybitmessage and pyqt4, I hope I can communicate it this time outside of github, last time this way of communication was succesful but not very efficient. But I know we have some people here using github, so if they insist on github, I'll point it out here if necessary.
<efraim>I think I have a working patch for CVE-2016-9082 against cairo, i'll post it to the list soon-ish
<civodul>cool!
<spacekitteh>wait so guix sits on top of nix?
<kmicu>Some parts are still from Nix (the package manager) code base, but it’s too little to make it compatible with Nix nowadays.
<spacekitteh>ah. so they're incompatible now?
<spacekitteh>store-wise?
<kmicu>I’m not sure if the last paragraph from https://www.gnu.org/software/guix/manual/guix.html#Requirements is still valid. civodul should know the current state of affairs. Last time I checked the diff between Nix and Guix C files it was too big to assume any compatibility.
<ng0>there's also the section where it was explained that you can run guix on nixos
<spacekitteh>ACTION nodnods
<spacekitteh>i've read that bit but i'm wondering if they're out of date :)
<civodul>spacekitteh: they've become slightly incompatible lately
<civodul>namely, the daemon protocol is a bit different
<spacekitteh>oic
<civodul>i'm afraid that was bound to happen :-/
<spacekitteh>yeah. oh well. does importing from nixpkgs still work?
<civodul>OTOH it gives more freedom to each project
<kmicu>spacekitteh: you can contribute first thing to Guix project and fix misleading manual :)
<civodul>spacekitteh: yes
<spacekitteh>cool. :3
<civodul>well, "most of the time" ;-)
<spacekitteh>first thing i'd probably wanna work on is a squashfs store >.>
<civodul>there are other repos to import from though, so i suspect very few people import from Nixpkgs: https://www.gnu.org/software/guix/manual/html_node/Invoking-guix-import.html
<spacekitteh>oh that's cool
<ng0>would the import still work? i tried something and it crashed. I think I really need to export NIX_REMOTE then
<civodul>yeah NIX_REMOTE needs to be set as noted in the page above
<ng0>and then? guix import nix ~/re-src/nixpkgs/ tor : breaks. guix import nix ~/re-src/nixpkgs/pkgs/ tor : breaks.
<ng0>same for libreoffice
<ng0>does it expect the path to the default.nix which holds $package ?
<ng0>i haven't read the code of the nix importer
<civodul>works for me :-)
<civodul>ng0: could you send the details of the failure to bug-guix@gnu.org?
<ng0>ok
<ng0>done
<sirgazil>Hi!
<sirgazil>Are packages supposed to have unique full-name values?
<bavier>sirgazil: yes, in order to avoid name conflicts in the UIs
<sirgazil>I'm trying to fix an HTML validation error on Guix website that involves duplicated IDs. Package names are used for anchors, but I get duplicated <package> objects (ruby-2.3.2) and duplicated full names (ruby-2.3.2, llvm-3.7.1, gfortran-4.9.4, armadillo-7.500.0)...
<sirgazil>bavier: Oh, really? Then the code in the website may be doing something wrong...
<bavier>sirgazil: well, it's not enforced per se, so its possible there really are some name conflicts
<sirgazil>hmm, I see.
<Apteryx>Is "guix refresh" know to not work when the uri is specified as a "pypi-uri"? Example: "guix refresh python-pip" should propose an update to 9.0.1 but returns nothing. Same for python-tox.
<Apteryx>s/know/known
<civodul>hello sirgazil!
<civodul>sirgazil: those conflicts are on the package list or issues.html?
<civodul>for packages/index.html, there's code to do conflict resolution for anchors, while preserving nice readable names as much as possible
<sirgazil>civodul: Yes, the `all-packages` procedure returns a list with duplicated packages.
<civodul>"duplicated" as in they are 'eq?', or they have the same full name?
<civodul>the conflict resolution thing i mentioned is 'packages->anchors' in that file
<sirgazil>civodul: Comparing the package objects, I get duplicated objects, and comparing full-name strings, I get additional duplicated full-names:
<sirgazil> https://paste.gnome.org/p1wcn8kls
<civodul>sirgazil: yes, right, but which page has duplicated anchors?
<sirgazil>Issues.html
<civodul>ok
<civodul>this is weird because both packages/index.html and issues.html use packages->anchors
<Apteryx>'weechat
<Apteryx>hm.
<Apteryx>;)
<sirgazil>civodul: Yes, exactly. I don't know why that is happenning. Although it may be that packages page has the duplicated IDs as well, but the validator does not show them because it chokes with that huge page (9.9 MiB) :)
<civodul>right :-) but you could grep it
<sirgazil>civodul: I'll do that...
<civodul>sirgazil: i can reproduce the problem: http://paste.lisp.org/+74RP
<civodul>eq?ness is not enough
<sirgazil>civodul: yeah, I grepped and found the duplicates in the Packages page as well.
<civodul>so that packages->anchors proc should be improved
<civodul>not high priority if you ask me, but if you have ideas, that'd be nice!
<sirgazil>civodul: I would have to study first what it does. In the meantime, I think we should then deploy to the website the other validation fixes at least, what do you think?
<sirgazil>civodul: Maybe the anchors problem can be fixed and deployed with Alex's patch for the Packages page...
<Apteryx>Could anyone tell me how to use the Guile REPL to execute a function? I'm in the Guile REPL, I've load the module with C-c . u. The module in question is (guix/scripts/import.scm)
<Apteryx>Now I'd like to just get the import function help printed, so I try: (guix-import "--help"), but nothing gets output and the REPL quit, asking me to press C-c C-z to bring it back?
<Apteryx>I could at least run (show-help) in the same module, with output.
<Apteryx>I'll practice the debug flow using that one.
<davexunit>Apteryx: printing help also exists the process
<davexunit>I don't know what you're trying to do, but there's surely a better way.
<davexunit>if you read the source to the guix-import procedure you can see how the "--help" flag is interpreted
<Apteryx>davexunit: OK. I'm just trying to debug the "refresh" function/script. Its entry points appears to be in guix/scripts/refresh.scm
<davexunit>okay, so what was all this stuff with the (guix scripts import) module then?
<Apteryx>I noticed that it seems to work fine to detect updates when the URI of the package is in a specific form, but fails otherwise.
<Apteryx>davexunit: I just got confused, but I tried the same thing there before and got similar results.
<davexunit>using --help is always going to exit
<davexunit>it would be better to avoid using the UI procedures altogether
<davexunit>and use the API that the UI is a wrapper for
<Apteryx>davexunit: OK.
<Apteryx>Actually, (guix-refresh) is doing its job as intended it seems.
<davexunit>though that might be hard to figure out so using the CLI entry point could be a good starting point before probing further
<davexunit>oh, well, good, I guess!
<Apteryx>sorry for my confusion :). And I saw I can use breakpoints using the interpreter (Guile) debug functions, I guess that's how it's done?
<geemili>How do I add proprietary stuff? I need one of these drivers for my wifi: https://wiki.debian.org/rtl819x
<jmd>geemili: That is off topic here.
<geemili>Oh
<bavier>geemili: in a nutshell, write a package for it and use it in your system config.
<geemili>bavier,
<bavier>but yeah, specific assistance probably won't be offered much
<geemili>Okay
<Apteryx>geemili: Might be easier finding libre hardware, such as a cheap usb wifi dongle.
<davexunit>I own one of these: https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-usb-adapter-gnu-linux-tpe-n150usb
<davexunit>works well
<bavier>indeed, the thinkpengion dongles are affordable and have worked well for me
<geemili>Apteryx, I have two wifi dongles, but they aren't working
<geemili>Maybe I should buy one of those
<davexunit>a shame that so many wireless chips require proprietary firmware
<Apteryx>geemili: I remember buying one from think penguin, it was about 30 USD.
<Apteryx>Although I'm not using it with Guix. I would think it's workable, as its blob free.
<geemili>The page is saying $25
<Apteryx>Maybe ask them if it's know to work out of the box with Linux Libre, and if so, might be a good investment.
<Apteryx>*known
<davexunit>Apteryx: thinkpenguin stuff works with linux-libre
<davexunit>no need to ask
<davexunit>the wireless N adapter I posted is even certified by the FSF
<davexunit>I've also used this with GuixSD in a laptop https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-half-height-mini-pcie-card
<bavier>I use both of their usb wifi devices with Guix on a daily basis
<paroneayea>how do you select an output for configuring your system object?
<paroneayea>eg I want to select sbcl-stumpwm and add to the (operating-system (packages ...)) field
<davexunit>paroneayea: I don't know if you can do that.
<jmd>paroneayea: Not sure that I understand the question. Normally you add it to your /etc/config.scm and run guix system reconfigure
<davexunit>on the topic of hardware compatibility, does anyone own a printer made by Brother?
<jje>yes
<rekado>paroneayea: (specification->package "sbcl-stumpwm:bin") ?
<davexunit>paroneayea: I need to re-read the source, but it would be nice if the package list was interpreted like it is in 'guix package --manifest'
<davexunit>with a (package, output) tuple
<davexunit>jje: can you print to it with GuixSD?
<jje>no tried everything too.
<davexunit>oh
<davexunit>well maybe I won't buy one :)
<jje>just ordered an HP printer from thinkpenguin. that will fix it.
<jmd>Printers are currently a big problem freedomwise.
<davexunit>I found this: http://www.openprinting.org/driver/Postscript-Brother/
<davexunit>I have yet to find a printer that I can't print to with GNU/Linux, so I find that surprising
<davexunit>but I hear stories of other people not being able to print
<davexunit>also, I'm looking for a networked printer.
<davexunit>not one you connect via usb to a single machine
<jmd>certain Samsungs one cannot without proprietary blobs.
<jmd>and many others certain features don't work without proprietary software.
<davexunit>I'll stick with HP, I suppose.
<paroneayea>rekado: that probably works...
<jmd>Lexmark and HP have chips in which prevent third party consumables being used.
<jmd>and and which will tell you that your cartridge is empty even when it's not.
<davexunit>is that true for laser printers?
<paroneayea>jmd: I did do that, though after reading the recent stumpwm post on the list, I was wondering if the reason why I didn't get it working was because I put the stumpwm package in the operating-system definition and not specifically the bin output
<paroneayea>davexunit: I have a networked printer I print to in debian fine
<paroneayea>I think we're missing the foomatic files for it to work in guixsd
<paroneayea>it's an HP laserjet, works great
<davexunit>HP laserjet it is!
<davexunit>I'd settle for an inkjet but if I get a laser printer I can make my own circuit boards at home ;)
<paroneayea>ACTION sometimes wonders if his laserjet's OS has been compromised...
<paroneayea>not that I've seen any evidence, but I don't think it gets security updates
<paroneayea>and I have no idea what that thing runs
<bavier>wasn't that one of rms's original encounters with proprietary software?
<paroneayea>bavier: yes, though in that case a driver that connected to the printer, rather than the software on the printer
<paroneayea>but yep
<bavier>maybe it'd be easier if we could all read punch-tape :)
<jmd>Is the person responsible for gnu/services/configuration.scm here?
<paroneayea>damn
<paroneayea>it looks like nixops doesn't supply a rackspace cloud option
<paroneayea>they just use EC2
<paroneayea>I'd really prefer to work on deploying using known strategies from Nix, but I also don't want to support Amazon or agree to their ToS
<davexunit>paroneayea: openstack exposes an EC2 compatible API, but I've never used it.
<davexunit>I've also written Ruby code in the past to write wrappers for the rackspace HTTP API. it's not too hard to do.
<paroneayea>yeah
<paroneayea>I guess I just need *a* damn machine running on these things to start testing with
<paroneayea>it's not clear to me what a guixsd machine needs built in it in order to run correctly
<paroneayea>Xen, I guess
<paroneayea>is the thing we don't have
<davexunit>yeah I have no idea what is needed to make a disk image
<davexunit>does openstack really use Xen?
<davexunit>would've thought it was KVM
<paroneayea>it looks like rackspace does at least
<davexunit>yeah looks like you're right
<davexunit>so if you can create a Xen image, you should be able to upload that to your rackspace account and boot it.
<paroneayea> https://support.rackspace.com/how-to/preparing-an-image-for-import-into-the-rackspace-opencloud/ just says "make a VHD file"
<paroneayea>which, we could do that now by converting the qcow file
<paroneayea>but, will that be enough?
<paroneayea>I guess I should just try it
<paroneayea>I'll need to modify the image ahead of time to drop in an ssh key I guess
<paroneayea>or define a service that installs one on activation
<davexunit>paroneayea: I'm not sure how the SSH thing works, but when I make VMs at work I specify that the server should allow root access with my key.
<davexunit>the key is not on the image. I have no clue how they make that work.
<paroneayea>davexunit: I think in our case we'll need to preload it on the image.
<paroneayea> https://github.com/NixOS/nixops/pull/408/commits/ae0b76b44c96605647fb9a7449a98bdba4613f65 <- hey lookie
<paroneayea>experimental openstack backend for nixops
<paroneayea>looks like they use the "shade" library to create/upload the image.
<davexunit>there we go
<davexunit>I hope whatever we do is less hacky than nixops :)
<paroneayea>self.cloud = shade.openstack_clouds(name=cloudname)
<paroneayea>self.cloud.create_image(vm_id, filename="{0}/disk.qcow2".format(base_image), wait=True)
<paroneayea>looks like that's the bulk of it
<paroneayea>I guess shade must get some configuration from a magic path or environment variable
<davexunit>if it's anything like the EC2 API wrappers, they read a credentials file from your home directory
<paroneayea>that's probably what's done
<rekado>I wonder why automounts don’t work.
<paroneayea>rekado: ?
<rekado>I noticed that starting $gvfs/libexec/gvfs-* is needed
<rekado>but that should be done automatically
<rekado>gvfsd must run as a regular user as well
<rekado>when I start this manually and then open nautilus I see attached USB devices to be mounted
<rekado>otherwise I have to use udiskctl to mount them as a user.
<paroneayea> http://hackaday.com/2016/11/28/neutralizing-intels-management-engine/ hey nice
<paroneayea>a way to disable intel ME on some machines
<geemili>Where should I look if I want to add a build system?
<davexunit>paroneayea: ah, cool! I remember seeing the coreboot thread about this a few months back.
<davexunit>I guess it really works!
<davexunit>also, another random GNU/Linux question: has anyone here used their computer as a bluetooth audio *server*?
<davexunit>maybe rekado? ;)
<davexunit>use-case: allowing guests to stream music to my stereo system without using some proprietary device.
<rekado>only used bluetoothd to stream music to a device
<davexunit>okay
<efraim>I have in the past successfully tethered my computer to my phone through bluetooth, using the command line
<rekado>re automount: looks like we need to add gvfs to the system packages, so that their “.service” files appear where dbus expects to find them.
<efraim>geemili: I'd look at one of the "derivitive" build systems, like cmake, and then look at the gnu-build-system to see the whole thing
<geemili>efraim: Thanks
<davexunit>well this looks promising: https://www.raspberrypi.org/forums/viewtopic.php?t=68779
<davexunit>I can just a freedom respecting computer instead :)
<davexunit>just use*
<davexunit>oh, and wait for guixsd to work on arm ;)
<rekado>(hmm, guess it actually needs a dbus service extension.)
<efraim>ok, I think I'm finally happy with the cairo cve patch
<davexunit>actually this looks like a better guide (in case anyone is interested) http://www.instructables.com/id/Turn-your-Raspberry-Pi-into-a-Portable-Bluetooth-A/
<rekado>so, this works: add “gvfs” to the system packages, reconfigure, start nautilus. USB devices can now be mounted as a user on click.
<davexunit>rekado: so does that mean that we should just include gvfs in our gnome package?
<rekado>davexunit: dunno. Maybe. I’m using it with Xfce now.
<rekado>davexunit: at least it should be mentioned somewhere, maybe in the example config for a desktop.
<dvc>guix tests require guile-ssh to run, so guix environment guix && make check doesn't work anymore. is this on purpouse or did someone just forget to add guile-ssh to guix's inputs?
<dvc>ah, it's documented in the manual, so seems to not be a mistake. maybe it needs to be added to the running tests section too...
<ng0>what's the state of that, guixsd on arm?
<ng0>bootloader made some progress last I checked
<dvc>are you asking me? I haven't had any time to work on it. I kind of got it working a while back but it needed some hacks
<ng0>no, a general question thrown into the channel to whoever knows more
<dvc>I don't think I've seen anything on the ML recently...
<dvc>regarding guixsd on arm that is
<ng0>weren't you working on rust build system a while back? if so, what was the problem that it wasn't ready for merge into master so far?
<dvc>no time...
<ng0>oh, ok
<ng0>so it's basically ready but needs some last reviews?
<dvc>it needs more than that
<ng0>anything other people could take on?
<dvc>would you like to?
<ng0>one of our prototypes needs to be build with rust, so I'm interested but I have very little experience with rust. it depends on what needs to be done
<dvc>it's been a while, I need to refresh my memory on the issues that came up. bundling the cairo dependencies into a tarball would make a lot simpler
<ng0>maybe you can take your time, refresh the issues, list them, write them to the mailinglist and people can pick them up. I don't think i'm the only one interested in this
<dvc>the problem with packaging any modern language is that they have 100's of dependencies, and you can't just use any version. so my naive importer simply imported the latest, and that leads to problems
<dvc>sry, meant cargo above obviously
<dvc>guix system tests fail because guile-ssh is missing... I'll send a patch to add guile-ssh to guix's inputs...
<paroneayea>looks like Guix now has 38% the amount of packages as Nix :)
<paroneayea>getting closer...
<paroneayea>50% is not far off!
<bavier>nix automates its import of all of cpan and hackage IIRC
<wingo>paroneayea: is it a subset, i wonder?
<bavier>which is a lot of packages
<wingo>i guess mostly subset
<wingo>except elogind etc
<kmicu>paroneayea: how did you measure that? :)
<paroneayea>kmicu: I looked at the Guix package page and the Nix package page
<paroneayea>and just compared the numbers
<paroneayea>Guix: 4484 packages
<paroneayea>Nix: 11872 packages
<kmicu>Nix webpage hides subsets like haskellPackages, emacsPackages, etc and unfree packages. There is over 30k packages available in Nixpkgs.
<paroneayea>wingo: yeah I dunno, it would be interesto do an attempt to compare, but I suspect you'd have to fuzz the strings a lot to get matches
<paroneayea>so comparisons probably won't really give you the right info
<paroneayea>kmicu: oh really?
<paroneayea>kmicu: guess I'm wrong then!
<paroneayea>15% then ;)
<davexunit>keep in mind that Nix package quality is overall pretty awful
<davexunit>lots of auto-generated code dumped in for many things
<civodul>bah, this GNU discussion about repro builds keeps disappointing me :-/
<kmicu>ACTION as a person familiar with Nixpkgs tree states that Nixpkgs quality is not ‘pretty awful’ and auto–generated sets like haskellPackages works flawlessly.
<davexunit>civodul: I had to stop reading it.
<davexunit>it's too frustrating.
<paroneayea>I got confused by that thread and why there was such pushback
<paroneayea>anyway, I also stopped reading it
<paroneayea>at the time I stopped at least it seemed like rms was very pro-reproducibility
<paroneayea>hopefully that didn't drop.
<civodul>yeah, i stopped reading, but somehow i can't help but look at a message once in a while ;-)
<davexunit>seemingly some GNU maintainers exist simply to block every proposed improvement.
<paroneayea>davexunit: I'm vaaaaguely considering submitting a libreplanet talk named "GNU and the Lisp Machine"
<civodul>go forth!
<civodul>:-)
<paroneayea>I wonder if anyone would go to it, or if anyone outside of #guix would go to it ;)
<davexunit>I would go to it :)
<paroneayea>but it wouldn't specifically be a guix talk (though that would be a component of "lisp as the gnu machine today") but also would be looking at lisp machine history (from my ameteur research)
<civodul>i'd go... if i were in Boston
<civodul>that sounds interesting
<paroneayea>civodul: LibrePlanet is a lot of fun if you can somehow make it out for it :)
<civodul>:-)
<davexunit>the deadline for LP submissions is today. I was thinking about conjuring up something but I've decided not to.
<bavier>when https://my.fsf.org/lp-call-for-sessions says "Wednesday, November 28th", do they mean the 30th?
<davexunit>I'll go just as a regular attendee this time around
<davexunit>bavier: I think they just got the day of the week wrong
<bavier>ok, so deadline is passed I guess
<paroneayea>bavier: it's wednesday!
<paroneayea>the LP page is all messed up
<paroneayea>confirmation from FSF employee in another channel
<paroneayea>davexunit: ^^
<bavier>oh, good to know
<bavier>I'll think about a submission some more then
<davexunit>paroneayea: thanks!
<Apteryx>Hi. I just updated python-pip to version 9.0.1. When I do: "pip list", there is now a warning output at the beginnig of the installed packages, which reads: DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
<civodul>bavier: oh oh! any teaser? :-)
<Apteryx>Is this OK? I guess it's good that this be visible. And the users could keep a local pip.conf with their preferred setting for the time being.
<bavier>civodul: I was thinking about a bootstrapping talk
<bavier>compiler/OS bootstrapping
<rekado>about the number of packages: would you be interested in getting a couple thousand of CRAN packages?
<rekado>or should we only add packages that have actually been requested by someone.
<Apteryx>rekado: if we have tools that can do this automatically (and keep them up to date, too), I'd say, why not.
<civodul>bavier: that would be great
<civodul>rekado: oh!
<dvc>bavier: that sounds interesting...
<Apteryx>When is LibrePlanet happening?
<jmd>Apteryx: Usually March.
<Apteryx>OK
<rekado>Apteryx: we have an importer and an updater for CRAN packages, and I’ve been using both in the past for mass imports and updates.
<bavier>I'd ideally have a bit more actual code to show, but submitting a talk proposal might be a good catalyst
<civodul>rekado: sounds cool!
<rekado>I’d like to see more packages be updated regularly.
<civodul>in an ideal world we'd have an automatic process hooked up to CI
<rekado>some of the perl and python stuff starts smelling already.
<civodul>yeah
<Apteryx>rekado: And the pypi updater doesn't find them all for some reason.
<civodul>i think it depends on the kind of URL being used
<civodul>but the problem is that 'guix refresh' doesn't report packages for which there's no updater
<rekado>we’ve said in the past that packages get updated by whoever is interested in them, but that doesn’t cover the supporting packages a few levels down
<Apteryx>Yes I think so too, when we use pypi-uri it doesn't find those.
<civodul>Apteryx: you can report a bug for that one, if it's not already filed
<Apteryx>civodul: Should I use the bug-guix@gnu.org mail list, or can I log it myself in the DB?
<civodul>just email bug-guix and that ends up in the DB
<civodul>there's no web interface
<Apteryx>Oh. Is there a specific template to use so that it gets parsed in a certain way, or?
<dvc>bavier: are you bootstrapping guix to a new architecture?
<ng0>what if we had an web display of that, which runs the refresh and displays the differences between what's available and what master has etc?
<bavier>dvc: actually, trying to re-bootstrap to x86_64 with smaller binaries/more source code
<dvc>aren't the bootstrap tools already pretty minimal?
<Apteryx>rekado: Also, for thousands of packages, how would you organize the package definition files? Hopefully it'd be split to not become the a monolith such as the python.scm module (~10k loc).
<jmd>Running guix system reconfigure, how can I get a stack trace on an exception?
<Apteryx>rekado: And can the tools update the definitions straight into where they are kept (.scm files) ? Otherwise that's still a lot of manual work.
<Apteryx>(for thousands of packages)
<rekado>Apteryx: yes, they are updated in place
<rekado>not sure about how to organise the CRAN packages. All of them are statistics or machine-learning packages.
<Apteryx>rekado: OK. Sounds good. As long as it's fully automated I'd say go for it :)
<rekado>(I regret suggesting the machine-learning module; it’s hard to distinguish between stats and ML.)
<bavier>dvc: yeah, a few megabytes, but it'd be fun if we could make it even less :)
<Apteryx>Alphabetically ordered, split into chunks of 50 or so packages per file?
<rekado>ng0: I wouldn’t really want a web interface that’s open to the public.
<dvc>bavier: sounds like fun indeed :)
<ng0>I know the problems that this could open
<rekado>would be neat if we could automate building updated packages automatically.
<Apteryx>rekado: Another thing, I saw that pypi importer seems to always list the inputs as "propagated-inputs" rather than just "inputs". So to make things right human intervention is still necessary.
<Apteryx>Not sure if you have such a limitation with your CRAN imported.
<Apteryx>importer*
<rekado>Apteryx: no, the CRAN and bioconductor importers do the right thing.
<rekado>Apteryx: what they don’t do well is write creative descriptions :)
<ng0>Apteryx: that was explained recently on the mailinglist by harmut, why the python was changed to propagated-inputs
<Apteryx>ng0: OK, will look it up, thanks.
<rekado>re lisp machine: AFAIU what’s great about them is that anything you can see can be inspected and modified as a lisp object. We have something like that with Emacs, but we lack a blissfully tweakable system like that outside of Emacs.
<paroneayea>rekado: indeed, that's one nice thing about them
<paroneayea>not the only nice thing, but maybe the nicest :)
<Apteryx>ng0: couldn't find it :/
<ng0>i have everything offline, I can't help with an link, sorry
<Apteryx>Oh, I think this is it: https://lists.gnu.org/archive/html/guix-devel/2016-10/msg00850.html
<Apteryx>ng0: np
<Apteryx>It's a better default than just inputs for sure. And I guess there is nothing standardized yet in the python world to distinguish between these two kinds of dependencies.
<paroneayea>hm interesting
<paroneayea>hm
<paroneayea>is the default image-size in guix system vm-image 100MB? is that what I'm reading?
<civodul>i think the default is bad no matter what
<paroneayea>I put together a pretty minimal image with just the base packages and openssh in it
<paroneayea>and it ran out of space
<paroneayea>or memory
<paroneayea>not sure which
<civodul>you need to specify the image size you want
<paroneayea>[ 1054.818598] SLUB: Unable to allocate memory on node -1, gfp=0x2080020(GFP_ATOMIC)
<paroneayea>error: committing transaction: database or disk is full
<paroneayea>
<civodul>try "guix size `guix system build foo.scm`" to get an idea
<paroneayea>civodul: oh hm ok
<civodul>i realize the command could make that guesswork for you
<paroneayea>probably a good idea
<paroneayea>also, I wonder if guix system vm-image should have an option to write the file to somewhere outside the store instead
<paroneayea>seems silly to generate the file, immediately move it outside the store, then gc
<paroneayea>and what if I needed to generate a 30GB image or something
<paroneayea>though, I guess COW-store resizes as needed? or do i remember wrong
<civodul>hmm not that simple
<civodul>"cow-store" is the service within the installation image, nothing more
<paroneayea>oh sorry, I mean the qcow2 format
<paroneayea>getting my cows mixed up!
<civodul>:-)
<civodul>but you're right, the extra copy in (guix build vm) is silly
<civodul>ACTION pokes at this
<paroneayea>--image-size is in bytes, right? it looks that way from scheme
<civodul>you can say --image-size=1G
<paroneayea>civodul: ah, nice! it doesn't make this clear in the docstring
<civodul>the manual mentions it, i think :-)
<paroneayea>oh
<paroneayea>ACTION should RTFM ;)
<paroneayea>(I did, but I'm missing things clearly.)
<jje>been following the mailing list (help-guix) concerning network-manager-service. getting unbound variable: wpa-supplicant-type. is there another module i need to add besides (gnu packages admin)?
<Sleep_Walker>wpa-supplicant-service-type
<Sleep_Walker>from (gnu services networking)
<jje>ok thank you much!
<paroneayea>I massively appreciate my libre x200 but I'd love for virtualization to not be as slow as butts
<paroneayea>and for opengl to generally work
<paroneayea>here's hoping that Intel ME disabling stuff works out :)
<rekado>paroneayea: do you use Libreboot on the X200?
<paroneayea>rekado: yup
<paroneayea>rekado: had to disable the hardware kvm support stuff
<rekado>yeah, that’s what I find really sad about Libreboot on my X200s :-/
<rekado>without hardware acceleration virtualisation is unusable
<paroneayea>yeah, and it would be really nice as a system to test a new system configuration before I boot it
<paroneayea>but I'm just like, well it's faster to just reboot into it and roll back if needed!
<paroneayea>and it'll be even *more* useful once GuixOps is a thing
<paroneayea>so hopefully, I'll eventually have a way for things to not be so slow.
<paroneayea>still, it's nice that *most* things work nicely enough for day to day stuff.
<civodul>and it gets better every single day!
<paroneayea>civodul: :)
<paroneayea>civodul: I'm not sure the state of hardware is getting better every day, but I do feel like the state of "libre" gets better every day, so :)
<paroneayea>there is hope!
<rekado> https://www.crowdsupply.com/raptor-computing-systems/talos-secure-workstation
<paroneayea>rekado: yeah I hope that makes it
<paroneayea>damn expensive though (and yes, for good reason)
<rekado>it’s a pity that it’s so very expensive
<rekado>can’t afford to spend that amount of money
<davexunit>yeah too pricy for me, and I bought a Novena.
<bavier>it was easy supporting the eoma68 crowd-fund, but the talos is a quite a bit harder
<civodul>paroneayea: oh i thought you were referring to the state of GuixSD
<rekado>I’m checking the progress of their campaign regularly but it doesn’t look good
<civodul>the state of hardware is very sad
<paroneayea>civodul: the state of GuixSD is definitely getting better every day :)
<paroneayea>quite a project to be part of
<rekado>this one is nice: https://www.crowdsupply.com/onchip/open-v
<paroneayea>I am always excited to see what's happening in Guix land.
<rekado>too slow, but a great start
<paroneayea>whee, finally built a vm image with "guix vm-image" :)
<paroneayea>now let's see if I can tweak it to the point where it runs on rackspace cloud
<civodul>would be nice, share your experience when you're done
<paroneayea>civodul: if I get it working, I will :)
<civodul>even if you don't ;-)
<paroneayea>:)
<paroneayea>btw what's the status of https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24703 ... should I be afraid to "guix gc" still? :)
<civodul>that thing needs a full rebuild that hasn't been done yet
<civodul>however, there are that many grafts yet, so chances are you won't hit that bug
<civodul>*there aren't
<paroneayea>ok :)
<civodul>not a great situation, but it'll be fixed eventually
<paroneayea>ACTION waits a bit longer, not out of space yet! :)
<civodul>heh