IRC channel logs

2024-06-13.log

back to list of logs

<bdju>how do I start pcmanfm-qt in a way that it uses wayland instead of xwayland?
<bdju>setting QT_QPA_PLATFORM to wayland doesn't work, says the plugin wasn't found
<efraim>bdju: IIRC you need qtbase and qtwayland in the environment for QT_QPA_PLATFORM to find wayland
<bdju>ah thanks. looks like I have qtwayland but maybe not qtbase
<bdju>trying to install it mentions conflicting entries so maybe I do have it
<bdju>just wasn't explicitly in my manifest
<efraim>you might also have to check if you need qtbase or qtbase@5
<efraim>I ended up making my own version of qutebrowser wrapped with qmake6 (for qtbase@6) and qtwayland
<efraim>I'm not sure there's a good solution in Guix currently though, I don't necessarily think we should need to wrap everything that could use qtwayland but clearly Something Needs To Be Done™
<efraim>ACTION wonders what the minimum needed is from qtbase and qtwayland to provide wayland support for Qt applications
<civodul>Hello Guix!
<efraim>o/
<janneke>\o
<efraim>looks like fftw should get the tunable? property
<civodul>efraim: doesn’t it use IFUNC or similar?
<efraim>I'll take a look. IIRC openblas uses IFUNC, but if you tune it you get a smaller library
<efraim>it might be worth adding that as a note somewhere by openblas so others don't try to test marking it tunable
<efraim>'grep IFUNC fftw-3.3.10' didn't return anything, I'll take a real look
<efraim>from their manual: Enable various SIMD instruction sets. You need compiler that supports the given SIMD extensions, but FFTW will try to detect at runtime whether the CPU supports these extensions. That is, you can compile with--enable-avx and the code will still run on a CPU without AVX support.
<civodul>ah, nice
<civodul>cbaines: hey! do you think you could restart https://qa.guix.gnu.org/issue/69591 ?
<civodul>i forgot the incantation, shame on me
<cbaines>civodul, looks like it's too old to be considered. Resending the patch series will change that
<cbaines>unfortunately there isn't an easier way currently
<cbaines>maybe QA could look at a debbugs usertag to prompt it to process specific older issues
<civodul>cbaines: ok, thanks for checking
<civodul>maybe i’ll resend on their behalf
<efraim>civodul: the output size of fftw after re-enabling the -mtune=native is the same size as before
<civodul>we shouldn’t use -mtune=native or -march=native, as this becomes non-reproducible
<efraim>agreed, and it may not run on everyone's machine
<civodul>yup
<civodul>but from what you wrote above, ‘--enable-avx’ should be a good match for us?
<nikolar>out of curiousity, what's the state of the guile rewrite of guix-daemon
<efraim>it's already there, with a bunch of other flags
<cbaines>nikolar, I've sent some patches to #70494 and I've got some more that I haven't sent yet which a for a very basic daemon which has initial support for some operations
<peanuts>"[PATCH 00/23] Groundwork for the Guile guix-daemon" https://issues.guix.gnu.org/70494
<nikolar>so it's still alive
<nikolar>neat
<cbaines>unfortunately I've been very distracted over the past couple of months working on the bordeaux build farm and QA
<jakef>hopefully worthwhile distractions! :)
<futurile>Morning all
<nikolar>Hello
<nikolar>cbaines: are you the main guy working on the guile daemon
<bonni>hi I am currently trying to create a qemu image for arm64 but building bash fails with the error that I am on amd64, this is my command: guix system image --system=aarch64-linux --image-type=qcow2 ~/guix/gnu/system/examples/bare-bones.tmpl --no-offload what am I doing wrong?
<cbaines>--system=aarch64-linux will built it natively, so either you need to have emulation available, or switch to cross building (via --target)
<nikolar>does guix currently support anything other than x86 and arm
<cbaines>nikolar, yep
<nikolar>huh nice
<nikolar>is there a list
<cbaines>guix build --list-systems and guix build --list-targets will give lists
<cbaines>there's also a list here https://guix.gnu.org/en/manual/devel/en/html_node/GNU-Distribution.html
<peanuts>"GNU Distribution (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/GNU-Distribution.html
<nikolar>huh powerpc and mips
<nikolar>not bad
<nikolar>there are avr and or1k targets
<nikolar>what does that exactly mean, that guix the tool will work there?
<wolfdog>you'll probably want to see the list of systems to see where guix the tool will work, afaik targets are just for cross-compilation
<msavoritias>anyone has the link to opt out from my code being included in software heritage? their site doesnt make it at all easy to find :(
<ieure>msavoritias, I still have a bunch of open questions about this. :/
<ieure>I'm not sure whether the archive requests Guix sense will add it right back.
<ieure>I think you have to email them.
<msavoritias>oh jesus okay then. i will email them and ask them to blocklist my repos/account i guess
<msavoritias>ieure have they actually given any reply to the issues that were posted the other day?
<ieure>msavoritias, No.
<msavoritias>ok
<ieure>msavoritias, You'll also want to beg "HuggingFace" to remove your stuff from their LLM.
<ieure>Because SWH gave them everything. And they output derivative works from that training set which mixes incompatible licenses and contains no attribution.
<ieure>I hate "AI."
<msavoritias>there is no code written yet
<msavoritias>so i want to see if i can block it from appearing in the first place
<ieure>And am just completely baffled that I seem to be the only one who thinks that stealing GPL'd source to launder into proprietary projects through LLM tumbling is not a hair-on-fire moment for Free Software.
<msavoritias>same same
<singpolyma>Luckily that's not happening yet. But I agree if it starts happening it's not great
<singpolyma>Though given that the GPL usually goes unenforced it wouldn't be a *huge* change to the status quo
<ieure>singpolyma, How would you know if it's happening? HuggingFace's *own StarCoder playground* gives unattributed code derived from their training set, right now, today.
<ieure>You can literally just go there and see it.
<msavoritias>ah just verified nothing is actually of my code in SH
<msavoritias>so heads up i sent SH an email asking if their AI stuff has changed and if not to block my code from ever being in the archive of SH
<msavoritias>will reply back here if or when they reply
<msavoritias>(hope they do)
<Guest44>I have a channel for packaging a local package with file:// as uri.  Currently I use the full path /home/... but how can I use a relative path?  Basically I want to use the channel directory
<freakingpenguin>Guest44: I use (channel (url (string-append "file://" (getcwd)))) if I want a channel that refers to the current repository.
<freakingpenguin>Probably could make it relative to the channels.scm file itself and not the cwd with current-source-directory in (guix utils).
<Guest44>freakingpenguin: Ah thanks. getcwd was it
<ngz>What is the URL where one can see what bordeaux build farm is currently up to?
<civodul>ngz: https://bordeaux.guix.gnu.org/activity
<peanuts>"Activity bordeaux.guix.gnu.org Build farm" https://bordeaux.guix.gnu.org/activity
<ngz>Ah! Thanks.
<civodul>that page really rocks
<ngz>Better than watching TV
<ngz>What are supposed to do upstream-source-compilers during an update? (Besides compiling upstream source records…).