IRC channel logs

2024-06-29.log

back to list of logs

<JetpackJackson>im gonna copy the checkouts folder from /root/.cache/guix (which has both channels) to ~/.cache/guix
<JetpackJackson>drat ok it still doesnt update so i think im gonna check my git config cause the error does say "git error"
<ieure>Yeah, maybe root's ~/.ssh/config has stuffy your user doesn't?
<JetpackJackson>how strange. there's nothing there
<JetpackJackson>in roots .ssh
<JetpackJackson>but root is the one thats working
<vagrantc>hrm. i am trying to inject some randomness into a package definition ... it takes a --with-os-version= configure argument ...
<vagrantc>from the guile REPL this *seems* to do what I want ... (string-append "--with-os-version=" (number->string (random 100)))
<vagrantc>but that bombs out when injecting into a package definition configure arguments ...
<vagrantc>error message https://paste.debian.net/1321793/
<vagrantc>hrm. i thought string-append outputs a string?
<vagrantc>is ... (string-append "x" "y") != "xy" ... ?
<vagrantc>will have to poke at this some other time ...
<ntczq>Maybe it's quoted
<JetpackJackson>strange, im getting "(exception misc-error (value #f) (value "no code for module ~S") (value ((packages arduino-cli))) (value #f))" when i sudo guix pull my updated channels file with my packages in it
<JetpackJackson>but ive organized it like how others have organized it so idk whats going on
<freakingpenguin>JetpackJackson: directory is added to the load-path root, not counting that directory. So you're trying to define a (pita-packs packages arduino-cli) in a GUILE_LOAD_PATH/packages/arduino-cli.scm file
<JetpackJackson>oh
<freakingpenguin>You'd either need to remove directory in .guix-channel or remove pita-pack from your define-module declarations.
<JetpackJackson>alright thank you
<JetpackJackson>lowkey forgot i had the "directory" variable in there
<jfred>Hmm. I've been having Shepherd hang sometimes after "guix system reconfigure"s, and there's issue #67538 which seems similar but also was fixed in 0.10.3...
<peanuts>"Shepherd stops responding during "guix system reconfigure"" https://issues.guix.gnu.org/67538
<freakingpenguin>Possibly fixed, #65463 was similar and seems fixed but I never figured out why
<peanuts>"Herd `fport_write: Broken pipe` error when running `guix home reconfigure`" https://issues.guix.gnu.org/65463
<jfred>I'm on 0.10.4 though
<jfred>so I wonder if it's one of the previous issues not having been fixed or a new one (or something specific to my setup)
<freakingpenguin>It's possible the bug's still there and just went into hiding for a bit. I wonder if the symptoms in 65463 match what you're experiencing (although that's the home shepherd, not system)
<jfred>you know now that I think about it I think I've had this happen on my other laptop on a home shepherd instance too
<jfred>I was troubleshooting a bunch of other stuff at the time so didn't look into it in too much detail, but maybe...
<freakingpenguin>Weird stuff for sure
<jfred>guess I've got a few reported issues to look through next time and see if my issue matches any of them
<freakingpenguin>Best of luck. These bugs seem to come and go and seemingly nobody's never identified the cause. It'd be lovely to iron them out.
<JetpackJackson>yknow, when i git clone/push to my repo, i always have to use my ssh key to do so. maybe guix pull is getting stuck at that part
<JetpackJackson>good news: removed the passphrase on the key and got the repo to download
<JetpackJackson>bad news: repo doesnt show up in guix describe and i cant install any of the packages from it
<freakingpenguin>guix time-machine -C channels.scm -- describe doesn't give the right output?
<JetpackJackson>without sudo it does that git error again: "guix time-machine: error: Git error: failed to start SSH session: Unable to exchange encryption keys"
<JetpackJackson>rerunning it with sudo now
<JetpackJackson>one moment
<JetpackJackson>this may take a few minutes ("computing Guix derivation")
<JetpackJackson>ok sudo time machine worked, shows both channels
<JetpackJackson>sorry it took me forever to get back to you
<JetpackJackson>i guess tomorrow ill figure out why sudo is the thing that makes stuff work
<JetpackJackson>freakingpenguin: thank you again so so much for your help today
<freakingpenguin>JetpackJackson: With the following channels.scm describe works just fine for me, not prompted for SSH or anything. https://paste.debian.net/1321799/
<JetpackJackson>alright ill try that real quick
<freakingpenguin>I'm not sure what the problem is but hopefully that helps you narrow it down to "probably not the channels.scm or repo itself".
<JetpackJackson>guix pull -C channels.scm does not work so i guess its something else then
<JetpackJackson>especially since i can install the pita-packs packages in the root profile using time-machine
<JetpackJackson>ok specifying a profile works with the sudo time machine
<JetpackJackson>interesting
<JetpackJackson>i need to shut down for now though, thanks again
<freakingpenguin>You're welcome, best of luck
<JetpackJackson>thanks
<JetpackJackson>oh and ieure, thank you for your help as well!
<adanska>hmm, `xdg-desktop-portal` seems to have a flaky test in the `test-portals` check. for me, it failed on the `/portal/inhibit/delay` portal check, but passed the second time. It seems that its failed on CI and the substitute isnt avaliable.
<adanska>oop, now its failing on `tests/test-document-fuse.sh`, `capsh: command not found`
<adanska>it seems like it needs a `libcap` in the inputs (or native-inputs, not sure if its needed outside of building/testing)
<PotentialUser-23>hello. how can i set my default shell to fish?
<ngz>cbaines: This doesn't bode well: <https://qa.guix.gnu.org/branch/core-updates>
<andrewzhurov>Heyo! Why does `guix gc` deletes packages that are needed by `guix`? So you call `guix something-something` afterwards and it downloads freshly removed packages. My expectation would be for it to keep deps of current roots. Is it intended? A tip on how to fix?
<ngz>andrewzhurov: It preserves inputs and propagated inputs, but not native inputs. It may be downloading native inputs required to build something.
<ngz>It depends on the `guix something-something`
<andrewzhurov>Aha, thanks. I noticed rde rebuilds `chromium` and `node` (it's hard to miss, takes hours:), despite them being in profile. But maybe it builds a new version of them, didn't note, so nevermind.
<andrewzhurov>As to `guixc smth-smth`, I ran `guix gc -F 20G` which deleted `meson`, after that running `guix system delete-generations` downloaded it back again.:)
<andrewzhurov>There are flags to `gc` to keep native inputs, yay! For those alike struggling with delete&redownload: https://yhetil.org/guix-bugs/87plsygypx.fsf@kitej/
<andrewzhurov>flags to `guix daemon`*
<PotentialUser-23>hi, is there a way to unset user environment variables?
<futurile>PotentialUser-23: env command?
<PotentialUser-23>im a complete noob, i want to unset GHC_PACKAGE_PATH, how with env path so its permanently unset in user env?
<PotentialUser-23>reason being it conflicts with cabal
<PotentialUser-23>env -u GHC_PACKAGE_PATH doesnt mutate the env variable state.
<PotentialUser-23>it semes to just return a list of the env variables without GHC
<PotentialUser-23>i think guix makes this read only, so i think, correct if wrong, that it must be done within guix home somehow, but i dont know how.
<PotentialUser-23>i simply want to unset one variable.
<PotentialUser-23>zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
<PotentialUser-23>unsetenv exists as a guile command...
<PotentialUser-23>built a new home environment with that in there but did nothing.
<futurile>PotentialUser-23: you said you're a 'noob', do you understand how shell environment variables work generally?
<PotentialUser-23>no.
<PotentialUser-23>only that i can set them and delete them and print them with env
<PotentialUser-23>dont know exactly where they're stored, or how programs access them, or how guix changes that, and so forth.
<futurile>PotentialUser-23: why do you want to unset GHC_PACKAGE_PATH?
<PotentialUser-23>i set it withย  (simple-service 'env-vars
<PotentialUser-23>ย  ย  home-environment-variables-service-type '(...)), but now im having trouble getting rid of it
<PotentialUser-23>oh just so i can use cabal
<PotentialUser-23>cabal build
<PotentialUser-23>cabal: Use of GHC's environment variable GHC_PACKAGE_PATH is incompatible with
<PotentialUser-23>Cabal. Use the flag --package-db to specify a package database (it can be used
<PotentialUser-23>multiple times).
<futurile>well you could (a) remove the variable with the simple service thing
<futurile>second you can just manipulate it in your bash shell by using set/unset - a google search turned up this artcile - https://www.tecmint.com/set-unset-environment-variables-in-linux/
<PotentialUser-23>i was having trouble with the second approach.
<PotentialUser-23>because the changes are not permanent.
<PotentialUser-23>i can run a script that runs unset but then its set again on the next call
<PotentialUser-23>i think its read only or something.
<PotentialUser-23>anyway thanks for using brain energy to think up a response.
<PotentialUser-23>will go and try some stuff
<PotentialUser-23>V
<thanosapollo>how can I disable substitutes and build everything from source, after already installing guix
<thanosapollo>couldn't find it on the docs, only info on foreign distro by restarting the daemon
<rrobin>there is a --no-substitutes argument
<rrobin>e.g. in guix build
<rrobin>in the manual it shows up in guix daemon, but also guix build https://guix.gnu.org/en/manual/devel/en/html_node/Common-Build-Options.html
<weary-traveler>guix pull seems to be lagging from current state of guix git repository. is this expected?
<weary-traveler>i thought if --no-substitutes is given it should fetch the latest
<cbaines>what do you mean by lagging weary-traveler?
<weary-traveler>cbaines: git is at b6ef3cfdf0e948f3f5e291cbfefea5e5a13068a7 but guix pull is fetching 78b881722f08325c76096557313a0faee847c66f
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=b6ef3cfdf0e948f3f5e291cbfefea5e5a13068a7
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=78b881722f08325c76096557313a0faee847c66f
<cbaines>weary-traveler, do you have this file ~/.config/guix/channels.scm ? If so, what is the contents?
<weary-traveler>cbaines: https://paste.mozilla.org/Okkam6NP
<cbaines>weary-traveler, looks like you've configured guix pull to sometimes not fetch the latest commit from the Git repository?
<weary-traveler>cbaines: it seems i've misunderstood that snippet then. it's effect isn't undone by --no-substitutes?
<cbaines>nope, all that'll happen in that case is guix pull will pick a commit with substitutes, but not use them
<weary-traveler>i see. so the only way is to not have that in channels.scm for the time being, iiuc
<weary-traveler>cbaines: thank you
<thanosapollo>thanks rrobin!
<thanosapollo>but I was just looking to disable substitutes entirely, I think removing substitute urls might do the trick
<JetpackJackson>freakingpenguin: ok i think i fixed the guix pull issue: i had a line in my git config that forced codeberg to use ssh instead of https... idk how i missed that lol
<rrobin>thanosapollo: guix-daemon has the same option, or if you are using guixsd you can configure the guix-service-type with use-substitutes? #f
<thanosapollo>I was going for setting (substitute-urls '()) didn't see the use-substitutes?, you saved some headache, thanks!
<freakingpenguin>JetpackJackson: Nice! It's always the one thing you configure and forget about.
<faust45>Hi guix!
<faust45>I have install guix-1.4.0 on my laptop thinkpad x13 but couldn't boot the system
<faust45>udevd[272]: no sender credentials received, message ignored
<faust45>Error: Driver 'pcspkr' is already registered, aborting...
<faust45>hci0: fails to request rampatch file: /*DEBLOBBED*/ -2
<faust45>hci0: Missing Free firmware (non-Free firmware loading is disabled)
<faust45>how can I fix that?
<jonsger>faust45: I guess you need non-free firmware which is not part of guix
<JetpackJackson>freakingpenguin: indeed lol. im just happy it wasnt something more involved
<faust45>but with nonguix I have the same errors
<cbaines>hci0 seems to be bluetooth related, and if it is I doubt it's preventing boot
<freakingpenguin>faust45: Google associates "fails to requets rampatch file" error with a bluetooth/wifi issue. You could try booting without the m.2 card inserted although I don't understand why that would halt boot.
<freakingpenguin>The pcspkr error is benign. I get that too.
<faust45>freakingpenguin I "fails to requets rampatch file" can be critical for boot process?
<freakingpenguin>faust45: I don't know but it would surprise me. The installer image booted fine, right?
<dmirth>Hello ... I have a sort of off-the-wall question: I'm doing a manual guix installation which requires that the HDD partitioning be done manually, obviously. But is it possible to script that somehow within guix?
<dmirth>Any suggestions would be welcome
<faust45>freakingpenguin: yes boot from image on flash was success
<freakingpenguin>dmirth: I don't know how to handle it at present, but in the future with #69090 merged and #71657 is fixed you might be able to just flash an image to the disk that'll resize itself.
<peanuts>"[PATCH] gnu: services: Add resize-fs-service." https://issues.guix.gnu.org/69090
<peanuts>"Improve support for generating system images with different file systems" https://issues.guix.gnu.org/71657
<fnat>dmirth: One of the first things I usually do is to enable SSH access to that I can then do most of the installation from a remote machine. This doesn't answer your question but perhaps it might be easier to do the disk configuration from another machine?
<dmirth>freakingpenguin: Thanks! I see where you're going with that. I think I might be able to work with that now.
<dmirth>fnat: I had not thought of that at all! Good idea ... I'll give it a try as well!
<faust45>have you any suggestions, how I can fix "Error: Driver 'pcspkr' is already registered, aborting..."
<graywolf>Hello :) Where can I find the output (stdout, stderr) of the activation-service-type?
<freakingpenguin>graywolf: I think they'd use whatever stdout/stderr is present during boot-system in (gnu build linux-boot) since they're run as part of boot-service-type. I don't think they'd log to a file in that case since that's runs before rootfs is mounted.
<freakingpenguin>I could be missing something though.
<freakingpenguin>Since #70451 was merged, any chance someone could look at #70314?
<peanuts>"[PATCH] gnu: system: Add nss-certs to %base-packages." https://issues.guix.gnu.org/70451
<peanuts>"[PATCH] guix: scripts: environment: add tls certs to networked containers" https://issues.guix.gnu.org/70314
<freakingpenguin>There's some odd behavior at present that can crop up under certain circumstances when trying to use nss-certs in a guix shell container since SSL_CERT_DIR/FILE aren't set at present.
<freakingpenguin>The summary is you also need to add something like curl for it to take effect that registers it as a search path which can cause TLS breakages in other packages such as rust-cargo that don't register said search path, making TLS operations fail even when nss-certs are present. https://paste.debian.net/1321851/
<graywolf>freakingpenguin: and during system reconfigure it would go where?
<attila_lendvai>i start a `guix system --debug=100000 vm ...` and it just quits, without any hint of what the error is.
<ngz>cbaines: IIUC, bordeaux is still building previous core-updates branch (revision f14d43c1). Would it make sense to stop it to leave more computing power for other tasks?
<cbaines>it's probably fine to let it continue for now, higher priority builds will automatically take over
<ngz>Yes, but isn't it a waste since we know for sure the same packages are going to be rebuilt?
<ieure>Anyone aware of debbugs.gnu.org MTA problems? Sent a patch in this morning, but it couldn't be delivered, "no route to host."
<ieure>Guess it could be a Fastmail issue or something in between, but GNU infra seems more likely.
<eftsoon>ieure: https://hostux.social/@fsfstatus/
<eftsoon>lots of brokenness lately
<ieure>Thanks.
<Guest44>Anyone know how I can configure GNU Guix without X with the spice-vdagent-service-type?
<madeleine-sydney>what can i do about a bunch of `fork: retry: Resource temporarily unavailable` and `vfork: Resource temporarily unavailable` errors during a build? some way to lower the number of jobs guix runs?
<freakingpenguin>madeleine-sydney: You can limit the number of cores used with --cores, e.g. guix build hello --cores=3
<freakingpenguin>Not sure if that's the problem.
<madeleine-sydney>not confident either, but we'll see :p. rebuilding now.
<madeleine-sydney>yeah, limiting the cores didn't help. :\
<JetpackJackson>whats the best way to manage multiple guix.scm files from repos that dont provide channels for their packages?
<JetpackJackson>i have two guix.scm files that rely on their respective git info to work lol
<SomniusX>Trying non Guix on a macbook air mid 2013 with one of my friends dotfiles for system home etc.
<SomniusX>Still can't figure how to enable wireless broadcom-wl
<SomniusX>Anyone can share some light? ๐Ÿ˜…๐Ÿ˜๐Ÿ˜”
<cmiller>Anyone know how I can configure GNU Guix without X with the spice-vdagent-service-type?
<sergiodj>hi folks, can I have a review of snac2 (bug #71587), please? I know things are down right now, no rush
<peanuts>"[PATCH 0/2] Rename mastodon.scm -> fediverse.scm and add snac2" https://issues.guix.gnu.org/71587
<cmiller>To my question, I can just use SSH. Don't know why I thought that complicated.
<ngz>sergiodj: At first glance, the snac2 package style could be updated: use G-exp, remove trailing #t from phase. Use #$output instead of %output. You also need to explain why you're disabling tests and configure phase. I also suggest (nitpicking) to move inputs below arguments. I also think the description could be better. But it may be just me: I'm not a huge fan of lists as description (sometimes, it is difficult to write it otherwise,
<ngz>tho).
<dgr>what todo about build of info.dir.drv failed?
<dgr>install-info: /gnu/store/b1dc9qrjaq1gdbrjwjg4z8xxqd6c5kp2-wget-1.21.3.24/share/info/wget.info.gz: empty file