IRC channel logs

2024-07-03.log

back to list of logs

<marmar_51>Is there a way to separate my config files so that I can do `guix system reconfigure $machine.scm` with a base config.scm that is shared between the machines
<jakef>marmar_51: you could use (load "./common-config.scm") or create your own module and import it
<cnx>Hi, may I have some eyes over at https://issues.guix.gnu.org/71143 (small fix for gitile service)
<simendsjo> I cannot get --load-path to work for guix system image, and have to use GUILE_LOAD_PATH instead. Why is that, and what's the best approach? More details here: https://gist.github.com/simendsjo/862771b3b98098adb99c0ae4bd11b3f8
<Franciman2>Hi, I have this configuration: pc1 (with guix) connected to internet via wifi and pc2 connected to pc1 via ethernet
<Franciman2>how can I make pc1 act as bridge so that pc2 can connect to internet?
<dariqq>Franciman2: Does it work if you in nm-applet edit the wired connection ipv4 method to "shared with other computers"?
<Franciman2>dariqq: i can try, would be awesome
<Franciman2>dariqq: do i need to set that option on pc1 or pc2 or both?
<dariqq>i think pc1 but not sure . havent needed to this in a while
<marmar_51>Is there any extra setup for flatpak than the one at flatpak.org? Using `flatpak run $app` after installing an app just hangs indefinitely. Same thing happens after a reboot
<Franciman2>ok i did this i think
<Franciman2>dariqq: it worked like a charm
<Franciman2>thanks a lot
<dariqq>Franciman2: awesome :)
<simendsjo>I try to start sway from by .bash_profile using [ "$(tty)" = "/dev/tty1" ] && exec sway, but I get "Error in service module". Opening another tty and running the same code works.
<redacted>It looks like /etc/subuid and /etc/subgid don't work as symlinks. getsubids exists with an error
<redacted>That means I can't use extra-special-files to create those files
<redacted>What approach should I use?
<redacted>ah, didn't notice that etc-service-type exists
<weary-traveler>convention wise, what's the distinction between guix.scm file and manifest.scm? is it accurate to say that guix.scm would provide the package definition and then manifest.scm provides a manifest including the development inputs?
<trevdev>Hey so...dbus services. If I launch StumpWM from GDB after having just simply installed it in my system configuration, org.freedesktop.Notifications is no longer provided by any .service files. Any suggestions?
<sneek>trevdev, you have 1 message!
<sneek>trevdev, efraim says: stumpwm:lib was just merged back into stumpwm so I wouldn't worry too much about trying to use stumpwm:lib at this point
<trevdev>efraim: Thanks for this, I did eventually figure that out. But also if anybody wants specific outputs, you would use a list to lower them as well.
<weary-traveler> https://guix.gnu.org/cs/blog/2023/from-development-environments-to-continuous-integrationthe-ultimate-guide-to-software-development-with-guix/ is useful
<weary-traveler>(answering my own question above)
<Gooberpatrol66>i set up the cuirass service, but it doesn't seem to build anything. it just does an infinite loop of "fetching channels", "evaluating with token #0", "polling jobset after 60s timeout expiry". am i missing something?
<dlowe>any way to get a pkg-config entry for libxml2 added?
<trevdev>dlowe: `guix search libxml2` shows it's already packaged if that's what you mean
<dlowe>That's not what I mean. pkg-config is a standardized way to get build flags
<dlowe>The data files end with .pc
<dlowe>if I wanted to build something with libxml, I could run pkg-config libxml-2.0 --cflags and it would output the necessary flags for it to build
<trevdev>I think I get it. And you're looking to build that thing with a guix derivation?
<dlowe>guix has some .pc files (inconsistently in lib/pkg-config and share/pkg-config) but not for libxml2
<dlowe>This is something I'm building with autoconf outside a derivation
<trevdev>Yeah I've been meaning to get more into how C builds stuff. I'm slow there. So you're looking for some outputs that libxml2 is missing for your standard build flow?
<dlowe>it's more autoconf has some convenient setup macros for pkg-config
<dlowe>KG_CHECK_MODULES([XML], [libxml-2.0])
<dlowe>*PKG
<attila_lendvai_>gpg keyring: i'm following the manual, `gpg --export [hash] | kbxutil --import-openpgp >>~/.config/guix/upstream/trustedkeys.kbx`, but then `guix refresh` gives me errors like "gpgv: [don't know]: invalid packet (ctb=00)"
<dariqq>dlowe: i ran guix build libxml2 and there is a lib/pkgconfig/libxml-2.0.pc. there.
<trevdev>dlowe: *whoosh* yeah sorry I wish I could be more helpful
<dlowe>hm. weird.
<dlowe>omg I didn't have it installed in this profile. Sorry for wasting everyone's time :p
<dlowe>Thanks, dariqq
<trevdev>At least it's an easy fix
<attila_lendvai>and `guix refresh` cannot download the key. when i say yes to add it to the keyring, then it does not import it because it has no user id.
<weary-traveler>are the licenses in the "guix licenses" module intended to be exhaustive?
<dlowe>(should probably configure pkg-config search paths, though)
<weary-traveler>i have a project $foo that uses a license that's not listed in guix licenses. i'm wondering what the best approach is to deal with that.
<dlowe>(oh, that's why it wants me to run the profile script again. nvm)
<attila_lendvai>ok, FTR, the problem is that some keyservers, e.g. keys.openpgp.org, strip the user ID. the solution was to use another keyserver: `./pre-inst-env guix refresh --key-server="hkps://keyserver.ubuntu.com" --update [pkg name]`
<trevdev>weary-traveler: There are 73 exports in guix/licenses.scm seems like a lot to me
<trevdev>weary-traveler: expat is what I've used for "who knows?" for me
<weary-traveler>trevdev: except it's not the expat license. it's not that the license is unknown. it's known. it's simply not one of the 73
<trevdev>Actually there are way more than 73 exports in licenses, there are 73 lines of exports. Multiple licenses per line
<trevdev>What's the license?
<weary-traveler>cc-by-nc-4.0
<weary-traveler>(though i'm not sure how that specifically matters)
<trevdev>Looks like a contribution waiting to happen :)
<trevdev>If you're going to contribute upstream it probably matters. If it's your own channel, it's up to you
<weary-traveler>right, so back to my question. the intent of guix licenses *is* to be exhaustive?
<trevdev>My compulsion is to say yes but I'm not qualified to answer
<weary-traveler>i'm hoping one of the people here is one who is qualified to answer before i take the time to submit a patch
<trevdev>Just add the license and bask in the glory, the scheme is easy
<trevdev>And if that's the wrong idea, somebody will definitely let you know
<weary-traveler>well the patches mailing list doesn't have the best record for timely responses =/
<trevdev>Fair, which is why I have my own channel. I package it there first, so I can use it as soon as it works for me
<trevdev>Then I contribute upstream. When they get to me, I can prune it from my channel
<weary-traveler>how do you add a license in your channel? the constructor for the license record seems to not be exported unless i'm misunderstanding
<trevdev>Copy-paste
<weary-traveler>i'm hoping that there's a better way than having to include various snippets copy-pasted from guix project in my channel
<ieure>weary-traveler, Does your channel use a license that's not already defined in the licenses module?
<weary-traveler>ieure: i have a package $foo that i'm including in my channel that uses such a license, ys
<weary-traveler>*yes
<ieure>weary-traveler, Ah, well. Lisp exported or not is pretty advisory, you can use @@ to get at the license constructor.
<weary-traveler>ieure: oh interesting. would you have an info reference for this "@@"?
<weary-traveler>and/or an example
<ieure>weary-traveler, It's in the Guile manual somewhere, or you can grep the Guix code for examples. Direct examples can also be found in certain third-party channels which support packages with similar licensing situations.
<trevdev>weary-traveler: I had to copy/paste to build my stumpwm contrib modules and contribute them. It's really not all that bad. For whatever reason Guix doesn't export stumpwm-contrib, but once I copied it, I stopped worrying about it. If the constructor is something you feel needs exporting, that could be a contribution, too
<apteryx>seems like nautilus should know to mount digital cameras via gvfs, which is built with libgphoto2
<apteryx>is nautilus supposed to pick 'gvfs' from PATH? or how does it detect gvfs support?
<attila_lendvai>apteryx, i don't know, but i just recently needed to quickly connect to some older cannon camera, and it didn't work... :/
<mirai>apteryx: I had to add gvfs into the packages field in operating-system for it to work
<apteryx>mirai: odd, thanks
<apteryx>ACTION wonder whether gvfs should be part of the desktop packages then
<apteryx>I guess it should work by picking up GIO_EXTRA_MODULES
<apteryx>but perhaps when using GDM some GVFS process is started early, before the user profile is part of GIO_EXTRA_MODULES
<apteryx>ACTION is thinking out loud
<futurile>I wouldn't be surprised - I thought it was assumed by GNOME apps
<mirai>IMO it shouldn't be in desktop-services since iirc KDE has its own thing but perhaps it should be included in gnome-service and xfce-service (pcmanfm uses it)
<apteryx>apparently we now have a gvfs-service-type, which augments the system profile with the gvfs package
<apteryx>I guess that's to be used for non-GNOME users
<mirai>the manual makes a passing mention of adding gvfs to OS packages for it
<apteryx>related thread: https://issues.guix.gnu.org/70508#0
<mirai>and someone has added a gvfs-service-type a while ago (I wanted to oppose to its addition since its just a simple profile extension but was late to the party/away)
<apteryx>prepared in the context of enabling some gvfs URI in thunar, the Xfce file manager.
<mirai>^^
<apteryx>it also pulls udisks as a dependency, IIUC though
<apteryx>so it does something of value as a service
<mirai>oh, I overlooked that line
<apteryx>ACTION notices the new mumi commands at the bottom of issues threads
<apteryx>fancy!
<apteryx>I'll try relogin in GNOME to see if my camera magically works there
<Gooberpatrol66>is it possible for a guix package definition to track the head of a git repo?
<Gooberpatrol66>that way you could use cuirass for CI on a repo without having to update the package definition with each commit
<ieure>Gooberpatrol66, No.
<ieure>Doing this would defeat reproduceability in package builds which is a fundamental goal of Guix.
<futurile>Gooberpatrol66: if you're building your own package you can do this - ieure means we don't track 'HEAD' each time - but for local development you can do that.
<futurile>Gooberpatrol66: is this for a local development dependency or something?
<Gooberpatrol66>futurile: yes
<Gooberpatrol66>how? do you just put "HEAD" in the commit?
<Gooberpatrol66>the version field i mean
<janneke>so, i've been trying to add "sonobus" -- https://gitlab.com/janneke/guix/-/commit/07e215244eff641ec7e1e1fb5f7b91f69b640682
<janneke>it either segfaults or hangs (polling a futex or somesuch indefinately)
<janneke>however, the nix package that i tried to copy works fine, any ideas where i could look?
<futurile>Gooberpatrol66: have a look at this: https://www.futurile.net/2023/04/30/guix-reproducible-dev-environments/
<futurile>Gooberpatrol66: there's an example 'local' guix package that uses a git commit from HEAD
<Gooberpatrol66>futurile: ty very much
<futurile>Gooberpatrol66: no worries
<apteryx>eh, I tried using GNOME (wayland) on my aging NV50 GPU and it was not a good experience
<apteryx>slow, with windows locking up or not being drawn at all
<apteryx>the 'GNOME (Xorg)' session type works well for it
<apteryx>OK, after making myself at home in GNOME a bit, I confirm the gvfs/libgphoto2 integration doesn't seem to work in Nautilus even when the session started is GNOME
<apteryx>I'll try reconfiguring with the gvfs-service-type added to my system
<apteryx>interestingly, /gnu/store/l38xglcs9hxynf33mhn22mnl8rgnnjkz-gvfs-1.50.7/libexec/gvfs-gphoto2-volume-monitor is already running as a process (I didn't start it myself)
<apteryx>looks like that is auto-spawned by dbus: https://github.com/GNOME/gvfs/blob/master/monitor/gphoto2/gvfs-gphoto2-volume-monitor.service.in
<apteryx>not everything works correctly in a 'GNOME (Xorg)' session for me still. some dlaiog don't open correctly, some windows flicker
<apteryx>I guess my GPU is too old for GNOME
<mirai>apteryx: re: gvfs have you tried restarting the whole system?
<Deltafire>i had some issues with gnome/xorg and went back to wayland
<Deltafire>'check' phasebuilder for `/gnu/store/4isdjpw11zqz2wpq2z4b6wz966gj7hlj-evolution-data-server-3.48.4.drv' failed with exit code 1
<Deltafire>ran reconfigure again and it built fine the second time
<apteryx>mirai: haven't added gvfs as a system package yet
<apteryx>but it seems to be available to the GNOME sessiona at least, as gvfs-gphoto2-volume-monitor was launched
<apteryx>another topic: privacy.resistFingerprinting.exemptedDomains appears to work in librewolf to disable fingerprinting for just a site
<apteryx>(to show the local time instead of UTC for example)
<apteryx>mirai: one thing I've found is this: https://github.com/NixOS/nixpkgs/pull/152289/files#diff-ea156126724d12af36575c83f32ffa65a6a0c1c719804fe8eebdd8789c194b8d
<apteryx>hm, we already od this for desktops... hm.
<ieure>Sigh, Savannah is down, returning 502s.
<ieure>Hm, guess it was a blip, it's back.
<sarg>hi guix, what is happening with CI? It seems to be idle for couple days
<ieure>sarg, Seems like it's hard down, I'm getting a 504.
<sarg> https://ci.guix.gnu.org/jobset/guix opens, but the jobs are pending since 2 days
<drakonis>oh hey, hurd supports smp on 32 bit x86 now
<drakonis>what a hurd day to be alive
<apteryx>best thing I've hurd today
<nikolar>lel
<freakingpenguin>These puns are hurding me
<aldum>hurd urr
<ieure>I will let you down / I will build The HURD
<freakingpenguin>Are the G_, N_, and P_ symbols documented anywhere? I see they're for internationalization in (guix i18n) but I'm not sure when we're supposed to use them.
<freakingpenguin>Or error handling best practices in general I guess. Sometimes we just use (error ...), other times it's a scary (raise (make-compound-condition ...)) call.
<freakingpenguin>Which would make sense if the latter was used when we need specific guard clauses, but they seem to be used even when we don't handle that error type.
<vagrantc>hrmpf. the openssh update broke diffoscope test suite ... and thus diffoscope fails to build :/
<freakingpenguin>vagrantc: Issue reported upstream and I see there's a commit that allegedly fixes it. https://salsa.debian.org/reproducible-builds/diffoscope/-/issues/382
<vagrantc>oh good!
<vagrantc>ah, DSA keytype removal ... that's been deprecated for ages, so no huge surprise