IRC channel logs

2024-08-10.log

back to list of logs

<freakingpenguin>lechner: You're welcome! (I'm shocked somebody read them hehe). Use case is to experiment with the Guix workflow language in guile-blocks. Unit tests in the package would of course need Guix WL.
<freakingpenguin>Rutherther: (info "(guix) Writing Manifests") shows an example of constructing a manifest entry from a computed-file construct. That page also shows how to construct a manifest from a list of entries and how to concatenate manifests.
<jaft_r>If you're packaging a bash script, is there a way to ensure that said script has access to the "lib" and "share" directories of its dependencies/inputs without just propagating said inputs?
<Xeroine>Hi, I've got Guix installed on a x86_64 PC, now I wanna get an image I can use to install on a aarch64 board (raspberry pi 4b). I tried the method mentioned here https://guix.gnu.org/manual/en/guix.html#Building-the-Installation-Image-for-ARM-Boards but for the system I used "aarch64-linux" and left the board name at some random value for now so it'll show me a list of boards. It started to compile
<Xeroine>bash but failed, in the log file it mentions that "'aarch64-linux' is required to build ... but I am a 'x86_64-linux'" so I guess it didn't figure out it should cross compile so I added a "--target" flag set to "aarch64-linux-gnu" yet it still doesn't want to compile and fails with the same error in the log file.
<Xeroine>Any idea what I can do to get it to cross-compile?
<robin>interesting, guix made in into the CL community survey results for dependency management purely via write-ins: https://blog.djhaskin.com/blog/common-lisp-community-survey-2024-results/
<jpoiret>sneek, last seen lfam
<jpoiret>huh
<janneke>sneek: seen lfam?
<sneek>I last saw lfam in #guix 5 days ago, saying: Of course they are running now so that's great.
<kaij>is there some docs on how to fork guix? not really sure how I should manage authentications. of course I can rewrite git history (add me key and an introduction ahead of the real introduction), but that seems like it would make contributing back very hard. is there a recommended setup?
<triangle-man>jaft_r: I'll investigate that idea! I think the other one is "MBR" -- or at least, that's the phrase I've read alongside GPT. Except, I didn't partition anything; the `guix system` was supposed (?) to do it, and I'm not sure how I *would* choose GPT if I wanted to.
<Rutherther>freakingpenguin: thanks, that showed me I forgot I had to also make it into a manifest, not just expose a list of manifest entries
<jpoiret>janneke: thanks :)
<jpoiret>triangle-man: `guix system` does not do any partitioning
<jpoiret>unless you're talking about `guix system image`
<jpoiret>but init and reconfigure do not
<nikolar>jpoiret: are you a maintainer or am I misremembering
<jpoiret>not a maintainer no, I have commit access but haven't done much in some months
<jpoiret>am just coming back to it now that i'm on holidays
<Rutherther>triangle-man: if you are running it in qemu, it's much easier to do legacy boot, not uefi. UEFI is a bit trickier to setup. So I suppose your VM is not using it right now and you would have to do additional setup - or have you done it already?
<Rutherther>triangle-man: additionaly, note that you need to be booted up under uefi already to be able to install the system with efi bootloader
<jpoiret>using uefi under qemu isn't that complicated, you just have to add the `-bios path/to/ovmf` argument
<jpoiret>if you're using bare qemu that is
<jpoiret>sneek, later tell lfam: rust has changed on master so we'll have to rebuild it anyways, t'would be a good time to merge boost and boost-for-source-highlighting
<sneek>Okay.
<pranavats>jpoiret: I'm happy your patches got merged in grub 2.12. I no longer have to apply them separately to use grub2 with luks2 now. Thanks.
<triangle-man>jpoiret: Yes -- exactly -- `guix system image`.
<triangle-man>Rutherther: I think I cannot do legacy boot because I'm on aarch64 (noting that any of my claims could be wrong!).
<triangle-man>(I'm running Ubuntu under QEMU on an M2 mac. I've installed Guix on the Ubuntu, and am attempting to make a Guix distribution image that I can run under QEMU.)
<triangle-man>(Ubuntu is booting with UEFI.)
<Rutherther>triangle-man: okay then, if you are already booted with uefi, then installing uefi system should work
<triangle-man>(I have also tried `guix system image` with `--image-type=efi-raw` and that produces an image; but under QEMU the boot process seems to hang after `shepherd[1]: Service mcron has been started.`)to get stuck before shepherd starts (
<triangle-man>It reminds of the good old days of installing Linux in the early 1990s, lots of trying things without much understanding of what is really going on!
<Xeroine>I can't get my image to cross-compile for aarch64, I'm running on x86_64 right now. This is the image https://bpa.st/LDSQ and it fails when building gawk-mesboot with these logs https://bpa.st/AHMA and I think this is related to this issue https://issues.guix.gnu.org/66866 but I'm not sure if it was fixed, they mention that grafts might be causing the issue in some closure, apparently --no-grafts
<Xeroine>should help but for me it still fails, now in the linux-modules package with the logs https://bpa.st/3WEQ
<PotentialUser-94>hey. anybody has a certbot dns plugin config to share? specifically with an mcron setup or shepherd timers?
<PotentialUser-94>i did a long investigation with another person today and turns out that the certbot service doesn't really work with any third party plugins currently. which is most of the dns providers
<PotentialUser-94>so instead of reimplementing the plugin (which sounds interesting at some point) i am looking to make it into a mcron thing and add the plugin to the path
<PotentialUser-94>right now i have https://paste.debian.net/hidden/051749f1/
<PotentialUser-94>which should work but it still can't find the package `python-certbot-plugin-gandi` in the path when i run the mcron job
<PotentialUser-94>the package exist and is imported ` (bechamel packages certbot-plugins)` at the top of the file
<maus>hello, I am trying to get Figma running from an AppImage in a guix container as detailed with VSCodium in this blog post https://guix.gnu.org/en/blog/2023/the-filesystem-hierarchy-standard-comes-to-guix-containers/ I'm able to launch the application successfully, can even get through the auth process by including chromium and xdg-utils in the
<maus>container, but after that I keep getting this error `(node:264) electron: Failed to load URL: https://www.figma.com/files/.../recent with error: ERR_INSUFFICIENT_RESOURCES`. I also get this `ERR_INSUFFICIENT_RESOURCES` error in Chromium itself (the container version) when visiting heavier websites and viewing the DevTools console. Wondering if
<maus>there is some resource limit being imposed on the container somehow? Here is the guix shell command I'm running to start the container https://pastebin.com/zuWAF6g0
<PotentialUser-94>how can i add modules in a gexp that are from channels other than guix?
<PotentialUser-94>if i add import the module on the whole file it works but inside the #~begin procedure it doesn't
<galois`>Can I develop a monogame game on guix with C# or would I need to use a VM?
<atweedie>has anyone tried loopback booting of a guix image?
<mange>PotentialUser-94: I think you can use something like (with-imported-modules (source-module-closure '((your module here))) #~(begin (use-modules (your module here)) ...))
<lvmer>I've added an LVM volume on new drive. A system reconfigure gives me a match-error with source: "vgrpool" targets: ("vgrpool-rpool"). Yet they exist and the /dev/mapper/vgrpool-rpool exists as well.
<PotentialUser-94>mange: that doesnt help sadly. doing it like this as per the manual https://paste.debian.net/hidden/d8b5085a/ still says that it can't find the certbot module
<PotentialUser-94>if I add the bechamel modules on the top use-modules field it finds them to reconfigure the system but then it complains when the mcron expression is run. because the modules dont exist inside the expressions for some reason
<PotentialUser-94>i did see the with-extensions thingy that is also being used in places in guix packages but that also didnt find the module
<PotentialUser-94>now i am looking if there is some magic combination of extensions, imported and use-modules to make the package appear in the path
<f1refly>I'm using NetworkManager to manage my wifi connections. For some reason, it puts the wrong ip into /etc/resolv.conf. When I connect to a friends wifi network, it still fills in my home dns resolver. Any ideas where things could go wrong?
<freakingpenguin>f1refly: Not sure, but if you're not using private urls you could set dns to none in network-manager-configuration and modify resolv.conf to point to a public namesearver.
<atweedie>ah, I see loopback booting is not yet supported!
<atweedie>there's a patch, but it seems stalled? https://issues.guix.gnu.org/issue/34863
<f1refly>freakingpenguin: I use my internal dns quite a bit when I'm at home, so a public dns won't cut it
<f1refly>I just noticed I set my name-service-switch to %mdns-host-lookup-nss, but I don't think that it should cause problems
<AwesomeAdam54321>Is it worth writing a package that contains 2 header files?
<AwesomeAdam54321>s/package/recipe for a package/
<ekaitz>any committer with some spare time? I have a very simple patch #72562 waiting for review (a packages update)
<peanuts>"[PATCH] gnu: chibi-scheme: Update to 0.11.0" https://issues.guix.gnu.org/72562
<ekaitz>for things like this i'd love to be a commiter...
<stencilv>Hi - I posted a question on reddit r/guix yesterday, but maybe will have better luck here. Really I have a question about the guix-kernel package. The suggestion on reddit was that I make an "issue" on the guix-kernel repo. But that repo is found on gitlab.inria.fr and it seems (?) that I'd need an account to open an issue...
<stencilv>The question concerns behavior of stdout in a jupyter lab. See https://pastebin.com/aam9QBzM
<attila_lendvai>stencilv, i don't know what is a guix-kernel package. is that the name of the package?
<stencilv>Yes.
<stencilv> https://gitlab.inria.fr/guix-hpc/guix-kernel
<attila_lendvai>oh, it's not the linux kernel... it's the guix-jupyter package that comes from the https://gitlab.inria.fr/guix-hpc/guix-kernel repo, right?
<stencilv>Really my quiestionis about that.
<stencilv>Yes, absolutely. Sorry, probably being too terse.
<attila_lendvai>guix-kernel is a very unfortunate name
<stencilv>I'm not sure where to pose this question. It really does belong as an issue on the guix-kernel repo, but...
<attila_lendvai>stencilv, i think you should open an issue in their gitlab. unless the error is due to something in the guix infrastructure, but it doesn't sound like that
<stencilv>How do I open an issue? (I don't have an account on gitlab.inria.fr)
<attila_lendvai>stencilv, welcome to the interwebz of 2024: you must register an account.
<stencilv>Sorry - I know that is not really a question for this group, but hoping for a suggestion.
<attila_lendvai>i have an account to a list of places i can't even keep track of (my pw manager does that)
<stencilv>"Inria members can login directly with their Inria login in the iLDAP tab. External users need to request an external account from an Inria member. When the account is created, the external users can login in the Standard tab."
<attila_lendvai>now, that doesn't sound too good
<stencilv>exactly.
<attila_lendvai>stencilv, i'd look up who is updating the package in the guix repo, and write an email asking either the question itself, or how to get an account
<attila_lendvai>ACTION needs to go
<stencilv>That seems like a decent suggestion. (I had also thought about filing an issue on related repos -- e.g. guile-zmq. But maybe better to just email)
<stencilv>(sorry I meant guile-simple-zmq)
<stencilv>Anyhow, thanks!
<fnat>Is emacs-next something anyone here uses as their daily driver already?
<fnat>That's a pretty convoluted wording haha.