IRC channel logs

2024-08-27.log

back to list of logs

<koorosh>hi, I'm trying to learn more about guix and specifically how guix services work, I've been browsing the source but I have problem with finding the point where services type or live-service type turns into a configuration file or some string that will be passed to a binary as a command line arguments can someone explain this subject to me
<jaft_r>koorosh: it's going to vary from service to service, somewhat (though, generally, not by much); usually, a service will define a config. construct for users to use, sometimes an srfi-9 record type (like the SLiM login manager, under gnu/services/xorg.scm) or sometimes using the "define-configuration" macro (like the Redshift home service, under gnu/home/services/desktop.scm).
<peanuts>"SRFI 9: Defining Record Types" https://srfi.schemers.org/srfi-9/srfi-9.html
<jaft_r>As to /when/ that config.'ll get generated into a file, that's where things can vary; using the SLiM example, it's done at https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/xorg.scm#n746
<jaft_r>Slim allows you to pass a config. file as an env. variable so the generated file is saved to the variable "slim.cfg" and, then, passed at the set #:environment-variables at line 800.
<jaft_r>(I don't know too much about how SLiM works but, just reading the code, that seems to be, as I understand things)
<koorosh>jaft_r: tnx a lot
<koorosh>I also found the service that I was looking for (mingetty-shepherd-service)
<koorosh>initially I had an issue with auto login using mingetty where upon automatic login I got the message (error in service module), do you have any suggestions on how I can debug this
<koorosh>is there a way to see the config or the command line arguments using herd
<mirai>herd configuration <THE-SERVICE>
<mirai>it doesn't always work though, varies from service to service
<jaft_r>That's nice; hadn't known about that command.
<koorosh>thank you mirai
<robin>shepherd seems to have a bit of a discoverability problem. i can't imagine it's better now that it's ditched goops
<AwesomeAdam54321>Yeah, most of shepherd's functionality is integrated as a part of Guix System
<AwesomeAdam54321>I might be the only one using the shepherd as the init system on a different distro
<robin>AwesomeAdam54321, debian gnu/hurd? ;)
<AwesomeAdam54321>robin: LL GNU/Linux
<AwesomeAdam54321>LL stands for "Linux Lite", but the name is misleading
<AwesomeAdam54321> https://whatsrc.org/
<jaft_r>robin: why'd they ditch GOOPS (just curiousity, on my part)?
<old>is there a way to find which commit of guix has a package at a given version?
<robin>AwesomeAdam54321, oh neat, hadn't heard of linux lite before
<robin>jaft_r, unclear but spritely has been pushing for actor-based oo in guile, and the spritely folks don't see any possible connection to CLOS-style OO (now that i'm not working there, anyways)
<robin>jaft_r, (it's not actually using spritely goblins -- their actor system -- but, i'd guess, some simple message-passing OO library inspired by it)
<robin>i'm hoping to work on goops as part of guile-emacs development, bring it closer to CLOS, fully support the MOP, etc. but that'd be after a year or so working on core guile-emacs stuff
<robin>(as part of CL-inspired improvements to elisp)
<amano>Let's assume that I installed firejail and apparmor. Both packages require files in /etc. How do people access those /etc files in guix?
<jaft_r>amano: are you just trying to view the files?
<amano>I want firejail to read files in /etc/firejail and apparmor to read files in /etc/apparmor.d
<jaft_r>That isn't, generally, how Guix operates; everything related to the package ends up under the package's directory in /gnu/store (sans configuration files which, generally, get set in your home directory's expected config. location; e.g. ~/.config/…, etc.).
<jaft_r>So any files that Firejail or Apparmor would usually provide under /etc would end up in /gnu/store/hash…-package-version/etc/…
<amano>But, how is firejail going to read its own files in /etc/firejail?
<amano>gnu guix already has firejail package.
<amano>Did someone make a firejail package without providing a way to use files in /etc/firejail?
<jaft_r>What I'm saying is that any files Firejail would normally place under /etc/ would get placed under /gnu/store/hash…-firejail-0.9.72/etc/ (and any, say, library files Firejail normally would have installed would end up under /gnu/store/hash…-firejail-0.9.72/lib/, etc.).
<amano>How am I supposed to use firejail on guix?
<jaft_r>I couldn't say; I've never used Firejail. When you've used it on another distro, what steps do you usually take, after install, to run it?
<amano>Perhaps, firejail package is configured to read files in /gnu/store/hash-firejail-x/etc/firejail?
<amano>I use run "firejail firefox", and it reads /etc/firejail/firefox.profile
<jaft_r>O. K. Lemme try installing it, real quick; then I can see how the files show up and get a better idea of what it looks like in comparison to what you're expecting.
<jaft_r>O. K.; yes. I think you're correct. That would definitely make sense, based on the file structure in /gnu/store
<amano>jaft_r: I haven't installed gnu guix, yet. Can you try running "firejail firefox" in a terminal?
<amano>What is the terminal output?
<jaft_r>Yeah; definitely. I am running Wayland (I don't know if you usually use XOrg); will that interfere with trying anything?
<amano>I'm on sway wayland compositor.
<jaft_r>O. K. That's good, at least. I think there may need to be some adjustments made for Firejail to work on Guix, though. It was finding some of the files under /gnu/store/hash…-firejail-0.9.72/etc/firejail/, like we were expecting, but I ran into other errors before it quit. I've put the full output here: https://pastebin.com/RQKSxvc6
<jaft_r>Or maybe someone else here does use Firejail and may have some advice on how they get it to work (hopefully).
<amano>At least, firejail reads files from /gnu/store/xxx-firejail-xxx/etc/firejail
<amano>I guess apparmor does the same....
<amano>What about swaylock?
<amano>Does swaylock read /gnu/store/xxx-swaylock-xxx/etc/pam.d/swaylock?
<jaft_r>Swaylock definitely works; I use swaylock-effects, for my screen locker.
<amano>Or, does it read /etc/pam.d/swaylock?
<jaft_r>Lemme check; one sec.
<jaft_r>(though I'd expect the former)
<amano>PAM is its own package. It might end up trying to read /gnu/store/xxx-pam-xxx/etc/pam.d/swaylock.
<amano>That file doesn't exist....
<jaft_r>Yep; the former (/gnu/store/xxx-swaylock-xxx/etc/pam.d/swaylock). Generally, files are put in the same folder of that package and then Guix makes everything know where to look through symlinks and setting the appropriate env. variables.
<amano>nat
<jaft_r>That keeps each package separate and allows you to do things like rollbacks and installing multiple versions of the same package.
<amano>That sounds very improbable... How did guix make PAM read /gnu/store/xxx-swaylock-xxx/etc/pam.d/swaylock?
<amano>How did you know PAM read /gnu/store/xxx-swaylock-xxx/etc/pam.d/swaylock?
<jaft_r>I don't, for certain. I'm only assuming. But that's where the file is located.
<amano>Can you run "strace swaylock" to make sure?
<amano>strace swaylock > swaylock.log 2>&1
<amano>"strace swaylock" doesn't capture /etc/pam.d/swaylock on my own system....
<amano>jaft_r: There is certainly /gnu/store/xxx-swaylock-xxx/etc/pam.d/swaylock, but PAM wasn't compiled for swaylock specifically, so it is very likely to read from /etc/pam.d or /gnu/store/xxx-pam-xxx/etc/pam.d
<jaft_r>I've put the output of strace here: https://pastebin.com/AJZQuERF
<amano>I only found /gnu/store/6kbyw9hx30qbh4rkb3qzhrl5ivxidh06-linux-pam-1.5.2/lib/libpam.so.0 from that paste.
<amano>Do you know how to modify /etc/pam.d files?
<amano>What's the content of /etc/pam.d on your system?
<jaft_r>chfn -> /gnu/store/krqipyr5w4cjpnhah6w0ycy4q844p9r8-chfn \n cups -> /gnu/store/rpgxa1p9xm7nzyhszibnknz3jnl3r8r6-cups \n groupadd -> /gnu/store/xzznca75qla7ja78blm5mk1kn49dvskv-groupadd \n groupdel -> /gnu/store/dil1i0c1983arfmdfavjdmg189frswb2-groupdel \n groupmod -> /gnu/store/3n6v8insfg98a7n2grxwy7pgcx77js6i-groupmod \n login -> /gnu/store/6p902npwa8y8r4vwzgcgpz2wrj6bv6d0-login \n other ->
<jaft_r>/gnu/store/zs1hvzc0k5a5iv03gcvanh3yaxl8i152-other \n passwd -> /gnu/store/5h6zpdns6rcpd4646j7wmw15dpgfnvmh-passwd \n polkit-1 -> /gnu/store/nnixaqbidfkll9lz53vjbpzn8iwi62a6-polkit-1 \n slock -> /gnu/store/6r6x9pr0c8irhmddig6ngdlk3gmd9xa9-slock \n su -> /gnu/store/c8cqfxjbd6k0r5y4v8vymc1gk7bg045w-su \n sudo -> /gnu/store/3vr0mkqgixyz2sj4na3bgmmblvxfm7xk-sudo \n swaylock -> /gnu/store/30k4q2dk82cpz8r1njcmd71xxqgr8ml6-swaylock \n useradd
<jaft_r>-> /gnu/store/qkl64bl9lrqc4bszrgv7z9q5rixyv190-useradd \n userdel -> /gnu/store/6dvn63sz14328knb410nx5bl71vsqzdw-userdel \n usermod -> /gnu/store/vq3mbfsi3anzfzc1bhihy3xwrrm3a59m-usermod \n xlock -> /gnu/store/6zxszq49p540pyqw1fib32xv9iy0r0dd-xlock
<jaft_r>(all symlinks)
<amano>Did you specifically configure swaylock in your guix declarative configuration?
<amano>I thought guix doesn't put anything into /etc by default?
<jaft_r>I did, via the Swaylock service.
<jaft_r>Or, more accurately, the screen-locker-service-type.
<jaft_r>Mmm; actually, I didn't really configure it much, via there.
<amano>If you remove that from your configuration, does /etc/pam.d/swaylock evaporate?
<amano>screen-locker-service adds pam file to /etc/pam.d
<jaft_r>I wouldn't expect so. I think that's being provided by the swaylock-effects package I have installed. We can see the symlink is pointing to /gnu/store/30k4q2dk82cpz8r1njcmd71xxqgr8ml6-swaylock
<amano>????
<amano>I think the other files in /etc/pam.d come from base service.
<jaft_r>I'll try removing the service and then say what happens to /etc/pam.d/swaylock.
<amano> https://guix.gnu.org/manual/en/html_node/X-Window.html says screen-locker-service adds package, a package for a screen locker or screen saver whose command is program, to the set of setuid programs and add a PAM entry for it.
<amano>That means without screen-locker-service, swaylock is unuseable.
<amano>because there is no /etc/pam.d/swaylock anymore.
<jaft_r>Then perhaps the service makes the symlink to the file in the Swaylock package; that would make sense as a design.
<amano>If you remove screen-locker-service, does /etc/pam.d/swaylock disappear?
<jaft_r>Still building.
<amano>What's the content of /etc/logrotate.d?
<amano>Did you manually configure logrotation in your global configuration file?
<amano>I'm starting to think that guix packages should export automatically enabled services.... which can be configured manually.
<jaft_r>It doesn't look like I don't have a /etc/logrotate.d directory. I'm guessing logrotated is a systemd service?
<amano>Outside base services, things in /etc must be configured manually, but on FHS-compliant distros, things in /etc come automatically from packages.
<amano>Can I add a few lines to /gnu/store/xxx-swaylock-xxx/etc/pam.d/swaylock through the global configuration?
<amano>How long does it take to build?
<Rutherther>You can make a new package to copy the contents and add lines. Not possible to edit packages that are already written in store. Its immutable and reproducible.
<jaft_r>amano: It's been a while since I ran a recognfiguration so it was updating a bunch of packages; I was almost to the end and…ran out of space. So running a garbage collection.
<amano>Can I override a package by defining a new package?
<Rutherther>You can inherit the old one to make a new package that is similar to the old one with just a few changes. Though of course that means it will be recompiled
<amano>That means no subsitute?
<amano>I want to just add a few lines to a subtitute package.
<Rutherther>Most of the time. Of course the substituter doesnt have that exact package so it cannot send it to you
<amano>Can a private guix channel define its own services that can be used in the global configuration?
<amano>Can a private guix channel export services that are automatically enabled in the presence of certain packages?
<amano>If I install my swaylock package, I want swaylock service to be enabled automatically.
<Rutherther>Yes, you can make channel with services, Guix system is completely customizable. Doesnt have to be a channel, can be even in your config.scm or other modules you add to your load path.
<Rutherther>Its not supported out of the box, but you could of course do that yourself. Its completely backwards though. Since the services are usually what adds the package to profile, and not the other way round
<amano>What if I want a system service?
<amano>I think profiles apply to user packages.
<Rutherther>The whole system has a profile... Its what "installing" packages means for most packages. To add them to the profile. Can be system profile or user one. But some need more files, and for those you need services.
<amano>So, for services, I don't install corresponding packages... I'm finally starting to understand....
<amano>What about packages that come with logrotation files? Do I enable services instead of installing packages?
<Rutherther>I dont know what you meant by "if i install swaylock package, i want service to be enabled automatically". if not to put it to your packages of operating-system which just puts it to your system profile.
<amano>swaylock requires /etc/pam.d/swaylock.
<amano>/etc/pam.d/swaylock must be installed by a service.
<Rutherther>I know we went over it many times
<amano>My idea was to make swaylock package export an automatically enabled swaylock service.
<amano>a service that installs /etc/pam.d/swaylock.
<amano>But, your idea is to make screen-lock-service install swaylock.
<Rutherther>You either install it with a service that will take care of that and then your question doesnt make sense, or you just put it to profile and expect it to work, and thats what I covered in my answers.
<Rutherther>So if you dont mean to put it to system profile please explain how you imagine to do "install swaylock package"
<amano>swaylock must be installed onto the system profile
<amano>If I just installed swaylock package onto the system, there would be no /etc/pam.d/swaylock by default. Correct?
<Rutherther>Okay, sorry, I dont understand at all what you mean, so maybe someone else will help you, but I cant anymore
<amano>Are you tired?
<Rutherther>No
<amano>As far as I know, packages don't insert any files in /etc.
<amano>Services do.
<amano>My theory is that if you want files in /etc that come with packages, instead of installing raw packages, I should just configure services that install the wanted packages and put the wanted files in /etc.
<AwesomeAdam54321>amano: That's how things work as far as I know
<amano>If I want to add a few lines to a package, I must create a new package. I don't know whether services will pick up the modified packages.
<Rutherther>You tell the service which package to use, so thats possible. Most of the already made services have config for which package to use
<amano>I mean adding a few lines to a file in a package.
<amano>Things are now starting to click.
<amano>But, what about https://guix.gnu.org/en/manual/en/html_node/Log-Rotation.html ?
<amano>Log rotation service doesn't seem to install a package.
<amano>Anyway, will there be a service for a package that requires any file in /etc?
<Rutherther>Some services just provide a shepherd service. No need to pollute your environment with it, so you dont see the package yourself, only the service does
<Rutherther>If you mean if there will be in the guix channel, then probably not. Even nixos that has a lot of more people around it doesnt have services for every package. There is too many programs
<amano>So, services are supposed to take care of packages that need files in /etc?
<Rutherther>Yes
<amano>Otherwise, those packages would be useless....
<amano>Okay, I think I'm beginning to wrap my mind around gnu guix....
<amano>If services take care of packages, it is actually sensible.
<amano>I thought packages were supposed to take care of services for reducing redundancy in configuration.
<amano>The prospect of seeing useless packages without any support file in /etc was horrible. Now, everything makes sense...
<amano>By the way, I read that guix has had problems with packaging python modules. Is it still a problem now?
<jaft_r>amano: I'm not sure how useful it is, still, but removing the service did remove the "swaylock" file from /etc/pam.d
<amano>Perhaps, guix doesn't wipe /etc when it builds.
<amano>Can you remove /etc/pam.d/swaylock and build again?
<amano>Can you remove /etc/pam.d/swaylock, build again, and install swaylock again?
<Rutherther>It does remove stuff that was used before on activation. The activation happens either on manual reconfigure or also every boot
<amano>Rebooting is enough to knock out /etc/pam.d/swaylock?
<Rutherther>If the generation you boot into doesnt have it added by a service, yes
<amano>I'm starting to think that gnu guix is really the most advanced OS, but its UI is simply not accessible to most people.
<amano>Apple is bad, but mac os really is easy to use.... with good UIs...
<amano>I wish all the guile code was actually GUI. GUI is really easy.
<amano>jaft_r: Did /etc/pam.d/swaylock disappear?
<rhuijzer>Mornin' all
<jaft_r>amano: I mentioned that it was removed when I removed the service, remember? Now that I've put the service back, the file is there, again.
<amano>I guess services are the way to modify the system outside /gnu/store.
<rhuijzer>Are we still busy with amano 's /etc/pam.d/swaylock.
<amano>Everything clicked when somebody mentioned that services should be used in place of packages when things outside /gnu/store need to be modified.
<amano>Services automatically install packages.
<amano>I thought packages should provide automatically enabled services. It was the other way around.
<rhuijzer>Great!
<amano>Infrastructure as code makes sense. It is better than all other configuration management services.
<amano>Gentoo linux has a few quirks such as requiring perl-cleaner, emacs-updater, haskell-updater, and emerge @golang-rebuild during system update. Having to call haskell-updater once or twice sometimes was a bit annoying. And, I couldn't install several versions of haskell libraries on gentoo linux. On gnu guix, all the quirks and issues on gentoo linux go away, but I'm sure there will be new problems
<amano>introduced by guix. New solutions introduce new problems.
<amano>In case of gnu guix, you have to write code for infrastructure. That's a good problem for developers, and a bad problem for most people.
<amano>Does gnu guix still have problems with packaging python modules?
<rhuijzer>not to my knowledge, works fine here. A lot is packaged already, you can try the pypi importer if it isn't (see guix import)
<amano>Does guix have something for managing symlinks in /etc?
<amano>Can it also synchronize directories?
<Franciman>hi does guix support bsd kernel
<Franciman>?
<wizard>Franciman: afaik it's only linux and hurd
<rhuijzer>What
<rhuijzer>What's the usecase amano
<amano>I want to symlink /etc/apparmor.d to a directory in a git repository.
<amano>I may want to synchronize /etc/firejail with a directory in a git repository.
<Franciman>thanks wizard
<Franciman>i hope the hurd gets up and running fast
<amano>I don't think it makes sense to write services dedicated to apparmor profiles and firejail profiles.
<amano>It makes sense to write services that synchronize directories or manage symlinks.
<amano>Firejail may break if /etc/firejail is a symlink.
<rhuijzer>amano yes that's possible. I don't know if apparmor works guix tho
<rhuijzer>It isn't really the way probably but I would write a simple service that just copy's the configuration to the right folder
<rhuijzer>I would recommend reading the manual or watching some youtube maybe amano, then stuff like this will became clear
<amano>It seems only home service manages files and directories directly. Nothing for the system.
<amano>I'm looking for things like symlink-service and directory-sync-service.
<amano>The kind of things I used to use with saltstack.
<esnos>Hi, I have problem with applications installed via flatpak on gnome. I wanted install codium using flatpak via "flatpak install com.vscodium.codium", but after restarting computer, the only way for me to run codium is to run "flatpak run com.vscodium.codium" from console. Do you know if there is a way to open codium from "show apps" menu?
<wizard>esnos: add `source ~/.guix-home/profile/etc/profile.d/flatpak.sh
<wizard>to your .bash_profile
<wizard>(without the `)
<wizard>(whoops)
<wizard>at least assuming you installed flatpak through guix home
<esnos>I will do it and try it out
<esnos>I installed flatpak through guix install
<wizard>it'll probably be under ~/.guix-profile then
<amano>It seems gnu guix can't subtitute for GNU stow
<rhuijzer>amano Use stow then. I've got a feeling that stuff like apparmor is a pain to use without a dedicated guix service but you could try. You can also write a small guix service that does the dotfile thingy for you (simple-service), then guix will take care of symlinking and versioning of the dotfiles
<rhuijzer>Try to read a bit of the manual
<amano>rhuijzer: I searched the manual.
<esnos>Okay, so I added `GUIX_PROFILE="/home/oskar/.guix-profile" . "$GUIX_PROFILE/etc/profile"` to the .bash_profile, logged out and I still can't see codium
<amano>It's weird. where do I find shepherd services defined for gnu guix?
<amano>Are all shepherd services defined in gnu guix repository?
<amano>It seems guix services double as shepherd services.
<esnos>Also, do you know how can I have always running session of irc? Right now I'm using erc, but whatever I log out, I have to join to #guix again and can't see previous messages unless I check logs on internet
<rhuijzer>esnos i think you need a relay for that
<kaij>If I have a package that can't be substituted but may cause the exact same output, will dependent packages be substituted?
<rhuijzer>amano try to read a bit of the manual https://guix.gnu.org/manual/en/html_node/Services.html
<esnos>I got flatpak to work! I needed to add `export XDG_DATA_DIRS=$XDG_DATA_DIRS:/var/lib/flatpak/exports/share:/home/<user>/.local/share/flatpak/exports/share` to .bash_profile
<rhuijzer>esnos great, going to borrow this line for my .zsh_profile
<ayatsfer>hello guix, what should I do if upstream doesn't have tests?
<ayatsfer>delete the check phase, or use #:tests? #f ?
<abcdw>I'm fixing libcamera package at the moment, more precisely signing of the libraries. I added a re-sign phases after stipping phases and build --no-grafts works fine. However, grafting breaks the signature verification and libcamera crashes. What is a proper way to deal with it?
<gabber>ayatsfer: #:tests? #f
<gabber>the 'check phase is only run when #:tests? is #true
<gabber>ah, and comment that there are no tests for the package
<ayatsfer>what's the reason behind that?
<taeaad>Can I put my /gnu/store folder on an external drive, if so would it cause any obvious issues?
<taeaad>Currently running GUIX only as package manager on another distro, but just wondering about this. Would it make sense to install full GUIX system on an external drive and EFI boot into it? Do all these options work?
<amano>I figured out where man pages come from. Now, I understand gnu guix at a conceptual level.
<Franciman>do you like it , amano ?
<amano>Packages in /gnu/store. Everything outside /gnu/store come from gnu guix codebase or gnu guix services...
<amano>Franciman: Yes, I like it. It's clean, but it's also going to be a compatibility problem with some programs.
<amano>NixOS already had problems with patching paths in (binary) packages....
<Franciman>true
<amano>After understanding it at a conceptual level, I also realized I can't justify the time expenditure required to migrate from gentoo linux to gnu guix anytime soon. Not until I become rich.
<amano>After I become rich, when I have time to waste, I will maybe learn gnu guix.
<Franciman>amano: how do you manage gentoo compilation times?
<Franciman>i think substitutes idea by guix are brilliant
<Franciman>is brilliant*
<amano>Franciman: The trick is to run it on a powerful computer with at least 32GB RAM and a fast CPU.
<Franciman>but i also udnerstand that it is only truly possible because of functional package management
<Franciman>eh i can't afford that
<amano>If you are poor, you don't have time to fiddle with OS....
<Franciman>i am poor, but i have time to fiddle with OS
<amano>That's why you are poor... Every hour you don't spend on making money, you cannot get back.
<Franciman>lol
<amano>Having time to fiddle with OS is why you are poor.... Rich people just use mac os.
<amano>Finish up your gnu guix configuration, and stop fiddling.
<amano>The earlier you can stop fiddling, the better.
<amano>Time to settle down.
<Deltafire>Ubuntu then? ;)
<amano>Ubuntu isn't bad.. I know how to handle ubuntu upgrades...
<amano>Anythying that's going to last and serves your needs without much hassle is good enough.
<amano>That being said, if I started from scratch, I would start with gnu guix.
<taeaad>"Rich people just use mac os." I have some reservations about this statement.
<amano>Content creators also tend to use mac os.
<amano>Just stick with whatever OS serves you, and learn gnu guix in the future when you are rich and actually have time.
<gabber>ayatsfer: the reason is that in review the reviewer knows that you didn't just exclude the tests because they were failing
<ayatsfer>I meant the reason being deleting the checkPhase vs using the flag
<gabber>ayatsfer: setting the flag is more beautiful (less code, more obvious what you are doing) and why the flag exists in the first place (:
<McParen>the following package shows a build failure after an update: https://ci.guix.gnu.org/build/5479549/details
<McParen>but i cant find out why it is failing on x86_64 but succeeding on i686.
<McParen>does anybody know how to find out why the former is failing? thanks.
<apteryx>hi! how can I connect a browser other than torbrowser to the tor network? I'm aware that's not the best for privacy.
<apteryx>i'm asking here because I've seen we have a tor-service-type, was wondering if this can be used for that
<koorosh>by default tor opens a port at 9050 if you are using firefox you can go to the settings and scroll all the way down or search for proxy settings and set the ip and socket there
<koorosh>you can also use gsettings to set system wide settings
<koorosh>    gsettings set  org.gnome.system.proxy mode manual
<nckx>McParen: If you scroll down to ‘Log file’, you can see the same build output you'd see if you built the package yourself. It usually explains build failures. In this case, this is a tooling bug I thought was dead & buried and it's not related to the package itself.
<apteryx>koorosh: I see! thanks a bunch
<McParen>nckx: Can I (as the package author) do anything to help anybody fixing that bug?
<McParen>does that bug in any way prevent the package from being used?
<nckx>McParen: No to the first question, it really is purely a CI bug. And no, the package will build fine on people's machines and other substitute servers. Users just won't get a substitute from ci.guix.gnu.org. I assume it's not expensive to build so it's not a blocker.
<nckx>I've restarted the build on CI though so with some luck that'll all be moot.
<nckx>It already is.
<McParen>ok, thanks for the info.
<nckx>For the channel record: this was the ‘unable to build missing derivation’ bug.
<apteryx>I'm like 20 minutes into this grafting business on an old x200 (which has an ssd)
<apteryx>(guix system reconfigure)
<rynn>Has anyone ran GuiXSD on a TalosII ppc machine? There was some work on it previously, but doesn't seem to be any new info since 2021ish.
<apteryx>there are some substitutes for it; you can see which packages were built for it by searching on ci.guix.gnu.org
<rynn>Yeah, seems to be very much wip there
<rynn>Which matches with what's seen on the branch in git, however it doesn't look like there have been any new commits on the p64 wip branch since 2021
<rynn>Which seems weird, since the powerpc stuff being developed by Talos is probably our best hope for a fully modern RYF system.
<nikolar>RYF?
<rynn>Respects Your Freedom
<nikolar>ah
<rynn>The FSF certifcation. Generally it's only the hardware based on the X200s that meet the criteria.
<rynn>Here's the article from back in 2019 when the Talos II line got it: https://www.talospace.com/2019/11/talos-ii-and-talos-ii-lite-officially.html
<rynn>Actually scratch that about the X200, I was thinking of something else. Currently you only have the Talos and Viking boards that get the RYF cert.
<apteryx>rynn: some people were reporting package bugs for the arch
<apteryx>at least a basic system or profile should be possible
<apteryx>you'll probably encounter some build problems for a full desktop
<PuercoPop>I can refer to a secondary output when using strings, ej. "gcc-toolchain:static". But what symbol do I pass to packages->manifest to use a secondary output in scheme code?
<ieure>PuercoPop, See https://guix.gnu.org/en/manual/devel/en/html_node/Writing-Manifests.html#index-packages_002d_003emanifest-1
<PuercoPop>ieure: Thanks, google-fu had pointed me to 6.4 Packages with Multiple Outputs. The section that you point is much more germane
<ieure>Google is horrible these days.
<PuercoPop>Indeed, I tried duckgogo a couple of years back it wasn't very good either. Sometimes I feel like I'm flying blind
<ieure>Yeah, Google was the gold standard and nobody else was as good; then Google exec got AI brainworms and now Google is just as bad as everyone else and no search engine works as well as Google used to.
<ieure>Even before the AI brainworms, Google's ad sales and "personalization" nonsense had made their results very poor; the brainworms just accelerated the rot.
<ieure>And the internet is a much more hostile place than it once was, so I don't think you can go back to the old Google techniques without getting overwhelmed with spam.
<ieure>All pretty terrible! If you need me, I'll be in a cabin in the woods of Michigan writing my manifesto.
<dlowe>I recently learned that a study inside Google in 2017 found that decreasing search quality didn't cause a decline in revenue, which tracks the beginning of its decline
<dlowe>AI brainworms may have been a opportunistic coincidence. Google's big enough to do more than one thing.
<ieure>Good (long) piece on Google search results becoming crap. https://www.wheresyoured.at/the-men-who-killed-google/
<ieure>I've been using SearxNG for several years -- it's a frontend for multiple search engines which makes them behave better. It's not great, but it does seem to be the least bad of the terrible options. Trivially self-hostable, so I do that.
<ieure>It fixes one thing that every search engine does, which drives me up the wall: the links to search results are real, actual, direct links to the listed thing. And not a redirect through the search engine's infrastructure so they can measure click through. I *detest* when I see a link, and hover the link and it looks right, then copy it and it's some horrible redirect.
<rynn>ieure: I use Kagi, which also doesn't include tracking in the links, allows full control over the search results, and in my experience gives very good search results. The caveat: it requires a paid subscription since the there is zero ads/user data aggregation for sale to pay for everything.
<ieure>rynn, Yes, I'm familiar with Kagi. They partner with Brave, the company that makes a scammy browser founded by a noted homophobe; and Kagi's CEO reacted very, very poorly when one of his customers asked them to reconsider that partnership.
<ieure> https://www.spacebar.news/stop-using-brave-browser/ https://kagifeedback.org/d/2808-reconsider-your-partnership-with-brave
<rynn>I'd heard of the issue, though I hadn't read the feedback thread before. I don't want to dive into political issues here, so I'll just say that I'm okay with the founder's stance on the issue in that thread and leave it at that.
<PotentialUser29>Is there a preferred way to CC a team on a patch without using git send-email? I see this page https://guix.gnu.org/manual/en/html_node/Teams.html but I'm wondering does that command just put all of the individual email addresses in the CC? Or is there a team specific email address that notifies those individuals?
<PotentialUser29>I guess what I'm asking is if I'm using an email client should I just manually put each team member's email address in the CC field if I want to notify a team?
<ieure>PotentialUser29, git-send-email figures out the cc list using etc/teams.scm in the Guix repo (it's an executable Guile script). You probably want to figure out how to run that manually, then use the cc list it outputs.
<PotentialUser29>ieure: Right, I can run "./etc/teams.scm list-teams" and see the email addresses for all members of all teams, I just want to confirm that those are the emails I should be using
<ieure>PotentialUser29, Yes, those are the ones `git send-email' would use. The configuration which accomplishes that is in etc/git/gitconfig in the Guix repo.
<ieure>If you want to see how it's invoked, or just see that this is indeed how the mechanism works.
<PotentialUser29>thank you
<dariqq>hmm, the qa page was claiming that some of my open patches dont exist anymore. I have just resend some of them as a v(N+1) and now they are back again
<esnos>Hi, do you know if I can see config.scm of my first guix reconfigure? I'm started using guix and I found out touchpad works on first generation, but not on later and I want to fix this problem
<podiki>esnos: guix system list-generations will give you the commits for each channel and a path to the system config
<podiki>for each generation (system reconfigure)
<esnos>podiki: It works, thank you
<podiki>power of guix!
<esnos>For real, this is awesome