IRC channel logs

2024-10-19.log

back to list of logs

<amano>Can I make guix run some guile code or some services whenever there are changes to /boot?
<amano>Is there a hook for that?
<amano>Changes to kernel arguments, initrd, kernel, and bootloader will change /boot.
<__cornflake__>Hey y'all, I'm trying to use home shepherd services to start my various autostart programs (emacs daemon, usb mounter, etc) instead of putting them in my window manager config, but I'm having issues. I'm basically a beginner with shepherd and I can't figure out what's wrong, so any help would be appreciated. Here is the home service I wrote to start the emacs daemon: https://paste.debian.net/1332713/ and here's the error it gives:
<__cornflake__> https://paste.debian.net/1332714/
<apteryx>interesting, I have segfaults error in ntpd (per dmesg)
<apteryx>and my time is off
<apteryx>is merging branches still stuck waiting on 'Request for merging "fonts-split-outputs" branch' ?
<AwesomeAdam54321>__cornflake__: Just a guess, but have you tried using file-append in the start slot?
<AwesomeAdam54321>"emacs" would become #$(file-append emacs "/bin/emacs")
<__cornflake__>oooooooooh, that makes sense
<__cornflake__>some of the examples have that too
<__cornflake__>that just turns into the full path to the emacs binary right?
<AwesomeAdam54321>Right
<__cornflake__>It works!!! Thank you!!!!
<__cornflake__>actually, I think I thought it worked, but now it doesn't anymore so idk what went wrong
<__cornflake__>:/
<__cornflake__>I'll start on this again tomorrow, thank you AwesomeAdam54321
<podiki>sneek: later tell apteryx re: branches, I think yes waiting on fonts-split-outputs. mesa-updates (just updated and rebased) should be good to go, just been waiting for non-x86 builds for weeks
<sneek>Will do.
<Guest71>Hello, could someone please provide me the 1.4 release or latest installation ISO for ARM CPUs? I don't have a x86_64 machine and emulation takes ages
<galois34>I use Debian on one computer, Arch on another computer, Guix on my laptop. It's a nice experience indeed.
<koalillo>does the project publish anywhere a -RR guix pack tarball? or any other "rootless" mean of running enough guix pack and similar tools?
<fireking04>Hi everyone, does anyone know how to enable cgroup controllers in guix system config? I need to have device enabled but looking at /sys/fs/cgroup/cgroup.controllers does not devices controller. But CONFIG_CGROUP_DEVICE=y is enabled in kernel config
<luca>Where exactly am I supposed to send patches? Is it guix-patches@debbugs.gnu.org or guix-patches@gnu.org ?
<Rutherther>luca: the second one will work for sure, not sure about the first one, never seen it.
<luca>I see, possibly outdated manual. I see the devel version has a different address
<Rutherther>what section?
<luca> https://guix.gnu.org/manual/en/guix.html#Multiple-Patches-1
<Rutherther>hmm, right, it's in one code block, possibly a mistake
<Rutherther>luca: btw you should be using the devel version, this one is for 1.4.0 that is old
<luca>Yeah, I kinda figured after 4 emails bounced :P
<Guest31>I ran "guix system image -t iso9660 --system=aarch64-linux gnu/system/install.scm" since I don't want to emulate the VM but I get "error: plain image kernel not supported - rebuild with CONFIG_(U)EFI_STUB enabled." but don't understand why it isn't working. If I disable UEFI boot in the VM, the guest will no initialize the display.
<Guest31>basically I just want to run the installer ISO on ARM but on the website only x86_64 is available
<futurile>afternoon all
<kaij>Is there some way to take a lock in shepherd natively? I have a bunch of one-shot services that can't run in parallel (the underlying CLI will take a lock and fail).
<ieure>I think there might be an unexpected issue with commit 5794926bed6fad4598bb565fb7f49be4205b11a1 rebuilding more packages than expected.
<peanuts>"gnu: font-cormorant: Split outputs. - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=5794926bed6fad4598bb565fb7f49be4205b11a1
<ieure>My Cuirass is rebuilding every package in my channel after pulling that commit. ci.guix has been evaluating it for over an hour: https://ci.guix.gnu.org/eval/1733664
<ieure>It's also intermittently 504ing.
<ieure>The last few evaluations have taken ~15-25 minutes, so 61 seems abnormal.
<ieure>ex. this package which has no inputs at all and uses cmake-build-system is rebuilding in my channel: https://codeberg.org/ieure/atomized-guix/src/branch/main/atomized/packages/floppy-disk.scm#L54-L77
<ieure>Trying to use `guix graph' to see what got updated that'd trigger this, but none of the commands in the manual work. sigh
<ieure>`guix graph coreutils | dot -Tpdf > dag.pdf' -- the dot command hangs forever.
<ieure>Or at least, if it works, it's too slow to be useful.
<ieure>`guix graph coreutils | xdot -' -- dies with "AttributeError: 'NoneType' object has no attribute 'get_property'"
<ieure>Okay, yeah, so the .dot file is >400kb and dot is just very slow to churn through all that.
<ieure>Annoying.
<ieure>Anyway, if anyone cares, I think that commit triggered something close to a world rebuild.
<abbe__>guix is broken :/
<nckhexen>ieure: That dot pipeline takes under a second for me. So if it truly 'hangs forever', it would be good to know where. Guix or dot?
<abbe__> https://git.savannah.gnu.org/cgit/guix.git/log/?qt=range&q=503919fcf01d7eb8d550df5c3993aee9a966ba9b..5794926bed6fad4598bb565fb7f49be4205b11a1 is reporting failures in cuirass
<peanuts>"gnu: font-cormorant: Split outputs. - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=5794926bed6fad4598bb565fb7f49be4205b11a1
<nckhexen>Whose Cuirass? Guix's gives me the 504inger. That does not look like a broken diff.
<forkbombidable>Hello, noob trying to write my first package and stuck on something. Is it possible to change the CMake build system to use the "cmake" package and not "cmake-minimal"? The library I am packaing needs CMake 3.25. "cmake-minimal" is 3.24, and "cmake" is 3.30. I don't see any options for modifying this: just a "default-cmake" function that I don't think I can hook into.
<civodul>forkbombidable: hi! yes, you can pass “#:cmake cmake” in the ‘arguments’ list
<forkbombidable>Oh, nice. I can't read: I see that in the docs now under "cmake-build-system" -_-. thank you!
<ieure>nckhexen, My Cuirass rebuilt every package in my channel when it pulled that Guix commit.
<ieure>ci.guix is definitely struggling, but I have no idea if it's related.
<civodul>‘fonts-split-outputs’ merged, yay!
<civodul>ci.guix doesn’t really seem to be struggling: https://ci.guix.gnu.org/jobset/master
<ieure>civodul, A good number of requests to ci.guix are 504ing for me.
<ieure>It finally started builds after ~90 minutes, seems to be building around 2000 packages.
<civodul>ieure: well yeah, the web interface is struggling; what i meant is that builds are happening and it’s pretty much up-to-date for ‘master’, despite the ‘fonts-split-outputs’ merge
<ieure>Agreed, builds are happening.
<ieure>But was it expected that 2100 packages would get rebuild?
<ieure>Alright, I guess this is expected: https://issues.guix.gnu.org/72959
<civodul>yes, it wasn’t done at 100% yet, though x86_64 was probably close to that
<nckhexen>2100 rebuilds across all architectures(?) is OKIMO.
<simendsjo>I think my email to help-guix@gnu.org might have been marked as spam or similar. Sent 24 hours ago, but it doesn't show up in the archive at https://lists.gnu.org/archive/html/help-guix/2024-10/index.html
<nckhexen>simendsjo: Will check!
<nckhexen>…not witheld for moderation.
<nckhexen>The gnu.org mail server sometimes has spells of 'not delivering anything today' that can last surprisingly long, until it eventually decides to clear its queue.
<simendsjo>So it is marked as spam? Not sure what information is necessary to check this. Message-ID: <87ttd9s16t.fsf@_>
<nckhexen>Mmm? That's not what I meant. I meant that the server takes several hours (as in, many) to deliver incoming mail to the list.
<nckhexen>And I meant your own sender address, hence the PM (ICYMI).
<nckhexen>I'm afraid that we have no control over the server or insight into its queue or logs.
<simendsjo>I've seen some long delays before, but not an entire day. How long should I wait before trying to resend the message? Two days?
<nckhexen>Sounds good.
<nckhexen>You're not in the blocklist, and not in the moderation queue, which are the only things we Guixers have access to. I'll report it to the FSF sysadmins if the message doesn't arrive at all.
<fnat>How do I install pulseaudio on a minimal Guix installation (no desktop services)?
<fnat>AFAIU '(service pulseaudio-service-type)' only installs config files?
<fnat>Or should I want to go for the PipeWire Home service instead?
<fnat>My objective here would be simply for the machine to emit a sound. :)
<nckhexen>You're right that it 'only installs config files', because the daemon is expected to be started on demand by clients. But 'just emit a sound' is already handled by alsa. There is no 'play audio daemon'.
<fnat>Thanks nckhexen!
<nckhexen>Which is all to say I'm not sure what exactly your question is, since 'installing pulseaudio' != 'playing sound' per se. Not meant to be pedantic. Pulseaudio just improves multiplexing/mixing when multiple clients want to play sound, and configuring fancy output devices ('sinks').
<nckhexen>I haven't followed the status of pipewire on Guix. Last I did, it wasn't as configure-and-forget as pulse.
<fnat>nckhexen: Sorry for the delay. Hm, I'll be making some experiments.
<fnat>nckhexen: I've tried with the alsa service only. But then a test with mpv fails, saying https://dpaste.org/DnE1A .
<fnat>I thought it could be an unrecognised soundcard, but then lspci seems to recognise it and indicate a kernel module for it.
<nckhexen>So it's still trying to start pulse (1st 2 messages).
<nckhexen>With the subsequent ones, I'm no help. I've never seen these. Sorz.
<fnat>It's alright, thanks nckhexen!
<nckhexen>(By the mention of 'jack', I guess it's trying everything it knows, but no idea why alsa didn't work. That's a Linux kernel API. It's... there.)
<fnat>nckhexen: Oh my oh my, the user wasn't in the audio group. Sorry!
<fnat>On a separate note, interesting what you said about sinks, it's exactly what I'd like to do - if possible at all: to send an audio stream to another computer's audio device over a network.
<fnat>Should I look into 'home-pulseaudio-rtp-sink-service-type'/'home-pulseaudio-rtp-source-service-type'?
<fnat>Hm, on yet another front, I'm getting a 'herd: error: /run/user/1000/shepherd/socket: No such file or directory' when using Guix Home.