IRC channel logs

2024-10-31.log

back to list of logs

<vhns>Is there some way to set the timezone and locale through Guix's home configuration or do I have to setup enviroment variables through it?
<ArneBab>futurile: I sadly don’t have the time to work on Icecat, though I really need it updated :-/
<apteryx>reboot is defined as a procedure in (shepherd system)
<apteryx>I'll try '(use-modules (shepherd system)) (reboot)' at the Shepherd's REPL
<apteryx>that's new on reconfigure: GC Warning: Repeated allocation of very large block (appr. size 68 KiB): May lead to memory leak and poor performance
<getstate>I'm trying to update rbw, so far rebased the prev attempt. How often should I split patches for a new package, is it the whole dependency tree? If I split it up I feel like it would be too big?
<apteryx>each dependency should be packaged individually as their own commit
<apteryx>it's OK to have a large series of multiple commit. Small diffs are easier to review than a giant one.
<getstate>Fair, thanks!
<apteryx>re my earlier question about rebooting with shepherd; it seems the root service has an 'eval' action that I could use: herd eval root '(use-modules (reboot))' should do it
<apteryx>ACTION tries
<apteryx>err, just '(reboot)'
<apteryx_>in the context of evaluating expressions in Shepherd for in system tests, there's 'eval-there' from (gnu services herd)
<bavier>ekaitz, efraim: RISE group is sponsoring a "Developer Appreciation Program" for devs who contribute to the RISC-V ecosystem. Request at https://github.com/Rise-dev-appreciation/Rise-dev-appreciation. Share around.
<vhns>Hi. I'm currently trying to instantiate my own Guix channel. The documentation recommends having your 'keyring' branch be an orphan branch. But, having master already pushed into a remote repository, 'guix git' is not letting me push the 'keyring' branch pointing me that the orphan branch is not a descendant of the introductory commit. Am I doing something wrong?
<vhns>Should I disable authentication for the keyring branch?
<mange>When you say "guix git", what do you mean? I would have expected "git push origin keyring" to work, no Guix involved?
<vhns>mange: I'll just post some terminal output to make it clearer, I couldn't think of a smarter way to put it. https://paste.debian.net/plain/1334038
<mange>Is this a fork of the upstream Guix repo? Or is this a completely new channel? Can you check if you have anything in .git/hooks/pre-push?
<vhns>This is an entirely new repository, yes. I do have some stuff in pre-push that runs guix git authenticate.
<vhns>It has '#Installed by 'guix git authenticate'' at the very top
<vhns>Ah
<mange>I imagine that's trying to validate your keyring branch, but I don't think that makes sense, does it? I've not really used "guix git authenticate". Can you disable the hook for this push?
<vhns>I can!
<vhns>I'll give it a try, one sec
<mange>I think git push --no-verify should do it, from a quick look at the man page.
<vhns>yep, that did it
<mange>Excellent!
<ArneBab>apteryx: would it be a lot of work to implement shutdown -h TIME (to shut down after the given wait time)?
<mange>If you've got loginctl does "loginctl poweroff TIME" work? I've never tried it, but it's in --help?
<sleepydog>hi, is there any guide for making changes to guix SD itself? like if I want to make a change to a non-package, how do I apply that to my system? I am trying to use the -L flag but my changes aren't picked up
<Rutherther>sleepydog: there is a manual on that, it revolves around using make to compile some stuff and then using pre-inst-env script. The page is called Building from Git, under Contributing
<mange>Maybe also "(guix) Running Guix Before It Is Installed"?
<sleepydog>ok, i'll take a look, thanks
<sleepydog>I copied $(guix build guix)/share/guile/site/3.0 to "dev", made some changes, then ran `sudo guix system reconfigure -L $(pwd)/dev`
<Rutherther>sleepydog: better to clone guix repo itself rather than doing that, since that built path contains some compiled files
<mange>You could also use "guix build -S guix" if you want the source, but I expect most people would build from git rather than doing that.
<sleepydog>yea, i just wanted to make sure i was working on a revision that matched my current generation. git's a better idea
<mange>You can make sure it matches your current generation by checking out the commit that "guix describe" mentions.
<sleepydog>oh! didn't know about that. that's perfect, thanks
<Rutherther>there is also guix system describe / guix system list-generations to see the channels of individual generations
<sleepydog>it would be cool to have a script that behaves like `guix _ edit` but it opens the file in a git clone and creates a branch for you
<jpoiret>hello guix
<jpoiret>podiki: i've been running on mesa-updates for a bit, to update sway, and we'll need a newer libva to support hw accel. I'm building it all locally and if it works ill send some patches for them
<futurile>jpoiret, podiki: are we trying to merge mesa-updates, or should https://issues.guix.gnu.org/73288 be closed and a new one can be reopened later when it's ready to go? It's first in the queue according to QA
<jpoiret>no idea, I have not followed anything in a few months
<jpoiret>however, having broken hw accel is going to be quite annoying imo
<futurile>jpoiret: ack ack - we seem to open these "ready to merge" tickets, and then for all the normal reasons dev continues, and then it blocks the queue we have
<futurile>jpoiret: absolutely acknowledging broken hw accel doesn't work for anyone
<jpoiret>thinking about it a bit more, it's only going to break for the just-released version of sway, and probably not for other wms yet, so it shouldn't be blocking
<jpoiret>seems that libva got forgotten in the video updates unfortunately
<Rutherther>jpoiret also can't you re enable the backend with -Dlegacy-wl-drm?
<metsomedog>Can someone point me to some example of dealing with circular package dependency? I'm trying to update the (Common Lisp) package sbcl-clog. sbcl-clog defines 3 ASDF systems; the clog/tools system depends on the ASDF systems clog-ace and clog-terminal; these 2 systems are defined in separate Git repos, but they both depend on the "clog" ASDF system which originates in the original (sbcl-clog) package.
<metsomedog>(by example I mean other package definitions that deal with the same problem; couldn't find anything with the search engine)
<Rutherther>metsomedog: I dont know these so I dont know what exactly they require, but some examples of bootstrapping are python packages that end with -bootstrap in name. Also build systems like gcc or rust, where cyclic dependency has to be broken. The idea is to first build the stuff without the dependencies where appropriate, and then build new ones with correct deps. You might have to bootstrap from an earlier version that did not have these requirements
<metsomedog>Rutherther: The sbcl-clog package defines 3 "subpackages" (systems) clog, clog/docs and clog/tools. Only the 1st system/subpackage clog is required to build the other 2 external dependencies I mentioned, which again are used for dependencies for the clog/tools system/subpackage. So build order needs to be something like: sbcl-clog: clog; clog-ace (external package), clog-terminal (external package); clog/docs (part of sbcl-clog
<metsomedog>package), clog/tools (part of sbcl-clog package)
<metsomedog>I will try to look into some Python bootstrap packages, thanks for the pointer
<metsomedog>Maybe the first system clog can be extracted into a package such as sbcl-clog-base, and then used for the other dependencies
<Rutherther>metsomedog that is the idea of bootstrapping, yes. You could also look at how upstream does it, they also had to start somewhere without a cyclic dependency
<jpoiret>Rutherther: you're right
<reedm>Hi all. I know I can pass through environment variables to a container shell with the --preserve flag, but is there a way to set new environment variables?
<reedm>ideally, in a manifest or other .scm file. But I would settle for some config flags in the guix shell command
<futurile>reedm: guix shell -- bash -c 'env TEST=$GUIX_ENVIRONMENT' works (got this from Rutherther) and some people create a .envrc and do `eval $(guix shell —search-paths)` in there
<jpoiret>Rutherther: although it's not a meson flag, but a run-time debug option. That would require users to find that option which is quite annoying
<reedm>futurile: thanks for the tip!
<metsomedog>Rutherther: got it to start compiling when using a ...-base package as I mentioned above. Thanks. Still have some other build issues though, but don't think they are related.
<Rutherther>jpoiret hm I didnt realize that, since it started with D, seemed like a compilation option. Even so, could be wrapped
<jonsger>futurile: I appreciate your idea with the Guix user/contributor survey :)
<futurile>jonsger: thanks for telling me, good to know that I'm not on my own in wondering :)
<jonsger> futurile it would also be interesting how many systems with Guix one is using/running. So a number/integer field
<jonsger>would fit to Q13/Q14
<podiki>futurile jpoiret I'd say mesa-updates has been ready for weeks, but stuck waiting for subs to build and then berlin was down
<podiki>futurile jpoiret looks like coverage is nearly there for non-x86 finally. if libva update is critical then it would be better to do it sooner so it can build (i'm away from a guix machine for a few days)
<marmalade>Does anyone know why my .desktop files would not be populating properly when my $XDG_DATA_DIRS is set properly?
<Rutherther>marmalade does the program that searches desktop files have it in its environment?
<marmalade>Rutherther: presumably? I'm using KDE Plasma 5 on Debian Bookworm.
<Rutherther>marmalade where do you set the env var?
<marmalade>Like, I installed emacs, and in the ~/.guix-profile/share/applications I have multiple emacs .desktop files, but my program list only shows an entry that says "Run emacs".
<marmalade>Rutherther: .zshenv
<marmalade>but I also have an entry in /etc/profile.d
<marmalade>guix.sh
<marmalade>though it was already in there so i think it was installed by the Debian Guix package.
<Rutherther>marmalade okay then this is fine
<marmalade>Rutherther: Yeah the only problem is it doesn't show up properly in the app list, as well as the 'auto launch' app list for file associations
<krascovict> https://packages.guix.gnu.org/ its dowm?
<krascovict>504 Gateway Time-out
<krascovict>nginx
<futurile>jpoiret: guess it's up to you if the libva update is critical, as podiki is 'away' for a few days would you be willing to do the merge?
<podiki>jpoiret: if you do update libva (assuming it is pretty straight forward?) you can also bump mesa, another bugfix release
<ieure>Got a couple patches out if anyone's inclined to take a look... This one is a very straightforward version bump: https://issues.guix.gnu.org/74069
<ieure>This is more involved due to upstream changes: https://issues.guix.gnu.org/74070
<weary-traveler>#72925 needs some love as well. see https://issues.guix.gnu.org/72925#68 for the one remaining outstanding issues (per ludovic's comment which i wasn't able to fully grasp)
<peanuts_>"Adding JPM package for Janet" https://issues.guix.gnu.org/72925
<viaken>Is there anyone who's run into https://issues.guix.gnu.org/70034 and had the workaround listed not help?
<lispmacs[work]>is anywhere else here using Emacs gnus for bug searching and such? The bug search functions from debbugs.el are not working for me, and wondering if it was just me
<lispmacs[work]>I can use debbugs-gnu-bugs to look up a specific bug, if I already know the number
<lispmacs[work]>but if I try to use debbugs-gnu-guix-search, I don't get any results, even for the most generic searches
<janneke>lispmacs[work]: there must be something down (or broken?), the usual "C-u M-x debbugs-gnu RET RET n n" does not work for me atm
<janneke>haven't used debbugs-gnu-guix-search, sounds nice
<lispmacs[work]>maybe something in the SOAP interface...?
<fnat>Does this make any sense at all? Am I being naive in thinking it might result in the concatenation of two local files? '(mixed-text-file "foobar" (local-file "foo") (local-file "bar"))'